My SDL package does not load up
Thread poster: Paula Tome

Paula Tome  Identity Verified
United Kingdom
Local time: 21:20
English to Portuguese
Aug 30, 2011

Hello,
I do not have a support contract and do not wish to buy one but I seem to be unable to load my SDL package. I never had this problem before. I get an error message relating to S42CMP.DELL and REGSV32.exe. I did try the Repair thing in Windows, it did not work. I do not know who to speak to, I get a lot of automated responses but no help.
Can anyone advise, please? I am thinking it might be an idea to remove the entire thing and start again. I have SDLTradosStudio2009_SP3_2229 and should also be able to open SDLX files. Many thanks!

[Edited at 2011-08-30 15:12 GMT]


 

Teymur Suleymanov  Identity Verified
Local time: 16:20
Russian to English
+ ...
Two system files missing Aug 30, 2011

It is a tricky task to determine which of your previously installed programs were using the Regsvr32.exe and S42CMP.DLL files. These are usually files in your C:/windows/system folder and if they get infected, the antivirus will just delete them, causing dependent programs to complain that their process "went orphaned".

The following set of instructions was provided by Philippe Riondel, cert. translator (http://tech.groups.yahoo.com/group/TW_users/message/53057)
--------------------------------------------------------------------------------------
SDL's Knowledge base article #2834 explain the problem and suggest a heavy
solution :

« # Error S42TMC.DLL failed to load or S42CMP.DLL failed to load:
This error can only be solved by uninstalling SDLX and doing a
reinstallation. After restarting the PC, the error warnings should no longer
appear. »

In fact, there is easier a solution.

Just locate the S42CMP.DLL in SDLx Folder (usually: C:\Program Files\SDL
International\SDLX), and in the contextual menu, click on 'Open with...'.

Then choose the regsvr32.exe file in the C:\Windows\System32 folder.

The dll should register successfully thanks to that exe.

You will then experiment the same problem with a 'S42TMC.DLL failed to load'
message. Do the same for that DLL, which is located in the same folder than the
first one.

In my case, the whole worked successfully, and I was able to open my ITD and
SDLx.

HTH
---------------------------------------------------------------------------
Thanks Philippe...

HTH
Teymur


 

Paula Tome  Identity Verified
United Kingdom
Local time: 21:20
English to Portuguese
TOPIC STARTER
Two system files missing/SDLTradosStudio2009_SP3_2229 Aug 30, 2011

Many thanks Teymur, I will try both solutions then and see what happens, very much appreciated!
Best regards
Paula


 

Paula Tome  Identity Verified
United Kingdom
Local time: 21:20
English to Portuguese
TOPIC STARTER
Still unable to open files with SDL Trados 2007 Sep 5, 2011

Hi, I have reinstalled the whole thing, I seem to be able to open files in Studio and Trados but still cannot open itds and respective memories. I get the same error message as before (relating to the dll) and sometimes various error messages relating to the multiterm widget as well as "Object reference not set." Does anyone have any suggestions? Any help will be much appreciated. Thanks. Paula

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

My SDL package does not load up

Advanced search






SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search