? falling flat to _ when changing keyboard from EN to ES
Thread poster: Edward Potter

Edward Potter  Identity Verified
Spain
Local time: 02:04
Member (2003)
Spanish to English
+ ...
Apr 29, 2014

Does anyone have this same annoying problem when switching keyboards from EN to ES?

You forget you have changed your keyboard from EN to ES, then you want to type a question mark (?) at the end of your sentence, then quickly hit enter. But, oops, you had changed to an ES layout keyboard and you get a frickin' underscore (_).

Doesn't this just p!ss you 0ff_


[Edited at 2014-04-29 15:52 GMT]


Direct link Reply with quote
 

Miguel Carmona  Identity Verified
United States
Local time: 17:04
English to Spanish
Underscore instead of question mark Apr 29, 2014

Edward Potter wrote:

Does anyone have this same annoying problem when switching keyboards from EN to ES?

You forget you have changed your keyboard from EN to ES, then you want to type a question mark (?) at the ehdn of your sentence, then quickly hit enter. But, oops, you had changed to an ES layout keyboard and you get a frickin' underscore (_).

Doesn't this just p!ss you 0ff_


Yes, everytime I forget what keyboard mapping I am using I do not get what I expected when hitting some keys, and, as you say, it is kind of annoying. Fortunately, it is an easy to solve situation.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 02:04
Member (2010)
Spanish to English
Bug in my case Apr 29, 2014

My new(ish) Lenovo ThinkPad came with Win 8.1 in Spanish and I changed the OS to English. So far so good. But it forgets which keyboard I'm using several times a day, and I get the problem you mention with underscores, question marks, brackets, etc., etc.

I'm sure I'm not pressing Winkey+spacebar by accident. It just happens on its own.

Very frustrating.


Direct link Reply with quote
 

Edward Potter  Identity Verified
Spain
Local time: 02:04
Member (2003)
Spanish to English
+ ...
TOPIC STARTER
Winkey-Space or Alt-Shift for changing languages Apr 29, 2014



I'm sure I'm not pressing Winkey+spacebar by accident. It just happens on its own.



I use Alt-Shift. Does the same thing.


Direct link Reply with quote
 

Francesca Bernardis  Identity Verified
Portugal
Local time: 01:04
Member (2010)
Portuguese to Italian
+ ...
Reply to Emma Apr 29, 2014

Emma Goldsmith wrote:

I'm sure I'm not pressing Winkey+spacebar by accident. It just happens on its own.

Very frustrating.


I thought the same when I upgraded to a new computer with Windows 8. It took me ages to realize that, while the official shortcut was Window key+spacebar, Ctrl+Shift also did the same. (It didn't in my old XP, and I use it all the time in combination with the arrow keys to select text, so it caused me quite a lot of problems!)

In the end I found a way to remove the offending shortcut, but to be honest I'm not sure where I found the solution or where I went to change settings, I think it was the solution explained here:
http://www.tech-recipes.com/rx/43501/windows-8-switch-input-method-using-a-keyboard-shortcut/
(but I'm not sure).

(@ Edward: sorry to hijack your thread, but I wish someone had told me this when I was in Emma's situation. BTW, I mostly use one keyboard layout only, but whenever I change I do forget to set it back, and inevitably I find myself in the situation you described... though in my case the first error I spot is ° instead of à)


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 02:04
Member (2010)
Spanish to English
Thank you! Apr 29, 2014

Francesca Bernardis wrote:

In the end I found a way to remove the offending shortcut, but to be honest I'm not sure where I found the solution or where I went to change settings, I think it was the solution explained here:
http://www.tech-recipes.com/rx/43501/windows-8-switch-input-method-using-a-keyboard-shortcut/


Francesca, this solution is fantastic!

I had no idea that Windows 8 assigns Ctrl+Shift to toggling keyboard languages. In my case Winkey+space does that too. The explanation in the link worked perfectly and I've removed the offending shortcut.
Honestly, Ctrl+Shift shortcut is the craziest shortcut that Microsoft could possibly choose. It clashes with selecting whole words in Word, for a start.

Anyway, I will be eternally grateful to you, Francesca, for giving me the solution, and many thanks to Edward for starting this thread, which can now get back on topic!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

? falling flat to _ when changing keyboard from EN to ES

Advanced search






TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search