how can i keep a | character in my .stl ?
Thread poster: croxanas
Nov 8, 2012

DICLAIMER: i'm a complete n00b when it comes to subtitling. i'm doing a job where the subtitles are in bangla [bangladeshi] and the problem is that their full stop [period] is a |.

so obviously i'm having the problem that where ever there's the end of a sentence i get a new line and my | disappears so i have an hour's worth of subtitles with crappy punctuation.

is there anyway to keep the | character in the subtitles or am i fighting a losing battle?

i've created my .stl from an .xml through FCxmlSubtitleXtractor, edited it as a text file and everything else is working just as i need it to in dvd studio pro, i just need to be able to keep the |s !!

does any one else out there have experience with bangla subtitling?

any help is most appreciated!

thanks,
Chantale


 

kmtext
United Kingdom
Local time: 21:44
English
+ ...
I think it's an encoding problem Nov 14, 2012

The .stl format should support | - at least it does in the files I export, so it's probably being lost when you change formats. Try using a different program for the conversion.

 

Parrot  Identity Verified
Spain
Local time: 22:44
Member
Spanish to English
+ ...
As I understand it Nov 14, 2012

Chantale's problem is the DVD Studio Pro line separator being an actual orthographic character. I haven't used studio pro myself, but on PC programs, it's possible to assign another character as line separator. I'm wondering whether another character might substitute for full sentence stop, but I have no knowledge of Bangladeshi.

 

Monica Paolillo
Italy
Local time: 22:44
Member (2005)
English to Italian
+ ...
I don't use DVD Studio Pro Nov 14, 2012

What are you trying to do with it? Maybe there's some other software you can use instead? Also you may want to try converting the stl into some other Studio Pro friendly format... I mean are you sure you have used the stl extension that's specific to DVD Studio Pro, not all stls are fine e.g. EBU stl might not work, but as I said I have never used the software, just mumbling about.



[Edited at 2012-11-14 17:46 GMT]


 

croxanas
TOPIC STARTER
i think the problem was a non-unicode bangla font Nov 18, 2012

hi all,

thanks for your replies...i'm pretty sure the problem was the font i was given to use. the translator was initially told it didn't matter what font she used, and the one she did use [sutonnyMJ] worked fine in FCP, but not fine when we went to create the .stl because it was a non-unicode font [which i didn't realise].

tests done re-typing the subtitles with avro [a unicode bangla font] seems promising as the darrie [bangla full stop] uses the english [.] to create the [|] character, leaving the [|] to fulfill its function as a line break

everything else was fine, the .stl format is the correct one and i'm keeping my fingers crossed that the problem has been resolved satisfactorily.

thanks again,
Chantale


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

how can i keep a | character in my .stl ?

Advanced search







SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search