Corrupt characters when converting Trados TM to Wordfast
Thread poster: TTilch

TTilch  Identity Verified
Local time: 13:41
English to German
+ ...
Aug 21, 2008

Hello,

I've been trying to convert a Trados TM to Wordfast, but whatever export format I use, some special characters get corrupted (i.e. the German special characters like ä, ö, ü, ß).

Is there any special trick to keep them intact? Any ideas?

Thank you for your help.

Best regards,

Tanja


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 14:41
Member (2006)
English to Russian
+ ...
For starters, describe in details what you did Aug 22, 2008

I know no straightforward way to convert Trados TMs into WF TMs, so what's your procedure?

Direct link Reply with quote
 

TTilch  Identity Verified
Local time: 13:41
English to German
+ ...
TOPIC STARTER
Details on the conversion Aug 22, 2008

Steps I took:
Open TM in Trados 2007 in exclusive mode.
Export the TM in TMX format (Trados offers different formats, I tried all three).
Open the exported file in Wordfast. Wordfast starts to convert it and saves it in Wordfast format.
Now it can be used with Wordfast, but some of the special characters appear corrupted. I am looking for a solution to this problem.
Any suggestions? Thank you for your input.

Best regards,

Tanja


Direct link Reply with quote
 

David Daduč
Czech Republic
Local time: 13:41
English to Czech
Which characters? Aug 22, 2008

TTilch wrote:

Now it can be used with Wordfast, but some of the special characters appear corrupted.


Tanja, can you give us a few examples of the corrupted characters (what they should be and what they are in the Wordfast TM)?

Anyway, unless the TMX file is too huge (dozens of megabytes or more), open it from NotePad (or any other good text editor). Check the characters. Are they OK? If so, go to File > Save as... menu. What encoding can you see pre-selected in the window? If it's "Unicode UTF-8", change it to "Unicode" only and save the file under a new name. Make sure its file extension remains .tmx. Select it in Wordfast - is it OK now?


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 14:41
Member (2006)
English to Russian
+ ...
I don't have Trados 2007, Aug 22, 2008

so, I can't advise in more details.
a) check out, if there's an option to set the encoding for the exported file. Select UTF-16.
b) open the resulting TMX file(s) in any good text editor (I'd recommend jEdit or UniRed) and check, if it's UTF-16. If not, re-save to UTF-16 or UTF-8.
c) try to convert the TMX with Wf2Tmx utility available in the Files section of the Wordfast mailing list at Yahoo! (http://tech.groups.yahoo.com/group/wordfast/files).

Good luck!


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 14:41
Member (2006)
English to Russian
+ ...
Gimme a break! Aug 22, 2008

David Daduc wrote:

NotePad (or any other good text editor).




NotePad and good text editors are two different planets!


Direct link Reply with quote
 

TTilch  Identity Verified
Local time: 13:41
English to German
+ ...
TOPIC STARTER
No results Aug 22, 2008

I thank you for your pieces of advice.
I tried to rename the files as you said (I tried both with UTF-8, 16 and 32 format), maintaining the extension .tmx, but without results.
Opening both the TM files (1.1tmx, 1.4tmx and 1.4b.tmx) and the renamed files, I can see the characters, but not when I try to translate a text with WordFast: the German special characters like ä, ö, ü, ß and Italian characters like ù, à, ò get corrupted.
Any other ideas?
Thank you.


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 14:41
Member (2006)
English to Russian
+ ...
Could you provide a sample of your TMX? Aug 22, 2008

Just a couple of TUs containing problematic characters would suffice.

So far the only idea: check the language codes. Open a TMX file and check out the attributes srclang in the file heading and lang in tags. Note, that Wordfast uses its own, specific language codes, such as RU-01 instead of normal RU-RU or ru_RU. So, change them accordingly.

BTW, what's your Wordfast version? I think, the 4.x had some problems related to Unicode.


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 14:41
Member (2006)
English to Russian
+ ...
And, BTW, what does “corrupt” mean? Aug 22, 2008

What do you see instead of ü, ä etc? Do any other characters present any problem? Maybe, you'd simply open the resulting Wordfast memory and search and replace just the problematic characters, et voila?

[Edited at 2008-08-22 14:52]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Corrupt characters when converting Trados TM to Wordfast

Advanced search


Translation news related to Wordfast





TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search