Pages in topic:   [1 2] >
Upper/Lower case problem with Wordfast
Thread poster: Tineke Van Beukering

Tineke Van Beukering  Identity Verified
Australia
Local time: 16:43
Dutch to English
+ ...
Jan 28, 2009

I am using Wordfast 5.52 on a Word document (MS Office 2007). I've got a table that is full of repetitive abbreviations in capitals, that I need to translate in combined upper/lower case:

" N/E " in the source text, meaning 'none established' in this context, needs to be translated into Dutch in my case as 'Niet vastgesteld'.

The problem I have is that the TM recognises the capitals in "N/E" and automativally gives me a suggested translation in all capitals "NIET VASTGESTELD" (NONE ESTABLISHED).

Is there a way that I can change the settings for the TM so it will give me the suggested translation exactly the same as I've entered previously: with intial capital followed by lower case? Or is there another way to solve this?


Direct link Reply with quote
 

Marie-Hélène Hayles  Identity Verified
Local time: 07:43
Italian to English
+ ...
Capitals Jan 28, 2009

WF is not very good at distinguishing between capitals and lower case, to my knowledge, so unless someone comes up with a better solution I suggest you just let it go through the whole thing and then do a blanket "find and replace" once you've finished your translation.

Direct link Reply with quote
 

Adrien Esparron
Local time: 07:43
Member (2007)
German to French
+ ...
Edit the TM ? Jan 28, 2009

Tineke Van Beukering wrote:

The problem I have is that the TM recognises the capitals in "N/E" and automativally gives me a suggested translation in all capitals "NIET VASTGESTELD" (NONE ESTABLISHED).



I think you just have to open the TM with some text editor or Excel and to correct it as whished ?

Hoping to be helpful,

Kind regards,

Olivier


Direct link Reply with quote
 

Tineke Van Beukering  Identity Verified
Australia
Local time: 16:43
Dutch to English
+ ...
TOPIC STARTER
Thanks! Jan 28, 2009

That's indeed a solution & so simple! I had completely overlooked it. I was so frustrated and concentrating too much on finding a solution within Wordfast. Thanks!

If anybody has a suggestion of how to do it within Wordfast I'd still like to hear of course!


Direct link Reply with quote
 

Tineke Van Beukering  Identity Verified
Australia
Local time: 16:43
Dutch to English
+ ...
TOPIC STARTER
Worth a try, but doesn't seem to do the trick Jan 28, 2009

Olivier MANESSE wrote:



I think you just have to open the TM with some text editor or Excel and to correct it as whished ?

Hoping to be helpful,

Kind regards,

Olivier [/quote]

Thanks Oliver. I've just tried your suggestion: edited the TM, replaced all capitals but upon opening a new segment I still get a proposed translation in capitals unfortunately....

By the way, my previous comment was a reply to Marie-Hélène's suggestion - I didn't include a quote.


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 07:43
Member (2006)
English to Afrikaans
+ ...
Nothing you can do Jan 28, 2009

Tineke Van Beukering wrote:
" N/E " in the source text, meaning 'none established' in this context, needs to be translated into Dutch in my case as 'Niet vastgesteld'.

The problem I have is that the TM recognises the capitals in "N/E" and automativally gives me a suggested translation in all capitals "NIET VASTGESTELD" (NONE ESTABLISHED).


I know of no solution to your problem. I have had similar problems in the past.


Direct link Reply with quote
 

Roman Bulkiewicz  Identity Verified
Ukraine
Local time: 08:43
Member (2004)
English to Ukrainian
+ ...
Edit the source Jan 28, 2009

An alternative to Marie-Hélène's suggestion:
Globally replace "N/E" with "N/e" in the source text.


Direct link Reply with quote
 

Marina Aleyeva  Identity Verified
Ukraine
Local time: 08:43
English to Russian
+ ...
You probably need to update you TM Jan 28, 2009


Thanks Oliver. I've just tried your suggestion: edited the TM, replaced all capitals but upon opening a new segment I still get a proposed translation in capitals unfortunately....


That is strange. Unless a 'capitalised' style was applied to the acronyms in your table, WF itself will not force capitals but rather insert your target term the way it appears in your working TM. Try opening a blank Word document, type 'N/E', translate it with the same TM and clean up. WF should update the memory and remember the case.

Close you working document while you are experimenting.

[Edited at 2009-01-28 15:45 GMT]


Direct link Reply with quote
 

Ulf Samuelsson  Identity Verified
Mexico
Local time: 00:43
Member (2007)
English to Swedish
+ ...
DifferentCase=99 Jan 28, 2009

This problem should be handled by putting the command DifferentCase=99 in PB.
That would force Wordfast to treat case differences as a 99% match so that it doesn't offer "NIET VASTGESTELD" from the memory instead of "Niet vastgesteld".

Without this command, Wordfast doesn't see any difference between "NIET VASTGESTELD" and "Niet vastgesteld".

Ulf


Direct link Reply with quote
 

Tineke Van Beukering  Identity Verified
Australia
Local time: 16:43
Dutch to English
+ ...
TOPIC STARTER
Tried it, but doesn't seem to work that way Jan 28, 2009

Marina Aleyeva wrote:


Thanks Oliver. I've just tried your suggestion: edited the TM, replaced all capitals but upon opening a new segment I still get a proposed translation in capitals unfortunately....


That is strange. Unless a 'capitalised' style was applied to the acronyms in your table, WF itself will not force capitals but rather insert your target term the way it appears in your working TM. Try opening a blank Word document, type 'N/E', translate it with the same TM and clean up. WF should update the memory and remember the case.

Close you working document while you are experimenting.

[Edited at 2009-01-28 15:45 GMT]


Thanks for the suggestion Marina. I tried it, but it doesn't seem to work. Wordfast does enforce the capitalsl. The translation memory contains an initial capital followed by lower case, but it keeps coming up with all capitals any time I open a new segment.

I suppose this comes down to the same solution as Olivier's suggestion to edit the TM - an has similar results.


Direct link Reply with quote
 

Tineke Van Beukering  Identity Verified
Australia
Local time: 16:43
Dutch to English
+ ...
TOPIC STARTER
Thanks Roman - this option works! Jan 28, 2009

Roman Bulkiewicz wrote:

An alternative to Marie-Hélène's suggestion:
Globally replace "N/E" with "N/e" in the source text.


Thanks, I tried this and indeed now the TM comes up with the suggested translation with initial capital followed by lower case. Similar to Marie-Hélène's suggestion of search & replace afterwards.

Only problem I still have with both of these solutions that they are not 'clean' solutions. I've been asked to supply the TM to the customer, and if they run the TM over a similar file they'll end up with the same problem again. But then again, that isn't my fault.

Thanks to all who've come up with suggestions so far. I'd still be interested to hear if someone knows of a way of solving the problem within wordfast.


Direct link Reply with quote
 

Nikki Graham  Identity Verified
United Kingdom
Local time: 06:43
Member (2003)
Spanish to English
Sorry, no solution, but similar problem Jan 29, 2009

I have just recently finished a translation in Wordfast where many segments were: "CE certified" and Wordfast's 100% match was "Ce certified". Then, when I changed it to "CE certified" the programme changed it back to "Ce certified" when I closed the segment. Any ideas on how to solve this? Isn't there anything in Pandora's box to solve these upper/lower case problems?

Direct link Reply with quote
 

Tineke Van Beukering  Identity Verified
Australia
Local time: 16:43
Dutch to English
+ ...
TOPIC STARTER
Solve it by editing the source or translation Jan 29, 2009

Nikki Graham wrote:

I have just recently finished a translation in Wordfast where many segments were: "CE certified" and Wordfast's 100% match was "Ce certified". Then, when I changed it to "CE certified" the programme changed it back to "Ce certified" when I closed the segment. Any ideas on how to solve this? Isn't there anything in Pandora's box to solve these upper/lower case problems?


Hi Nikki,

So far I haven't come across such a Pandora's box, I was hoping to find one too. But you can solve the problem with an editor: either edit the source text and change the upper/lower case there, or do a case sensitive search/replace in the translated text when you're finished. Thanks Roman and Marie-Hélène for your helpful suggestions here!


Direct link Reply with quote
 
xxxNMR
France
Local time: 07:43
French to Dutch
+ ...
Solve it with a Word shortcut Jan 29, 2009

Highlight the text and then use Shift + F3. This is a toggle with three positions: capitalized, first letter capitalized, not capitalized. Very useful for long titles.

There is no need to update the TM, it will come back anyway.

Good luck.


Direct link Reply with quote
 

Tineke Van Beukering  Identity Verified
Australia
Local time: 16:43
Dutch to English
+ ...
TOPIC STARTER
Re: DifferentCase=99 Jan 29, 2009

Ulf Samuelsson wrote:

This problem should be handled by putting the command DifferentCase=99 in PB.
That would force Wordfast to treat case differences as a 99% match so that it doesn't offer "NIET VASTGESTELD" from the memory instead of "Niet vastgesteld".

Without this command, Wordfast doesn't see any difference between "NIET VASTGESTELD" and "Niet vastgesteld".

Ulf



Thanks Ulf. Are you sure this works? To make this change, am I correct that I have to click Wordfast>Setup>PB>Enable and then type DifferentCase=99 ? I did all this, but I am still getting a suggested translation from the TM in all capitals .... Did I do something wrong? This is so frustrating!


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Upper/Lower case problem with Wordfast

Advanced search


Translation news related to Wordfast





PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search