Placeables in Wordfast Pro
Thread poster: VIVA VOCE Ltd.

VIVA VOCE Ltd.  Identity Verified
Croatia
Local time: 15:31
English to Croatian
+ ...
Mar 30, 2009

Hello,

I'm working on a word file with a lot of placeables, but the program recognizes only link codes (ut) as placeables. Numbers are not recognized. How can I change placeable preferences?

Also, can I reorganize TM in Wordfast PRO?
Finally, are TMs interchangeable between PRO and Classic, as I haven't been able to store segments translated in PRO in Classic.

Thanks,

Ljerka

[Subject edited by staff or moderator 2009-03-30 09:50 GMT]


Direct link Reply with quote
 

Kristyna Marrero  Identity Verified
United States
Local time: 09:31
Placeables in Wordfast Pro Apr 1, 2009

Hi Ljerka,

In regards to your placeables question, numbers are never treated as placeables in Wordfast. However, if you would like your numbers to be ignored while creating your translation, you can check Numbers Extraction. This option is found in Edit-Preferences-Filters. This will disregard any number only segments when creating the TXML. In future releases we will be offering a new option to treat numbers as placeables instead of extraction in the current model.

There is currently no "reorganize" feature in Wordfast Pro. However, Wordfast Classic and Wordfast Pro TMs are identical and completely interchangeable. You can reorganize your TMs in Wordfast Classic and open them in Wordfast Pro.

If you don't see the segments in WF Classic that you translated using WF Pro, are you sure you are updating your TM before opening it in WF Classic?

Sincerely,

Kristyna


Direct link Reply with quote
 

Comunican
United Kingdom
Local time: 14:31
Catalan to English
+ ...
number snot being ignored even though Numbers Extraction" box checked Aug 5, 2010

Kristyna Marrero wrote:

if you would like your numbers to be ignored while creating your translation, you can check Numbers Extraction. This option is found in Edit-Preferences-Filters. T


I have this problem too except even though I have checked the "Numbers Extraction" box, numbers are still not being ignored - eg

when the source is "0,0471 €", Wf Pro offers a match "308.18€"
and when the source is "288,73", Wf Pro offers a match "1.5"

This is quite dangerous because it's easy to miss numbers...


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 15:31
English to Arabic
"Fuzzy Match Threshold" + "Use Replaceables for higher TM matches" Aug 5, 2010

Comunican wrote:

I have this problem too except even though I have checked the "Numbers Extraction" box, numbers are still not being ignored - eg

when the source is "0,0471 €", Wf Pro offers a match "308.18€"
and when the source is "288,73", Wf Pro offers a match "1.5"

This is quite dangerous because it's easy to miss numbers...



Dear Comunican,

This is a completely different issue. To avoid what you described, please raise your Fuzzy Match Threshold to at least 50 or so (Edit > Preferences > Translation Memory). You should notice the difference.

A relevant tip (that can help with matches with higher percentages) is when the only difference between two sentences is in numbers; in this case, you can check the option "Use Replaceables for higher TM matches" (Edit > Preferences > Translation Memory). This will automatically replace the numbers in such fuzzy matches instead of offering them with incorrect numbers from old translated sentences stored in the TM.

I hope adjusting the two settings will help.



---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net



[Edited at 2010-08-05 21:00 GMT]


Direct link Reply with quote
 

Comunican
United Kingdom
Local time: 14:31
Catalan to English
+ ...
Fuzzy Match Threshold already 75% Aug 6, 2010

Yasmin Moslem wrote:

To avoid what you described, please raise your Fuzzy Match Threshold to at least 50 or so (Edit > Preferences > Translation Memory). You should notice the difference.

A relevant tip (that can help with matches with higher percentages) is when the only difference between two sentences is in numbers; in this case, you can check the option "Use Replaceables for higher TM matches" (Edit > Preferences > Translation Memory). This will automatically replace the numbers in such fuzzy matches instead of offering them with incorrect numbers from old translated sentences stored in the TM.



[Edited at 2010-08-05 21:00 GMT]


Hi Yasmin
Thanks for your suggestions.

I already have a "Fuzzy Match Threshold" of 75%

And under "Edit > Preferences > Translation Memory", no option is showing for "Use Replaceables for higher TM matches"
The only options are:
"Copy source on no match"
"Fuzzy Match Threshold in %"
"When editing an existing TU,"
"Add to TM by overwriting the existing TU"
"Add to TM by overwriting the existing TU if attributes are identical"
"Add to TM do not overwrite existing TU"
"Do not add to TM"

Thanks


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 15:31
English to Arabic
Upgrade Aug 6, 2010

Comunican wrote:

I already have a "Fuzzy Match Threshold" of 75%

And under "Edit > Preferences > Translation Memory", no option is showing for "Use Replaceables for higher TM matches"



Dear Comunican,

This means that your version is not the latest one. Please download and install the latest version of Wordfast Professional available at:
http://www.wordfast.com/store_download.html


I hope this helps.



---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 

Comunican
United Kingdom
Local time: 14:31
Catalan to English
+ ...
I downloaded the latest version, but now it won't run Aug 6, 2010

Yasmin Moslem wrote:

Please download and install the latest version of Wordfast Professional available at:
http://www.wordfast.com/store_download.html


I hope this helps.

---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net



Hi Yasmin
I downloaded the latest version as you suggested and now I can't run Wordfast Pro at all. It gives me an error message:

"An error has occurred. See the log file (followed by address of the log file)"

When I look at the log it means nothing to me...

Any suggestion as to what I do, please?


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 15:31
English to Arabic
Reinstall Aug 6, 2010

[quote]Comunican wrote:

Yasmin Moslem wrote:

I downloaded the latest version as you suggested and now I can't run Wordfast Pro at all. It gives me an error message:

"An error has occurred. See the log file (followed by address of the log file)"

When I look at the log it means nothing to me...

Any suggestion as to what I do, please?


Dear Comunican,

What was the older version, and what is your operating system?

You completely uninstall Wordfast Pro. When you are asked to keep configuration files, answer with "No". (Make sure you first back up your glossaries, if any.) Then, try installing again, hopefully it could resolve that.

As you run Windows Vista (or Windows 7), it is better usually to turn off the UAC during installing, licensing and updating Wordfast Pro. You can turn it on later:
(Control Panel -> User Accounts -> Turn User Account Control on or off -> (un-check) Use User Account Control) -> Re-start your computer.


I hope this helps. Please let me know.



---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 

Comunican
United Kingdom
Local time: 14:31
Catalan to English
+ ...
I managed to install new version but numbers problem still occurring Aug 6, 2010

Yasmin Moslem wrote:

What was the older version, and what is your operating system?

You completely uninstall Wordfast Pro. When you are asked to keep configuration files, answer with "No". (Make sure you first back up your glossaries, if any.) Then, try installing again, hopefully it could resolve that.

As you run Windows Vista (or Windows 7), it is better usually to turn off the UAC during installing, licensing and updating Wordfast Pro. You can turn it on later:
(Control Panel -> User Accounts -> Turn User Account Control on or off -> (un-check) Use User Account Control) -> Re-start your computer.



Hi Yasmin
Thanks for your reply.
I'm afraid I can't remember for sure the previous version (since it is no gone). My operating system is Winbdows7 32-bit.
I tried turning off UAC and reinstalling Wf Pro, but I got the same error message.
Then I uninstalled Wf Pro using Revo and tried re-installing it again. This time it installed ok, so I now have version 2.4.0.1.
Hurrah!
Unfortunately after spending about an hour with all that, I still have the same problem.
eg 654,78€ is coming out as 308.18 €.
Boo!
I have numbers extraction box checked and I have Fuzzy Match set to 75%...
:S


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 15:31
English to Arabic
Check the option "Use Replaceables for higher TM matches" Aug 6, 2010

Comunican wrote:

Unfortunately after spending about an hour with all that, I still have the same problem.
eg 654,78€ is coming out as 308.18 €.
Boo!
I have numbers extraction box checked and I have Fuzzy Match set to 75%...
:S



Dear Comunican,

Please check the option "Use Replaceables for higher TM matches" (Edit > Preferences > Translation Memory).

You should get what you want.

I hope this helps. Please let me know.



---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 
xxxNMR
France
Local time: 15:31
French to Dutch
+ ...
Thanks Yasmin Aug 8, 2010

Yasmin Moslem wrote:

Please check the option "Use Replaceables for higher TM matches" (Edit > Preferences > Translation Memory).


It works fine.

I didn't know there were other interesting things at the bottom of this list. (such as: CopySourceWhenNoMatch).


Direct link Reply with quote
 

Comunican
United Kingdom
Local time: 14:31
Catalan to English
+ ...
"Use Replaceables for higher TM matches" has partially worked Aug 9, 2010

Yasmin Moslem wrote:

check the option "Use Replaceables for higher TM matches" (Edit > Preferences > Translation Memory).



Thanks Yasmin, that has partially worked, but not completely:

0 in source was ignored, a blank was presented
680 in source was ignored, a blank was presented

I have the following settings:
Use Replaceables for higher TM matches - checked
Fuzzzy Match Threshold - 75%

Is there no way of having Pro work the same as Classic in that any segment consisting solely of numbers is just ignored (though it would be great if full stops and comma scould be reversed to reflect difference in the number punctuation used in French/Spanish and that used in English...)

Many thanks


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 15:31
English to Arabic
Uncheck "Number Extraction" Aug 9, 2010

Comunican wrote:

0 in source was ignored, a blank was presented
680 in source was ignored, a blank was presented

I have the following settings:
Use Replaceables for higher TM matches - checked
Fuzzzy Match Threshold - 75%

Is there no way of having Pro work the same as Classic in that any segment consisting solely of numbers is just ignored (though it would be great if full stops and comma scould be reversed to reflect difference in the number punctuation used in French/Spanish and that used in English...)


Dear Comunican,

Sole numbers such as 0 and 680 should be ignored unless you check "Number Extraction". So, by default, 0 and 680 should not appear in the TXML file.

So please go to Edit > Preferences > Filters and make sure the option "Number Extraction" is unchecked.


I hope this helps.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 

Pavel Zalutski  Identity Verified
United States
Local time: 09:31
English to Russian
+ ...
Full stop to comma and vice versa Feb 18, 2011

But how about this part of Comunican's last question: it would be great if full stops and comma scould be reversed to reflect difference in the number punctuation used in French/Spanish and that used in English...

THIS IS SUPER SUPER NEEDED! We cannot live without this!

[Edited at 2011-02-18 00:10 GMT]

[Edited at 2011-02-18 00:10 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Placeables in Wordfast Pro

Advanced search


Translation news related to Wordfast





Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search