International Translation Day 2018

Join ProZ.com/TV for a FREE event September 25-26th celebrating International Translation Day! 50+ hours of content, Chat, Live Q&A & more. Join 1,000's of linguists from around the globe as ProZ.com/TV celebrates International Translation Day.

Click for Full Participation

I figured out the copy source problem with Wordfast pro on Macs!
Thread poster: Evan Wilson

Evan Wilson  Identity Verified
United States
Local time: 03:53
Member (2008)
German to English
Sep 28, 2009

Sorry if this has already been posted somewhere, but there are so many forums on Proz that its daunting to search through everything to check.

I was so excited that there's finally a market standard CAT tool platform for Mac! Thanks Wordfast. But like I've heard from so many other people, I'm frustrated with many of the glitches and seemingly missing features. I was quite bothered by the "Insert" key command for the copy source function, since Macs, or at least laptops, dont have an Insert key. I had searched the Internet up and down for a solution, found none, and then just stumbled upon the solution myself, so I thought I'd post. Here it goes:

Go to Edit -> Preferences ->"Keys" -> Scroll down to "Copy Source" and enter your own command function in "Binding:" and click Apply.

That should do it.

Now if I could only figure out all of the formatting/segmentation problems when a PDF file (scanned or not) has been converted into Word. I spend more time reformatting everything than it seems worth it.....

Cheers!


 

Ruth Simpson  Identity Verified
France
Local time: 12:53
Member (2008)
French to English
Thank you!! Dec 11, 2009

I have been wasting so much time going to the menu and using the mouse, thank you for this solution, it works perfectly!

 

bandarra  Identity Verified
Local time: 07:53
English to Portuguese
+ ...
Thanks! Mar 16, 2011

That really helped. Too bad wordfast doesn't seem to have the presence of mind of not overwriting the target in the "copy all source", like trados studio 2009 does. I'm still not going back to windows, though.icon_smile.gif

 

Yasmin Moslem  Identity Verified
Egypt
Local time: 12:53
English to Arabic
Copy Source on No Match! Mar 16, 2011

bandarra wrote:

That really helped. Too bad wordfast doesn't seem to have the presence of mind of not overwriting the target in the "copy all source", like trados studio 2009 does. I'm still not going back to windows, though.icon_smile.gif


Dear Bandarra,

I hope I got your comment correctly; please let me know if I did not.

You can go to "Edit" menu > "Preferences" > "Translation Memory" and select the option "Copy Source on No Match". Whenever you go to a non-translated segment (Alt+Down), the source will be copied for you without the need to use the shortcut.

I hope this helps.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


 

Jason Hall
Ecuador
Local time: 05:53
English to Spanish
+ ...
I don't think that's it... Jul 27, 2011

Thanks for your comments Yasmin, it’s nice to have WF Support participating in these forums!

The function that you mentioned is useful but I do not think it is what Bandarra was referring to.

When one goes to “Edit” > “Preferences” > “Keys”, under the command list, the command “Copy Source” appears twice, though in reality one is “Copy Source” and the other is “Copy all Source”, which is indicated in the description windows but is easy to miss.

If one were to set the shortcut key to “Copy Source” (actually “Copy all Source”) rather than “Copy Source” (actually “Copy Source”), one would accidently overwrite one’s previously translated segments, rather than just the empty segments.

Just out of curiosity, why does Wordfast Pro for Mac include a shortcut key which des not exist on the Mac keyboard (insert)?

Am I missing something obvious here?

Thanks!


 

PCovs
Denmark
Local time: 12:53
Member (2003)
English to Danish
+ ...
Wordfast for Mac shortcut using 'Insert'? Oct 25, 2011

Jason Hall wrote:


Just out of curiosity, why does Wordfast Pro for Mac include a shortcut key which des not exist on the Mac keyboard (insert)?

Am I missing something obvious here?

Thanks!



I am just wondering the exact same thing. Why is this shortcut listed for the Mac version of Wordfast?

Incidently, I cannot seem to make it work when I try to create my own shortcut for Copy Source as described. I change the settings and continue translating, but the shortcut does not work. Should I close and reopen the programme before the change takes effect, or what?


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

I figured out the copy source problem with Wordfast pro on Macs!

Advanced search


Translation news related to Wordfast





SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »
SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search