Adding comma and semicolon to delimiters does not work in Wordfast Classic
Thread poster: Chris Lovelace

Chris Lovelace  Identity Verified
Argentina
Local time: 20:52
Russian to English
+ ...
Nov 25, 2009

In the Wordfast Classic setup dialogue:

I have changed the "End of segment punctuation" in Wordfast to read as follows:

, : . ! ? ^t ;

When I closed the dialogue box, it asked if I wanted to save to wordfast.ini, which I did.

After rebooting my computer and resuming the translation, segmentation still goes to the next period, and ignores intervening commas and semicolons.

How can I resolve this, or at least get Wordfast to generate shorter segments?

PS - I posted this question in an old forum discussion, but decided to re-post here when I got no responses. Not sure if the other thread is dead, so I apologize for the double post if this causes any problems.


Direct link Reply with quote
 

Anna Haxen  Identity Verified
Denmark
Local time: 01:52
Member (2005)
English to Danish
+ ...
A quick fix Nov 25, 2009

I recently had a text where an entire list appeared in one segment. I solved it by typing periods in the source text after each item on the list and removing them again afterwards. Definitely not the authorized solution, but I was in a hurry, and it worked.

Direct link Reply with quote
 

Chris Lovelace  Identity Verified
Argentina
Local time: 20:52
Russian to English
+ ...
TOPIC STARTER
"Shrink/Expand Segment" does not work Nov 25, 2009

The Shrink and Expand Segment buttons and shortcuts do not work for me in Wordfast Classic. I am running Office 2002 on an XP system.

...Perhaps this has something to do with the problem I originally mentioned.


Direct link Reply with quote
 

Chris Lovelace  Identity Verified
Argentina
Local time: 20:52
Russian to English
+ ...
TOPIC STARTER
Quick fix sounds good, but my document is too big for that Nov 25, 2009

Anna Haxen wrote:

I recently had a text where an entire list appeared in one segment. I solved it by typing periods in the source text after each item on the list and removing them again afterwards. Definitely not the authorized solution, but I was in a hurry, and it worked.


Sounds like a workable solution, but I don't think that will help. The document I'm doing is very large. Any thoughts on why the Exoand and Shrink don't work?


Direct link Reply with quote
 

Anna Haxen  Identity Verified
Denmark
Local time: 01:52
Member (2005)
English to Danish
+ ...
Shrink/expand are erratic Nov 25, 2009

Sometimes they work, sometimes they don't (2007 & XP). I haven't been able to figure out when or why. Hopefully, one of the experts will be along soon ...

Direct link Reply with quote
 

ilija5150
Macedonia (FYROM)
Local time: 01:52
Macedonian to English
+ ...
I was about to suggest Shrink Segment Nov 25, 2009

Chris,

I was about to suggest that you need to shrink the segment as Wordfast does not automatically segment sentences ending with a semi-colon. However, you did mention that Shrink/Expand do not work. This might be due to another program using the designated shortcuts or the Wordfast version is simply shoddy on your particular PC. I would therefore suggest for you to download a different version, not necessarily a newer one and try it out. The second solution I would suggest is to designate keyboard shortcuts for these two functions yourself. I presume that you do know how to do it, so I shall not bore you with the details. But, I'll be here if you do.

Hope I helped.

Cheers.




[Edited at 2009-11-25 20:41 GMT]


Direct link Reply with quote
 
xxxNMR
France
Local time: 01:52
French to Dutch
+ ...
In the source text Nov 25, 2009

I think the problem is not in the semicolon but in the end of paragraph character.
So in the source text, replace ^l by ^p ("soft" end of paragraph character by "hard" end of paragraph character). Then the ; in end of segment punctuation should work.
Hope this helps.

(If your text is coming from Excel, there will be a problem in copying back the text in the Excel column, because both end-of-paragraph signs in Word mean a separation between cells in Excel. Again, the problem is not in Wordfast which does things fine, but Word en Excel are slightly incompatible. So be careful, try this out on a small scale).


[Modifié le 2009-11-25 22:03 GMT]


Direct link Reply with quote
 

Chris Lovelace  Identity Verified
Argentina
Local time: 20:52
Russian to English
+ ...
TOPIC STARTER
Cell protection had to be disabled Nov 26, 2009

It seemed to make a difference when I disabled cell protection (CTRL+ALT+F12).

However, it may have also made a difference that I replaced all commas with ,^p to create breaks at each comma while not losing the distinction bewteen a comma and a ^p. I later changed this back, and for some reason the document responded better under the segmentation process.

Regarding this response:


NMR wrote:

So in the source text, replace ^l by ^p ("soft" end of paragraph character by "hard" end of paragraph character). Then the ; in end of segment punctuation should work.
Hope this helps.



[Modifié le 2009-11-25 22:03 GMT]


When I tried this throughout the whole document, 0 replacements were made.

Incidentally, I also tried working with the document in Wordfast 6.0, where it responded better when I had it set on "TEXT" rather than "TABLE," but gave me the same problems in "TABLE" mode.
Once I went back to Wordfast Classic, I was able to shrink the segments.


Direct link Reply with quote
 
xxxNMR
France
Local time: 01:52
French to Dutch
+ ...
This is another solution Nov 26, 2009

However, it may have also made a difference that I replaced all commas with ,^p to create breaks at each comma while not losing the distinction bewteen a comma and a ^p. I later changed this back, and for some reason the document responded better under the segmentation process.

Glad you found a solution.

Sometimes you'll have to force line breaks manually in the source document, for instance in lists of instructions or ingredients, when there are dots • between the segments. And sometimes the whole document is one segment!


Direct link Reply with quote
 

Chris Lovelace  Identity Verified
Argentina
Local time: 20:52
Russian to English
+ ...
TOPIC STARTER
Thanks... Still open to ideas Nov 26, 2009

Thanks to all who answered. My document seems to be behaving better.

I do think the CTRL+ALT+F12 function makes a difference, since I've had to use it twice more...

I'd still very much appreciate any pointers you can offer, since I'm new to Wordfast, and really want to make it work.


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 01:52
English to Arabic
Setup > Segments Nov 26, 2009

Chris Lovelace wrote:

In the Wordfast Classic setup dialogue:

I have changed the "End of segment punctuation" in Wordfast to read as follows:

, : . ! ? ^t ;

When I closed the dialogue box, it asked if I wanted to save to wordfast.ini, which I did.

After rebooting my computer and resuming the translation, segmentation still goes to the next period, and ignores intervening commas and semicolons.

How can I resolve this, or at least get Wordfast to generate shorter segments?



Hi Chris,

This is because the text following commas and semicolons usually starts with a small letter. Go to *Setup* (tab) > *Segments* (sub-tab) and check the option: *An ESP + a space + a lower case end a segment*.


HTH,
Yasmin


Direct link Reply with quote
 

Chris Lovelace  Identity Verified
Argentina
Local time: 20:52
Russian to English
+ ...
TOPIC STARTER
Thanks Nov 26, 2009

Yasmin Moslem wrote:

This is because the text following commas and semicolons usually starts with a small letter. Go to *Setup* (tab) > *Segments* (sub-tab) and check the option: *An ESP + a space + a lower case end a segment*.


HTH,
Yasmin



Thanks, Yasmin!

I'll give this a shot.

Thank you for your help!

Chris


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Adding comma and semicolon to delimiters does not work in Wordfast Classic

Advanced search


Translation news related to Wordfast





SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search