No automatic leverage in WF Pro (WF Pro 2.2.4 / OS X 10.4.11)
Thread poster: Laurence Nunny
Laurence Nunny
Spain
Local time: 05:45
Spanish to English
+ ...
Dec 22, 2009

Simple problem:

WF Pro has stopped automatically leveraging translation memory matches. So, I "alt-down" to activate the next segment (which I know to be 100% match) and no matches come up until I "alt-space".

Is there an option I have inadvertently checked, or is this a bug?

Thanks.


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 06:45
English to Arabic
Re-establish TM Connection Dec 23, 2009

Laurence Nunny wrote:

WF Pro has stopped automatically leveraging translation memory matches. So, I "alt-down" to activate the next segment (which I know to be 100% match) and no matches come up until I "alt-space".



Dear Laurence,

Could you please try the following:

1- Press Alt+End (or the equivalent toolbar button) to commit all the TUs to the TM.
2- Translation Memory (menu) > New/Select TM > highlight the TM and click "Remove". Then, click "Open", browse, and select the TM again.


If the problem persists, please send the TXML file as well as the TM to investigate the issue.

---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 
Laurence Nunny
Spain
Local time: 05:45
Spanish to English
+ ...
TOPIC STARTER
Resolved Dec 23, 2009

Hi Yasmin,


The problem had resolved itself by the time I came to testing it.

This was after I have closed everything down for the night, rebooted, and worked on a different project and TM for a different translation, which is more or less what your instructions had asked me to do.

I will let you know if the issue comes up again and is not resolved by such a "reboot".

Thanks for your help.


Direct link Reply with quote
 

Mike (de Oliveira) Brady  Identity Verified
United Kingdom
Member (2008)
Portuguese to English
Same problem - not solved Jun 14, 2010

I'm having the same problem. I had to update to be able to cope with a TTX file.

Now I have to leverage each segment when I move on to it. It is not doing this automatically and filling the target field.

To cope with the TTX file from Trados, my client had to fill all the target cells with source text, as per Wordfast Pro instructions, so I can't commit all TUs to the TM, or it fills the TM with untranslated text. However, I have committed all the segments I have translated to a new file and relinked to this as described above.

The same situation applies - I have to leverage each segment when I reach it. It's one extra click per segment, but as it didn't require this in the past, it is a bit of a pain.

I have already translated 400 segments and this problem has only arisen now. Automatic leveraging was working to start with.


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 06:45
English to Arabic
Colour Jun 14, 2010

Mike (de Oliveira) Brady wrote:

The same situation applies - I have to leverage each segment when I reach it. It's one extra click per segment, but as it didn't require this in the past, it is a bit of a pain.

I have already translated 400 segments and this problem has only arisen now. Automatic leveraging was working to start with.



Dear Mike,

Even if you have a TTX file with source segments both in the source and the target, automatic leveraging should work properly. Please note that the case of TTX files is completely different from the "Copy Source" function. When you use "Copy Source", the segment will be considered "modified" and so it will not be leveraged until you press Alt+Space, which is NOT the case of TTX files because segments are not marked as "modified", yet.

The question now: What is the colour of the segments that refuse to be automatically leveraged? Did you use Spelling Check > "Change All" function, for example?

Mike (de Oliveira) Brady wrote:

I can't commit all TUs to the TM


Remember that:

1- Alt+Down can be used to move to the next segment and commit (store) the current one into the TM.
2- You can lower the Fuzzy Match Threshold (Edit menu > Preferences > Translation Memory > Fuzzy Match Threshold > 40) to get more matches, if possible.


If you like to send me the TXML and the TM to check, I will be more than willing to look into them and advise you.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 

Mike (de Oliveira) Brady  Identity Verified
United Kingdom
Member (2008)
Portuguese to English
Does find/replace all stop automatic leveraging? Jun 14, 2010

The question now: What is the colour of the segments that refuse to be automatically leveraged? Did you use Spelling Check > "Change All" function, for example?


Aha! I did a find/replace all. And it may well be that it stopped automatically leveraging after this.

The segments that won't leverage are coloured pink in the Score column with N/A appearing.

Because the TTX file has to have text in the target column, I guess they were all updated as a result of the find/replace all.

If that is the explanation, is there any way to avoid it in future, or to undo the flagging as 'modified'?


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 06:45
English to Arabic
Yes! Jun 14, 2010

Dear Mike,


Mike (de Oliveira) Brady wrote:

Aha! I did a find/replace all. And it may well be that it stopped automatically leveraging after this.

The segments that won't leverage are coloured pink in the Score column with N/A appearing.

Because the TTX file has to have text in the target column, I guess they were all updated as a result of the find/replace all.

If that is the explanation, is there any way to avoid it in future, or to undo the flagging as 'modified'?



"Replace All" does NOT have the same effect as Spelling Check > "Change All". But as you said, it could be because the target text in the TTX file has been updated as well.


The solution now is to open the TXML file in NotePad or TextEdit and apply the following Find-Replace formula:

Find what: modified="true"
Replace with: modified="false"

Now, you will be able to leverage modified segments.

Also, please have a look at the recently added tip at the end of the knowledge-base article on how to translate TTX files in WFP:
http://www.wordfast.net/?kb=138-35


I hope this helps.



---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

No automatic leverage in WF Pro (WF Pro 2.2.4 / OS X 10.4.11)

Advanced search


Translation news related to Wordfast





SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search