Auto-propagation does not work
Thread poster: Natalie

Natalie  Identity Verified
Poland
Local time: 16:38
Member (2002)
English to Russian
+ ...

Moderator of this forum
Jan 16, 2010

Hi all,

I have the following problem (I use WF Pro, latest build): no matter which option is checked (global auto-propagation or partial), it does not work. I also cannot find anything about auto-propagation in the manual (the description of this function is absent there).

Is it a function that is expected to be working sometimes in the future or am I missing something here?

Thanks for enlightening me,
Natalia


 

Yasmin Moslem  Identity Verified
Egypt
Local time: 16:38
English to Arabic
Auto-Propagation Jan 16, 2010

Natalie wrote:
I have the following problem (I use WF Pro, latest build): no matter which option is checked (global auto-propagation or partial), it does not work. I also cannot find anything about auto-propagation in the manual (the description of this function is absent there).


Dear Natalia,

In the latest version of Wordfast Pro, Auto-Propagation is fully functional and should work without any problem.

In general, Auto-propagation means that if you have some "repetitions" (=segments with the same source text), and you leverage a segment (Alt+Space), translate & commit it (Alt+Down), or even change it without committing (moving with the mouse), the rest of the repeated segments will be automatically filled with the same translation.


There are three options under (Edit > Preferences > Auto-Propagation):

~ Disable Auto-Propagation: If you have some repetitions, leveraging or changing one of them will affect the current segment only and will have no effect on other repeated segments.

~ Global Auto-Propagation: If you have some repetitions, leveraging or changing one of them will change all the repeated segments – no exceptions.

~ Partial Auto-Propagation: If you have some repetitions, leveraging or changing one of them will change ONLY the repeated segments which are untouched, source copied or already auto-propagated. Other repeated segments, those that you have translated in a different way for some reason, will not be changed.


If you have any further questions, please let me know.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


 

Natalie  Identity Verified
Poland
Local time: 16:38
Member (2002)
English to Russian
+ ...

Moderator of this forum
TOPIC STARTER
Dear Yasmin Jan 17, 2010

Many thanks for your prompt response.

Yes, automatic changing of the repeated segments when I change one of them is exactly what I need: I am editing a document with some repetitions.

I have just checked if I have the latest version - and yes, I have it. I have tried checking either the partial or global propagation options but either nothing happens (when I change one of the repeated segments) or I get an error: "Failed to update segment. The following error(s) occured: [Translation memory name here]: Failed to update tu. null"

What would would you suggest?

Thank you very much,
Natalia



[Edited at 2010-01-17 00:15 GMT]


 

Yasmin Moslem  Identity Verified
Egypt
Local time: 16:38
English to Arabic
Re-establish TM Connection Jan 17, 2010

Natalie wrote:
Failed to update tu. null"


Dear Natalia,

Do you use a Remote TM?

Whatever the TM type you use (even if it is Local), try to re-establish the TM Connection by restarting Wordfast Pro, or "removing" the TM from the translation memories list and "opening" it gain.

I hope this helps. Please let me know.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


 

Natalie  Identity Verified
Poland
Local time: 16:38
Member (2002)
English to Russian
+ ...

Moderator of this forum
TOPIC STARTER
Thank you, Yasmin Jan 17, 2010

No, it was a local TM from the outsourcer. After several unsuccessful tries, I removed the TM completely and unpacked a "fresh" copy of it from the ZIP attached to the email, and the error finally disappeared.

And auto-propagation also works fine now!

Natalia



[Edited at 2010-01-17 15:45 GMT]


 

SPI-Trad
Local time: 16:38
Czech to French
+ ...
How to autopropagate glossary? Nov 5, 2010

Hello,
I'm trying to autopropagate my glossary into the target segments (something like PropagateAndHighlight in the Pandora box of WF Classic)
In Edit/Preferences/Terminology, I've tried all three possibilities (Copy only source, etc.) but nothing works, WFP only copies the source segment (I've selected Copy source on no match) into the target segment without propagating the glossary. I would welcome any advice...
(WFP 2.4.0.1, Vista, txml file to translate)
Thanks in advance!


 

Yasmin Moslem  Identity Verified
Egypt
Local time: 16:38
English to Arabic
Copy Source Button Nov 6, 2010

JSpin wrote:

In Edit/Preferences/Terminology, I've tried all three possibilities (Copy only source, etc.) but nothing works, WFP only copies the source segment (I've selected Copy source on no match) into the target segment without propagating the glossary.


Dear JSpin,

Currently, Terminology Propagation works only with the toolbar button Copy Source or Alt+Insert.

Currently, it does not work with "Copy source on no match" but this has been requested.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


 

SPI-Trad
Local time: 16:38
Czech to French
+ ...
thank you Nov 7, 2010

Thank you Yasmin!

 

Hila A
Local time: 22:38
Member (2007)
English to Tagalog
+ ...
autopropagation does not work Mar 21, 2015

Hello everyone,

I have the same problem. Mine does not work too. It says TXML perspective appears, but there is none, or maybe I just don't know what it is.
Upon clicking everything as instructed, still nothing. I hope someone can help me with this.


 

Graeme Waller  Identity Verified
Finland
Local time: 17:38
Finnish to English
+ ...
Fix (Wordfast Pro 3.4.7) Apr 23, 2016

This problem has irritated me for some time.

I found a fix today using Wordfast Pro 3.4.7.

Go to ‘Auto-propagation in ‘Preferences’ (General > Translations > Auto-propagation). Ensure that ‘Enable autopropagation’ is checked.

‘Fuzzy matches’, ‘Modified segments’, ‘Machine Translated segments’ are already checked (defaults).

Check ‘Autopropagated matches’ (the default setting leaves it unchecked).

I have run some tests on the document I am translating, and it works now.icon_smile.gif

You also have the option to ‘enable auto-propagation across all files’.

[Edited at 2016-04-23 09:58 GMT]

[Edited at 2016-04-23 09:59 GMT]

[Edited at 2016-04-23 10:00 GMT]

[Edited at 2016-04-23 10:12 GMT]


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Auto-propagation does not work

Advanced search


Translation news related to Wordfast





SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search