Having some trouble using Trados TMX in WF
Thread poster: alexliz

alexliz  Identity Verified
Greece
Local time: 09:15
English to Greek
+ ...
Jan 20, 2010

I am running Trados 2007 in Parallels on MacOS X Leopard 10.5.7, as well as WordFast 2.2.0.4 (Build 20090609-2041) demo version. I am really trying to move from Trados to WF, but I want to make sure of how things work. So far, I am not doing too well. Sorry for the length of this post. Here is the problem:

I have a project which is half-way through in Trados. Source language is Greek; target English-US. I update its TM, then close Trados. In Workbench I open my TM for the project, then File->Export it as TMX. I go to WordFast.

I open a new file, then go to the Translation Memory menu and click on Open. The new dialog which appears on the screen has predefined source and target locales. For Source Locale it has "English (United States)" and for Target Locale it's "Greek". My project direction is the other way around, so I quickly go into the drop-down menus and switch them around. Now they read Source "Greek" and Target "English (United States)". Good.

I now go to the top right and click on 'browse' to go to the newly created TMX version of the TM. In the new window I go to the bottom, switch 'LocalTM File' to 'Translation Memory eXchange File', then point to the TMX I produced a few moments ago. After clicking on 'Open' I get the window warning me that:

"This file is in TMX format, a copy will be created in local format.
Non-compatible locales will not be imported.

Press OK to continue."

I press OK. I am informed that

'TMX Imported Finished.
Total TMX TUs: 13
Total Imported: 13

Locales in TMX: , EL, EN-US' [initial comma is as shown]

I click on OK, then click the final OK. WF informs me that TM connection established successfully after which I OK twice and I'm looking at my main WF window which is currently empty. I open my original Word file (the untranslated file) and I would have expected that the TM will be applied to it. Alas, it isn't. All I get is the source segments on the left hand column, and the blank target segments on the right. No problem, I think, I'll go into the Translation Memory menu, click on Translate Until Fuzzy/Until No Match, and it will apply the TM. No, sir, it doesn't.

So I'm thinking one of three things:

1. WF is not working properly (I doubt it)
2. The TM hasn't converted/mounted properly (perhaps), or
3. I don't know what I'm doing overall.

I opened the WordFast local version TM file in TextEdit.app (Mac version of Notepad.exe) just to confirm that it does indeed have the TU in it. I can confirm that the TUs are in it. I also see the two locales; they appear to be columns 4 and 6 in the .txt file. They show up as 'EL' and 'EN-US'.

Like I said, sorry for the lengthy post, but I just wanted to make sure that I convey the deal over to you.

If you are among the brave who actually have reached this point, please do drop a line if you also happen to have an idea as to what I'm doing wrong.

Many thanks, people!


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 09:15
Member (2006)
English to Russian
+ ...
This might be about entities and tags Jan 21, 2010

Trados is known to insert its specific entities and tags into TMX causing problems when reading such files in other programs. Did you choose TMX 1.1 or TMX 1.4 when exporting? If it was 1.4, try out 1.1.

Try also a workaround: take wf2tmx utility (available in the files section of Wordfast mail list in Yahoo) and try to convert your TMX into Wordfast Classic format, then import the latter into WF Pro.


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 08:15
English to Arabic
Files Jan 22, 2010

Dear Alex,

Could you please send the TMX file as well as the original Word doc.

... so that I can see the problem.

Thanks in advance.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Having some trouble using Trados TMX in WF

Advanced search


Translation news related to Wordfast





LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search