Non-breaking space before !?; problem
Thread poster: jeffrey engberg

jeffrey engberg  Identity Verified
Norway
Local time: 18:27
Member (2006)
Norwegian to English
+ ...
Jan 27, 2010

hi all.
Since changing to WORD 2007, I have been having a problem with Wordfast that I can't seem to solve.
When I confirm a segment (Alt+downarrow) with a question mark, semi-colon etc, I get a little wordfast pop-up window asking me if I want to insert a space befor my character.
I have tried to change the Wordfast settings in QC and Pandora's Box, but nothing seems to help.
It is a bother and waste of time to press yes, no, or cancel. every time a question mark or semi-colon appears!
Any ideas?


Direct link Reply with quote
 

Slawomir Nieciecki  Identity Verified
Poland
Local time: 18:27
English to Polish
+ ...
Try this... Jan 27, 2010

Setup -> QC, disable Warn if target finds="[!^s][\!\?\:\;]" /wc (No non-breaking space before !?:;)"
Setup -> PB, disable "F_R="[!^s][\!\?\:\;]" /wc (No non-breaking space before !?:;)" (it is the same command as in Setup/QC).
Close Setup window and SAVE changes.
You can also try to disable QC options during translation (Setup -> QC -> un-check Enable following ...)

Since Toolbar commands are supposedly ineffective with Word 2007, maybe you should manually change wordfast.ini file?


Direct link Reply with quote
 

jeffrey engberg  Identity Verified
Norway
Local time: 18:27
Member (2006)
Norwegian to English
+ ...
TOPIC STARTER
nope Jan 27, 2010

I already tried all that.
Nothing seems to work.
Any other ideas?


Direct link Reply with quote
 

Stevi  Identity Verified
France
Local time: 18:27
English to French
+ ...
shift+ctrl+space Jan 27, 2010

try shift+ctrl+space

sincerely


Direct link Reply with quote
 

Sergei Leshchinsky  Identity Verified
Ukraine
Local time: 19:27
Member (2008)
English to Russian
+ ...
space before ; ! or ? is an error Jan 27, 2010

Why do you need it?

Direct link Reply with quote
 

jeffrey engberg  Identity Verified
Norway
Local time: 18:27
Member (2006)
Norwegian to English
+ ...
TOPIC STARTER
Please read my post... Jan 27, 2010

I do not need it or want it.
I want to get rid of it.
The wordfast pop-up command comes whether I like it or not, even after trying to change all the control commands.
Shift+control+space is the same problem.
I shouldn't need to tell wordfast NOT to ask me for a space before the characters.


Direct link Reply with quote
 

jeffrey engberg  Identity Verified
Norway
Local time: 18:27
Member (2006)
Norwegian to English
+ ...
TOPIC STARTER
To Slawomir Jan 27, 2010

I took a look at Wordfast.ini.
Everything looks normal there!


Direct link Reply with quote
 

Slawomir Nieciecki  Identity Verified
Poland
Local time: 18:27
English to Polish
+ ...
Ok :) Jan 28, 2010

Remove old wordfast.dot file (files?), copy new "fresh" wordfast.dot file and install it.

Direct link Reply with quote
 

jeffrey engberg  Identity Verified
Norway
Local time: 18:27
Member (2006)
Norwegian to English
+ ...
TOPIC STARTER
Remove old wordfast.dot... Jan 28, 2010

Okay. I will try it.
Where or how do I copy a new wordfast.dot?
does it appear on its own if I trash the old one?


Direct link Reply with quote
 

Florence B  Identity Verified
France
Local time: 18:27
Member (2002)
English to French
+ ...
French? Jan 28, 2010


space before ; ! or ? is an error


It's not an error if you write in French, it's even compulsory in this case... Afaik French is the only language using this feature, are you sure that your document is not set to French?

[Modifié le 2010-01-28 17:00 GMT]


Direct link Reply with quote
 

jeffrey engberg  Identity Verified
Norway
Local time: 18:27
Member (2006)
Norwegian to English
+ ...
TOPIC STARTER
no error... Jan 28, 2010

It is also sometimes used in British English.
But my question is not where it is used!
I want to know how to get rid of an unwanted wordfast command...


Direct link Reply with quote
 

Christine Andersen  Identity Verified
Denmark
Local time: 18:27
Member (2003)
Danish to English
+ ...
Does your TM mysteriously change to French? Jan 28, 2010

Florence B wrote:


space before ; ! or ? is an error


... are you sure that your document is not set to French?

[Modifié le 2010-01-28 17:00 GMT]


Are you quite sure?
Wordfast was ´born´ in France after all, and one of my TMs occasionally changes to French as the target for unknown reasons.

My workaround, I'm afraid, is to create a new TM or use Trados! I can still use the glossary, where I have all the important terminology.
Best of luck!


Direct link Reply with quote
 

Sergei Tumanov  Identity Verified
Local time: 19:27
English to Russian
+ ...
hello Jan 28, 2010


But my question is not where it is used!
I want to know how to get rid of an unwanted wordfast command...


Jeffrey, it seems that all of a sudden the spellchecker installed at your computer has started to treat the text as written in French. One of possible reasons, imho.
And we try to clarify this in order to find the way to switch it off. If this is THE REASON.

This is one of assumptions, nothing more.

[Edited at 2010-01-28 19:24 GMT]


Direct link Reply with quote
 
NR_Stedman  Identity Verified
France
Local time: 18:27
French to English
I've never found a solution to this either Jan 29, 2010

For the last 5 years at the end of every translation I have had to use the Word Find/replace function to get rid of all those spaces before !?:; in my French target texts.
I can find no way of getting rid of them automatically.
When I saw this function in WF panadora's box I thought that someone had found a solution but I can't get it to work either.

I would be VERY grateful for someone who could clearly explain how to do this

Incidentally another thing that doesn't work in WF pandoras box is the message about changing the translation memory in a document. I get a message when I have changed the TM to ask me if I want to revert back to the document's original TM. However when I click YES nothing happens and I don't revert to the original TM


Direct link Reply with quote
 

jeffrey engberg  Identity Verified
Norway
Local time: 18:27
Member (2006)
Norwegian to English
+ ...
TOPIC STARTER
Eureka! I found it... Jan 29, 2010

Non-breaking space solve.

Thanks for all the help everyone.
I hope this solve works for others!
I Found a Pandora's Box command called NoPromptToSaveIni
I activated this (No_PromptToSaveIni) and the problem was solved.

And I made certain that the QC command "[!^s][\!\?\:\;]" /wc (No non-br. space before !?:;) was turned off,
and that Pandora's Box command FR="[!^s][\!\?\:\;]" /wc (No non-breaking space before !?:;) was turned off F_R="[!^s][\!\?\:\;]" /wc (No non-breaking space before !?:;)

So for me the answer is:
Turn off the Pandora command NoPromtToSaveIni!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Non-breaking space before !?; problem

Advanced search


Translation news related to Wordfast





PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search