Error message in Wordfast Pro: Unable to establish TM connection
Thread poster: svenfrade

svenfrade  Identity Verified
Germany
Local time: 08:15
French to German
+ ...
Feb 2, 2010

I have had this problem for a while now:

When I select a TM for an ongoing project and open a new file, I keep getting the error message "Unable to establish TM connection". I have no idea what I am doing wrong. This happened for the first time a few weeks ago, but now occurs every time.

Does anyone have any ideas what I could be doing wrong?


Direct link Reply with quote
 

Edward Vreeburg  Identity Verified
Netherlands
Local time: 08:15
Member (2008)
English to Dutch
+ ...
Could it be.. Feb 2, 2010

...the TM was located on another drive letter or in another directory? (perhaps you are using an USB-key?). If you select it manually, are you OK?

===
Ed

[Edited at 2010-02-02 13:23 GMT]

[Edited at 2010-02-02 13:23 GMT]


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 08:15
English to Arabic
Path? Feb 3, 2010

inkweaver wrote:

I have had this problem for a while now:

When I select a TM for an ongoing project and open a new file, I keep getting the error message "Unable to establish TM connection". I have no idea what I am doing wrong. This happened for the first time a few weeks ago, but now occurs every time.

Does anyone have any ideas what I could be doing wrong?


Dear inkweaver,

Does this happen with each TM or with only specific TM?

If this happens with a specific TM, could you please move it to a closer folder, say: C:\MyTM, and make sure that its name does not include any special or assented characters. Does this help?

If this is related to every TM, also please try the previous step. If this does not help, you can completely uninstall Wordfast Pro. When you are asked to keep configuration files, answer with "No". (Make sure you first back up your glossaries, if any.) Then, download and install the latest version of Wordfast Professional available at:
http://www.wordfast.com/store_download.html

If the problem is related to only one TM and the previous suggestion does not help, please send it so that I can look into it and advice you.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 

svenfrade  Identity Verified
Germany
Local time: 08:15
French to German
+ ...
TOPIC STARTER
Seems to happen with every TM... Feb 4, 2010

but I will certainly try what you suggested, Yasmin, thanks.

Direct link Reply with quote
 

ROBINDUSTBIN
Local time: 14:15
I have the same problem too. Jun 28, 2010

I am currently using wordfast classic to generate my TM. Ever since my company works with Arabic language, we are exploring Wordfast Pro. I tried to generate TM for 1 page of Arabic translations from Wordfast Classic. I am trying to use INX format on Wordfast Pro for the translation work by linking to the TM (generated by Wordfast Classic) but this message error popped said "localTM://tm_file_location.txt:Failed to connect 1. Please note that this TM will be disabled.

Is there anyway to work around this problem?
Please help.


Direct link Reply with quote
 

Geoffrey Barrow
Local time: 02:15
Norwegian to English
Did you find a solution? Aug 26, 2010

ROBINDUSTBIN wrote:

I am currently using wordfast classic to generate my TM. Ever since my company works with Arabic language, we are exploring Wordfast Pro. I tried to generate TM for 1 page of Arabic translations from Wordfast Classic. I am trying to use INX format on Wordfast Pro for the translation work by linking to the TM (generated by Wordfast Classic) but this message error popped said "localTM://tm_file_location.txt:Failed to connect 1. Please note that this TM will be disabled.

Is there anyway to work around this problem?
Please help.


Did you ever find a solution to this problem? I am experiencing the same when I open a TM (which I have used in WF Classic as late as yesterday), and try to translate a document. I have posted a question on the WF Pro Yahoo group, without receiving any helpful response, and have also sent a query to Wordfast support, but so far, all I have received is a suggestion from Yasmin that I try re-installing Worfast. This I have done, but it doesn't help. I have also tried exporting a Trados TM in .tmx, converting it to WF .txt using the conversion program on the Yahoo group's web site, and opening that in WF Pro, but - surprise surprise! - I get exactly the same error message.

Geoff


Direct link Reply with quote
 

Geoffrey Barrow
Local time: 02:15
Norwegian to English
The solution! Sep 10, 2010

Eventually I found the answer, thanks to Yasmin. Although we didn't actually realise what was going on at the time, she pointed me in the right direction. It turns out that there was an error in the header of my TM, which was created in Wordfast Classic. The version number was given as 5.90z1, but the version number in an empty TM created using Wordfast Pro was 546/00. It turns ot that if you open the Wordfast Classic TM file in Notepad and add "/00" after the version number, WF Pro will be able to recognise the TM. Don't ask me why this had happened, or why so few users have experienced it, but Yasmin has assured me that the software developers have been notified and the error will be corrected in newer versions.

I'd just like to say thank you to Yasmin who sat in a GoToMeeting for about two hours with me trying to work through this one. Her attitude was friendly and helpful and the entire conversation was a very positive experience. As I say, the answer came to me AFTER our meeting, but it was very much as a result of our conversation. I have heard people criticising the support they get from Wordfast, but in my experience, this was some of the best support I have ever received from ANY software manufacturer.

Geoff


Direct link Reply with quote
 

ni-cole  Identity Verified
Switzerland
Local time: 08:15
German to French
+ ...
Thanks Geoffrey! Oct 16, 2010

Geoffrey Barrow wrote:

The version number was given as 5.90z1, but the version number in an empty TM created using Wordfast Pro was 546/00. It turns ot that if you open the Wordfast Classic TM file in Notepad and add "/00" after the version number, WF Pro will be able to recognise the TM.

Geoff


I am using today WF Pro the first time (needing it for PowerPoint) and had the same problem: I could create a project and add any TM on it, except the one I needed...! I find finally your post and add "/00" after the version number and now it works!

So thank you very much, its a quiet urgent work and I really didn't know how to fix the problem.

Nicole.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Error message in Wordfast Pro: Unable to establish TM connection

Advanced search


Translation news related to Wordfast





TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
SDL Trados Studio 2017 only €495 / $595
Get the cheapest prices for SDL Trados Studio 2017 on ProZ.com

Join this translator’s group buy brought to you by ProZ.com and buy SDL Trados Studio 2017 Freelance for only €495 / $595 / £425 / ¥70,000 You will also receive FREE access to Studio 2019 when released.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search