WF PRO, can't save translated .docx file (error)
Thread poster: Krzysztof Kajetanowicz (X)

Krzysztof Kajetanowicz (X)  Identity Verified
Poland
Local time: 02:21
English to Polish
+ ...
Jun 12, 2010

Hi,

When trying to Save Translated File, I get the following error:


java.util.EmptyStackException

The problem is only with .docx files (i.e. saving the target text of a .docx.txml as a .docx).

I'm using PRO v. 2.3 with all current updates (except for some dictionaries) under Vista.

Rebooting the computer or launching WF by opening the .txml directly from Windows hasn't helped.

What has helped is converting the original .docx file to .doc, changing "docx" do "doc" in the .txml file using Notepad and saving the target .doc file. Obviously, not a real solution.

Any tips?

[Edited at 2010-06-12 12:12 GMT]


 

Yasmin Moslem  Identity Verified
Egypt
Local time: 03:21
English to Arabic
Pre-Translate Jun 12, 2010

Dear Krzysztof,

Krzysztof Kajetanowicz wrote:

When trying to Save Translated File, I get the following error:

java.util.EmptyStackException


Please try to completely uninstall Wordfast Pro. When you are asked to keep configuration files, answer with "No". (Make sure you first back up your glossaries, if any.) Then, try installing again, hopefully it could resolve that.

As you run Windows Vista, it is better usually to turn off the UAC during installing, licensing and updating Wordfast Pro. You can turn it on later:
(Control Panel -> User Accounts -> Turn User Account Control on or off -> (un-check) Use User Account Control) -> Re-start your computer.


If this does not help, open a fresh copy of the DOCX file and pre-translate it using the toolbar button Translate All.


I hope this helps. Please let me know.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net

[Edited at 2010-06-12 12:31 GMT]


 

Irene Elmerot  Identity Verified
Sweden
Local time: 02:21
Dutch to Swedish
+ ...
Same problem on Mac OS 10.6.8 Aug 22, 2011

I just got the exact same problem.
Thanks to the idea from Krzysztof, I opened the txml files in TextWrangler and replaced all "docx" with "doc" (one in each file), and that solved it – albeit not a pretty solution. SO a big Thank you! to Krzysztof for letting me know I could do such a thing.

No other ideas except uninstalling?

Kind regards,
/Irene Elmerot
MacBook Pro, Wordfast Pro 2.4.2, Mac OS 10.6.8

Yasmin Moslem wrote:

Dear Krzysztof,

Krzysztof Kajetanowicz wrote:

When trying to Save Translated File, I get the following error:

java.util.EmptyStackException


Please try to completely uninstall Wordfast Pro. When you are asked to keep configuration files, answer with "No". (Make sure you first back up your glossaries, if any.) Then, try installing again, hopefully it could resolve that.

As you run Windows Vista, it is better usually to turn off the UAC during installing, licensing and updating Wordfast Pro. You can turn it on later:
(Control Panel -> User Accounts -> Turn User Account Control on or off -> (un-check) Use User Account Control) -> Re-start your computer.


If this does not help, open a fresh copy of the DOCX file and pre-translate it using the toolbar button Translate All.


I hope this helps. Please let me know.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net

[Edited at 2010-06-12 12:31 GMT]


[Edited at 2011-08-22 10:53 GMT]


 

uytteb  Identity Verified
Belgium
Local time: 02:21
French to Dutch
+ ...
Same problem with .doc file Sep 9, 2014

I have the exact same problem, but with a .doc file. I tried changing the file name, copying the text and pasting it in a blank document, and then pre-translating that new file - no success. I am rather unwilling to uninstall and re-install.

Any ideas?


 

Yasmin Moslem  Identity Verified
Egypt
Local time: 03:21
English to Arabic
TransCheck Sep 10, 2014

uytteb wrote:

I have the exact same problem, but with a .doc file. I tried changing the file name, copying the text and pasting it in a blank document, and then pre-translating that new file - no success.


The last time I handled this error, the problem was that there was a missing tag {ut} in a segment; when I added it, I could save the file.

Please make sure you always run TransCheck on tags before saving files: Edit > Preferences > TransCheck > select "Tag" (Apply)) and then use the toolbar button TransCheck; insert and correct the missing or the mismatched placeables.

I hope this helps. Please let me know.


Kind regards,
Yasmin


 

KateKaminski
Local time: 01:21
German to English
Seconded Sep 11, 2014

Yasmin Moslem wrote:

uytteb wrote:

I have the exact same problem, but with a .doc file. I tried changing the file name, copying the text and pasting it in a blank document, and then pre-translating that new file - no success.


The last time I handled this error, the problem was that there was a missing tag {ut} in a segment; when I added it, I could save the file.

Please make sure you always run TransCheck on tags before saving files: Edit > Preferences > TransCheck > select "Tag" (Apply)) and then use the toolbar button TransCheck; insert and correct the missing or the mismatched placeables.

I hope this helps. Please let me know.


Kind regards,
Yasmin


I had a nightmare a while ago which sounds similar to your problem. It turned out to be extremely quick and easy to fix.

The tag no. might be in the error message. If not, run TransCheck to find the missing tag - it should take under 5 minutesicon_smile.gif


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

WF PRO, can't save translated .docx file (error)

Advanced search


Translation news related to Wordfast





PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search