How to undo "ALT+insert" (ALL segments replaced by source) - disaster
Thread poster: Katarina Delic

Katarina Delic  Identity Verified
Serbia
Local time: 07:33
Member (2008)
English to Serbian
+ ...
Jul 10, 2010

Can somebody please tell me if there is a way to undo "ALT+insert"? I pressed ALT+insert and ALL target segments got replaced with source segments. It's a nightmare!!! The "undo" option doesn't do anything - it is clickable, but nothing changes when I click on it! I never committed the segments to TM. Is there anything I can do?

Thanks in advance!

Katarina

[Edited at 2010-07-10 09:50 GMT]


Direct link Reply with quote
 

Dušan Ján Hlísta  Identity Verified
Slovakia
Local time: 07:33
English to Slovak
+ ...
Katarina Jul 10, 2010

there is simple option to save the WORD document without the changes. As far as I know the translated segments are saved in TM. However "Alt + Insert" does it only for the currently open segment - never for every segment of the file. Do you really insist on the fact that you press only two keys (Alt + Insert) - according to my experience it must be more than that.
Anyway Good luck charm...
Dušan Ján Hlísta


Direct link Reply with quote
 

Katarina Delic  Identity Verified
Serbia
Local time: 07:33
Member (2008)
English to Serbian
+ ...
TOPIC STARTER
Just alt+insert Jul 10, 2010

skopko wrote:

there is simple option to save the WORD document without the changes. As far as I know the translated segments are saved in TM. However "Alt + Insert" does it only for the currently open segment - never for every segment of the file. Do you really insist on the fact that you press only two keys (Alt + Insert) - according to my experience it must be more than that.
Anyway Good luck charm...
Dušan Ján Hlísta


I am 100% positive that I pressed just "alt+insert"!!! I do that all the time and this is the first time that all segments got replaced. Maybe no segment was open... I don't know... Anyway, I can't take any more risks since I already started the translation from the beginning; I remember most of the stuff... So, I won't be closing the file now. When the thing happened to me, I pressed undo zillion times and tried other things such as translate all and other similar options and then things got worse since everything got translated to source again and thus I SEALED the target segments as source segments.
To cut the long story short, it will take me about an hour to translate everything again since the doc is not so big. After this one, I have a few files with quite big word counts and I definitely won't be using the option "copy source" again!!!


Direct link Reply with quote
 

Katarina Delic  Identity Verified
Serbia
Local time: 07:33
Member (2008)
English to Serbian
+ ...
TOPIC STARTER
I realized what happened, but the "undo" seems impossible... Jul 10, 2010

I opened a few other unimportant TXMLs and realized that when I press ALT+insert on the keyboard ALL target segments turn to source segments but when I click on the arrow for copy source within the programme itself just the segment currently open turns to source.
When the problem first occurred, I did get sick of clicking on copy source and started using the keyboard shortcut and then... So, the keyboard shortcut does not match the program option, at least in my case...


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 07:33
Member (2006)
English to Afrikaans
+ ...
WFP Jul 10, 2010

Katarina Delic wrote:
I opened a few other unimportant TXMLs...


Aaah, so you were using Wordfast PRO...


Direct link Reply with quote
 

Katarina Delic  Identity Verified
Serbia
Local time: 07:33
Member (2008)
English to Serbian
+ ...
TOPIC STARTER
Yes Jul 10, 2010

Samuel Murray wrote:
Aaah, so you were using Wordfast PRO...


Sorry for not mentioning it right away!


Direct link Reply with quote
 

Dušan Ján Hlísta  Identity Verified
Slovakia
Local time: 07:33
English to Slovak
+ ...
Hey you! Jul 10, 2010

Katarina Delic wrote:

Samuel Murray wrote:
Aaah, so you were using Wordfast PRO...


Sorry for not mentioning it right away!

I also thought that you use Wordfast Classic (where it is impossible to do such a harakiri)...


Direct link Reply with quote
 

Alma de Kok  Identity Verified
Poland
Local time: 07:33
Member (2006)
Polish to Dutch
+ ...
I think you touched Ctrl + Alt + Ins Jul 11, 2010

A few seconds ago I accidentally hitCtrl + Alt + Ins and i received a message: " Do you want to overwrite all target segments? Of course I said no... (but automatically I almost cliecked yes) But I think that is what happened in your case. Very dangerous.....
No thoughts about repairing though..

Kind regards,

Alma


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 07:33
English to Arabic
Warning + Pre-Translation Jul 11, 2010

Alma de Kok wrote:

A few seconds ago I accidentally hit Ctrl + Alt + Ins and i received a message: " Do you want to overwrite all target segments? Of course I said no...



Yes, this warning has been added to recent versions 2.3/2.4. (Messages are to be read.)

In the case of such mistake, closing without saving is what should be done. Otherwise, restoring to the TM will be the best solution. The toolbar button "Translate All" can be used to pre-translate the the whole TXML file.

You can change the Fuzzy Match Threshold (Edit menu > Preferences > Translation Memory > Fuzzy Match Threshold > 90) to get only exact and semi-exact matches.


I hope this helps.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 

Katarina Delic  Identity Verified
Serbia
Local time: 07:33
Member (2008)
English to Serbian
+ ...
TOPIC STARTER
Not true in my case... I did find out something interesting Jul 11, 2010

Alma de Kok wrote:

A few seconds ago I accidentally hitCtrl + Alt + Ins and i received a message: " Do you want to overwrite all target segments? Of course I said no... (but automatically I almost cliecked yes) But I think that is what happened in your case. Very dangerous.....
No thoughts about repairing though..

Kind regards,

Alma



I opened a TXML and tried out some things and it turns out that the two alt buttons on my keyboard do different things (different from each other). If I press the alt button located to the left of the space button + insert, just one segment is replaced with source. However, if I press the alt button located on the right of the space button + insert, ALL segments turn to source (without any notice).
If I press CTRL+ALT+insert, ALL segments get replaced without any notice!!!

I don't know if it's just my keyboard or not. In any case, beware!!!

p.s. from now on, I will be using only the "copy source" within the programme

[Edited at 2010-07-11 15:29 GMT]


Direct link Reply with quote
 

Katarina Delic  Identity Verified
Serbia
Local time: 07:33
Member (2008)
English to Serbian
+ ...
TOPIC STARTER
Keyboard shortcut for such a big change? Jul 11, 2010

Anyway, I find it very stupid that there should be a keyboard shortcut for copying ALL source segments to target segments. It's not something you would want to do all the time so that you would really need a shortcut. Not to mention that it can mess things up...

Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 07:33
English to Arabic
AltGr Jul 11, 2010

Katarina Delic wrote:

If I press the alt button located to the left of the space button + insert, just one segment is replaced with source. However, if I press the alt button located on the right of the space button + insert, ALL segments turn to source (without any notice).
If I press CTRL+ALT+insert, ALL segments get replaced without any notice!!!


Dear Katarina,

AltGr (Right Alt) on many keyboards are the same as Ctrl+Alt.
http://office.microsoft.com/en-us/word-help/alt-gr-keys-HP005259063.aspx


As for not having a notice, this means that your Wordfast Pro version is old. To avoid any other potential problems, please make sure you download and install the latest version of Wordfast Professional available at:
http://www.wordfast.com/store_download.html


Again, unbinding the shortcut is possible (Edit > Preferences > Keys > select the command "Copy Source - Ctrl+Alt+Ins" > "Remove Binding").


I hope this helps.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 

Katarina Delic  Identity Verified
Serbia
Local time: 07:33
Member (2008)
English to Serbian
+ ...
TOPIC STARTER
Thanks! Jul 11, 2010

Yasmin Moslem wrote:

Dear Katarina,

AltGr (Right Alt) on many keyboards are the same as Ctrl+Alt.
http://office.microsoft.com/en-us/word-help/alt-gr-keys-HP005259063.aspx


As for not having a notice, this means that your Wordfast Pro version is old. To avoid any other potential problems, please make sure you download and install the latest version of Wordfast Professional available at:
http://www.wordfast.com/store_download.html


Again, unbinding the shortcut is possible (Edit > Preferences > Keys > select the command "Copy Source - Ctrl+Alt+Ins" > "Remove Binding").


I hope this helps.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Never knew that about the ALT buttons...

Good to know that shortcuts can be removed!


Direct link Reply with quote
 

Hallvard Viken  Identity Verified
Norway
Local time: 07:33
Spanish to Norwegian
+ ...
Solution Nov 24, 2014

Why is there no way to undo this? Same thing happened to me (1000 segments), and now I have to go and copy every single segment from the TM all over.

My solution: Stay with Trados.


Direct link Reply with quote
 

Katarina Delic  Identity Verified
Serbia
Local time: 07:33
Member (2008)
English to Serbian
+ ...
TOPIC STARTER
Memoq Nov 24, 2014

Hallvard Viken wrote:

My solution: Stay with Trados.


Even better (or much better), switch to Memoq.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to undo "ALT+insert" (ALL segments replaced by source) - disaster

Advanced search


Translation news related to Wordfast





memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search