Segmentation of Excel documents in Wordfast Pro 2.3
Thread poster: Mike (de Oliveira) Brady

Mike (de Oliveira) Brady  Identity Verified
United Kingdom
Member (2008)
Portuguese to English
Aug 3, 2010

I'm using Wordfast Pro 2.3 on a MacBook and need to translate an Excel document.

The document opens fine. The problem is the segmentation is based on sentences rather than cells. In other words, there is a new segment whenever a full stop is encountered in text. I would much prefer it if one segment corresponded to one cell in the excel spreadsheet. Some cells contain several sentences and it loses context to chop them into separate segments.

Under preferences in Wordfast Pro I see that the segmentation settings file is wfsegmentation.properties. There are three other options for settings files. I've tried one of these to see what happened and it froze Wordfast.

I haven't been able to find a topic about this here or on the Wordfast site.

If anyone can point me to an existing article or tell me here how to force Wordfast Pro to segement Excel files by cells then I would be very grateful.

Thanks,

Mike


Direct link Reply with quote
 

Mike (de Oliveira) Brady  Identity Verified
United Kingdom
Member (2008)
Portuguese to English
TOPIC STARTER
Found a solution... Aug 3, 2010

Flying blind, I've just come up with the following solution that has worked.

I exported the wfsegmentation.properties file and saved it as excel.properties

I opened this in text editor and after playing around with a few things, found the following command, where I changed 'false' to 'true'.

---
# true | false - A segmenter that breaks on
boundaries instead of linguistic boundaries.
# Setting this to true invalidates all other segmentation settings.
segmenter.default.brsegmenter=true
---

I then imported this and opened my file using my newly created excel.properties rules.

I did find that I had to delete a file with the same name where my changes hadn't worked and import again for the changes to take.

Hope this helps anyone else looking for a solution.

Anyone with better ideas or a link to instructions, please do post.


Direct link Reply with quote
 

Soonthon LUPKITARO(Ph.D.)  Identity Verified
Thailand
Local time: 13:23
Member (2004)
English to Thai
+ ...
Join segment command? Aug 4, 2010

I stop using WordFast Pro from version 2.2.

In other CAT e.g. SDLX, it is easy to join segments into cell-based view for editing purposes. I am not sure WordFast Pro will provide this command or not.

Regards,

Soonthon L.


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 08:23
English to Arabic
Upgrade Aug 4, 2010

Mike (de Oliveira) Brady wrote:

I'm using Wordfast Pro 2.3 on a MacBook and need to translate an Excel document.

The document opens fine. The problem is the segmentation is based on sentences rather than cells. In other words, there is a new segment whenever a full stop is encountered in text. I would much prefer it if one segment corresponded to one cell in the excel spreadsheet. Some cells contain several sentences and it loses context to chop them into separate segments.



Dear Mike,

The procedure you used is intelligent, but now in Wordfast Pro 2.4, there is GUI for the Segmentation Settings which should make it much easier.

To segment an Excel file based on cells, please go to Edit > Preferences > Segmentation Settings and select "Break".

Otherwise, you can keep it "Wordfast/Trados" and check only "CR" to have the same result.

You can download and install the latest version of Wordfast Professional 2.4.0.1 available at:
http://www.wordfast.com/store_download.html


I hope this helps. If you have any further questions, please let me know.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 

Mike (de Oliveira) Brady  Identity Verified
United Kingdom
Member (2008)
Portuguese to English
TOPIC STARTER
Thanks - and another thing... Aug 7, 2010

Dear Yasmin,

Many thanks. I will download the new version when I have finished this job.

A problem I am finding with version 2.3 is that the hot-key for running the analysis report is shift / space.

Virtually every time I type a sentence including 'I', it triggers an analysis report. I've gone into preferences to try to set a different hot-key for this command, but the 'key' section under preferences does not allow this.

Is there a way to deactivate this hot-key sequence in 2.3 or the latest version as it is very annoying?


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 08:23
English to Arabic
Remove Binding Aug 7, 2010

Mike (de Oliveira) Brady wrote:

A problem I am finding with version 2.3 is that the hot-key for running the analysis report is shift / space.
....
Is there a way to deactivate this hot-key sequence in 2.3 or the latest version as it is very annoying?


Dear Mike,

As for un-assigning the shortcut of Analyze, you can do that as follows

- Go to WFP "Edit" > "Preferences" > "Keys"
- Place the cursor on the command Analyze; you should now see the shortcut in the textbox labeled "Binding".
- Remove it by your "Backspace" or by clicking on the "Remove Binding" button. Make sure the textbox is empty.
- You can insert another unassigned shortcut or just leave it empty.
- Click "OK" to save changes.

I hope this helps.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net



[Edited at 2010-08-07 08:39 GMT]


Direct link Reply with quote
 

Mike (de Oliveira) Brady  Identity Verified
United Kingdom
Member (2008)
Portuguese to English
TOPIC STARTER
Nothing is bound... Aug 8, 2010

That's what I was trying, Yasmin, but nothing appears in the fields when I select Analyze. Clicking on 'unbind command' makes no difference.

I'll see if the upgrade works when I can download it.

[Edited at 2010-08-08 04:35 GMT]


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 08:23
English to Arabic
another shortcut Aug 8, 2010

Dear Mike,

What if you tried to assign another (unassigned) shortcut to it?

HTH,
Yasmin


Direct link Reply with quote
 

Mike (de Oliveira) Brady  Identity Verified
United Kingdom
Member (2008)
Portuguese to English
TOPIC STARTER
Binding is not working Aug 16, 2010

I've downloaded Wordfast 2.4 and tried both to unbind Analyze from the shift-space shortcut and to assign other shortcuts.

Neither has worked. I note that when I return the the keys preferences, the shortcut I have added is no longer there - even when I have clicked 'apply'.

I am running this on a MacBook running system version 10.5.8 and a 2GHz Inter Core 2 Duo.


Direct link Reply with quote
 

RolandCombes  Identity Verified
Netherlands
Local time: 08:23
Spanish to English
+ ...
Probably need to change to WordFast Classic scheme Sep 18, 2010

I'm using Wordfast version 2.4.0.1 on an Intel Duo Core Mac Mini running Mac OS X 10.5.8.

Initially, I had the same problem with trying to unbind the Analyze key (Shift-space). When I would select the Analyze command from the list, no binding would appear below.

The fix was to change the scheme to Wordfast Classic. I selected it in the Scheme drop-down menu above the list of commands. It was on Wordfast and so I changed it to Wordfast Classic. Low and behold, the binding suddenly appeared below. I clicked on the Unbind Command button, which promptly removed it.

Now the Analyze function is no longer invoked by pressing Shift-space. Yay!

- Roland Combes


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Segmentation of Excel documents in Wordfast Pro 2.3

Advanced search


Translation news related to Wordfast





Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search