How to deal with a Trados-minded project in Wordfast Pro?
Thread poster: Federica D'Alessio

Federica D'Alessio
Italy
Local time: 02:07
Member (2005)
English to Italian
+ ...
Nov 19, 2010

Dear all,
I received a project from an agency which was clearly thought to be done with Trados, but I'm just in the process of entertaining myself by learning how to use my magical brand new WFPro and I'd really like to work on it using WF Pro, as I know this should be technically possible. In fact, the main reason why I bought WFPro is that I quite hate Trados and would like to get rid of it forever...furthermore, I'm a proud Mac user and although using Boot Camp with Windows 7, my hugest dream would be to get to work on every single project without never be forced to switch to Windows.
But! As for every big dream, I'm encountering many problems in the long path to realize this one.

I'd be very, very glad if some of you could help with this mess.

First: I received a .txt export from a huge memory (more than 300 thousands TUs).
Then I received 4 .ttx files, two of which were .xls, and the other two .xml.
First of all I converted the .txt TM export in TMX (I used ApsicXBench for this).
Then, I tried to open the .tmx with WFPro, but while making the conversion, I received many error messages of about TM strings containing errors, and I edited them one by one within the TM text file.

Finally, I received the last message:
local tm:////Users//XXXXX/XXXXX/XXXXX.txt Failed to connect. Translation memory file does not exist. Please note that this TM will be disabled.

As a result, I do not have any usable TM for this project yet.

After many tentatives I decided to try to go on by opening an empty TM and starting translation.
But when trying to open the ttx files, I received this message:

Error converting file.xml.ttx
Reason: TTX file must be segmented in Trados in order to opened in Wordfast.

The same message appears for all 4 files, both the .xml ones and the .xls ones.

So....what do I have to do with this now?
Can somebody help? At the moment I'm quite paralyzed with this and I'd like to try to find a solution before surrendering and coming back knocking on the Trados door.

Thanks a lot,
Federica


Direct link Reply with quote
 

Soonthon LUPKITARO(Ph.D.)  Identity Verified
Thailand
Local time: 08:07
Member (2004)
English to Thai
+ ...
Your client? Nov 19, 2010

Your client might not imagine how you work with *.ttx files in WFP (even they are supported by WFP). If you have a number of troubles through direct access of ttx files, try this method: http://www.translatum.gr/forum/index.php?topic=72020.0 It is quite intuitive and interesting.

Soonthon Lupkitaro


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 03:07
Member (2003)
Finnish to German
+ ...
If you cannot use the TM don't translate Nov 19, 2010

Your client will expect that you are able to use the TM. Did you get an analysis? Of course if there are no matches above 90 % the TM would be useless except for terminology search.
But without the possibility of using the TM I would not start translation.

You could ask someone (your client perhaps) to convert the TM to tmx so that you could import it into any other tool.


Direct link Reply with quote
 

Federica D'Alessio
Italy
Local time: 02:07
Member (2005)
English to Italian
+ ...
TOPIC STARTER
Thanks Nov 19, 2010

Heinrich Pesch wrote:

Your client will expect that you are able to use the TM. Did you get an analysis? Of course if there are no matches above 90 % the TM would be useless except for terminology search.
But without the possibility of using the TM I would not start translation.

You could ask someone (your client perhaps) to convert the TM to tmx so that you could import it into any other tool.


Thanks Heinrich for your advice,
actually I have a tmx, i made the conversion myself and the result was the one explained above, I'd like some help on how to solve it.
Thanks and thanks to Soonthon too, I'd try that way.
Federica


Direct link Reply with quote
 

Mette Melchior  Identity Verified
Sweden
Local time: 02:07
English to Danish
+ ...
You need to pre-translate the TTX-files in Trados first Nov 19, 2010

Soonthon LUPKITARO(Ph.D.) wrote:

If you have a number of troubles through direct access of ttx files, try this method: http://www.translatum.gr/forum/index.php?topic=72020.0 It is quite intuitive and interesting.

Soonthon Lupkitaro


The method described on this link is for Wordfast Classic which uses Word as interface, not Wordfast Pro. There might be other workarounds as well, but if you pre-translate the TTX files in Trados and check the option "Segment unknown sentences" (under Tools > Translate in Workbench) you can work on the files in Wordfast Pro. This is what the error message refers to.


Direct link Reply with quote
 
Claudio Porcellana  Identity Verified
Italy
How to deal with a Trados-minded project in Wordfast Pro? Nov 19, 2010

Hi all

there is no need to pretranslate a ttx as Worfast Pro opens and manages TagEditor files (both untranslated, partially translated or fully translated) smoothly

and about the memory, Worfast Pro doesn't manage tmx files, so I recommend using Olifant
http://okapi.sourceforge.net/Release/Olifant/Help/

with the "Import" feature and the "Check for invalid XML characters" option selected

then, you must filter and remove ALL EMPTY TUs that can crash CATs, finally export in a wordfast memory file (txt)

At this point translate the file with Worfast Pro and its txt memory

at the end you'll have a Worfast Pro txml unclean file and apparently you can only save it as a ttx clean file, but if you open this apparently clean ttx file you'll see that it's indeed an unclean ttx ...


and about the TM with your translations, again you must import/export it with Olifant

Claudio

[Modificato alle 2010-11-19 22:41 GMT]


Direct link Reply with quote
 

Federica D'Alessio
Italy
Local time: 02:07
Member (2005)
English to Italian
+ ...
TOPIC STARTER
Finally I could, but... Nov 22, 2010

Thanks everybody for your help!
I finally could work the files with WFPro but as Mette said, I had to pre-translate the files in Trados first. Until this passage, WF was not able to open them, it said that the files were not segmented and impossible to open (sorry I don't remember the perfect message but it was something like this).
I pre-translated in Trados, saved the Trados TM as tmx and then opened it with Wordfast. I had to cancel one by one all TUs with errors, and finally WF converted it into a Local TM.
[Claudio, I tried to use Olifant for this, but within Import I could not find anywhere the "Check for invalid XML characters" option, where is it? :S]
So now I have a good-functioning Wordfast TM but I fear that next time I receive TagEditor files I will have to do the same, pre-translating in Trados and then move to WF. I really would like to avoid this passage and I still dont' know if and how this could be possible.

I've to say that I'm quite allergic to every kind of informatics tricks, and that's exactly why I like WFPro (and Mac), much easier to understand and use than any other CAT I've tried, you know where everything you need can be found, that's not the same in SDL Studio, sort of labyrinth to me. So thanks a lot again for your help!

Have a nice day all,
Federica


Direct link Reply with quote
 
Claudio Porcellana  Identity Verified
Italy
"Check for invalid XML characters" option, where is it? Nov 22, 2010

Hi Federica

you must select and load a tmx memory first!
then in the secondary window that opens, you find in the middle:

Flag the imported entries
Ignore region differencies in language identifiers
Check for invalid XML characters
Ignore the following properties (with a drop down menu)

anyway, can you send me that ttx file?
I'm curious to see if my WF Pro opens it or not, as so far I never had problems to open a wide range of files

BTW, the WF Pro help says
Note: Wordfast Pro supports only those TTX files that are translated and segmented using tag editor. The TTX files must be renamed to match the source format if they need to be viewed in tag editor.

but as you received a job supposed to be managed with Trados, I'm asking myself why it was not translated and segmented using tag editor ?!?

may be as the LSP doesn't have indeed Trados, so may be you can do them a favour asking to translate with another CAT. so avoiding dangerous conversions ?
quite odd situation, to me ...


Claudio

[Modificato alle 2010-11-22 11:37 GMT]

[Modificato alle 2010-11-22 11:38 GMT]


Direct link Reply with quote
 
SandraMe
Local time: 02:07
English to Slovenian
+ ...
Only 100% matches are imported into Wordfast Pro Oct 13, 2011

Hello,
I have the similar problem as described above.
When I open the ttx file in Wordfast Pro, only those segments are visible, which are 100% match. Empty segments didn't appear.
I tried with Trados Workbench - Translate feature, but the problem is the same.
Thanks in advance for any hint.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to deal with a Trados-minded project in Wordfast Pro?

Advanced search


Translation news related to Wordfast





Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search