WFP does not connect to TM
Thread poster: Stefan Stefanov

Stefan Stefanov  Identity Verified
Bulgaria
Local time: 21:27
English to Bulgarian
+ ...
Apr 17, 2011

Hello,

I am having a serious problem that prevents me from continuing my work. Every time I move to a new segment (whether a blank one or editing already translated segments), the "Establishing TM connection" dialog flashes for a very short time and disappears. Results are NOT retrieved from the TM, it appears it simply cannot connect to the TM.

I have tried restarting WFP but to no avail.

Could this be because of the size of the TM - I have been working on a gigantic project and I am past the middle of it, meaning there are at least 60,000 units in the TM (1.51MB)?

I need help urgently, please!

[Edited at 2011-04-17 09:09 GMT]


EDIT: I changed the Fuzzy Match Threshold (from 60% to 65%) and the problem was suddenly fixed. So, I tried restarting WFP and the problem occurred again... and changing the threshold does not fix the problem

[Edited at 2011-04-17 09:23 GMT]


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 21:27
English to Arabic
TXML Apr 17, 2011

Dear Stefan,

If the TM did not work at all, I would say that you need to re-establish TM connection by removing and re-opening.

Now, I suspect that it could be related to the TXML. First of all, please make sure you have the latest version of WFP (info you did not mention). Then, open a fresh copy of the source text in WFP to generate a new TXML and see if the problem is fixed for the same problematic segments.

You can lower the Fuzzy Match Threshold (Edit menu > Preferences > Translation Memory > Fuzzy Match Threshold > 40) to get more matches, if possible.


I hope this helps. Please let me know.

---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net

[Edited at 2011-04-17 09:43 GMT]


Direct link Reply with quote
 

Stefan Stefanov  Identity Verified
Bulgaria
Local time: 21:27
English to Bulgarian
+ ...
TOPIC STARTER
Random Apr 17, 2011

Yasmin Moslem wrote:

Dear Stefan,

If the TM did not work at all, I would say that you need to re-establish TM connection by removing and re-opening.

Now, I suspect that it could be related to the TXML. First of all, please make sure you have the latest version of WFP (info you did not mention). Then, open a fresh copy of the source text in WFP to generate a new TXML and see if the problem is fixed for the same problematic segments.

You can lower the Fuzzy Match Threshold (Edit menu > Preferences > Translation Memory > Fuzzy Match Threshold > 40) to get more matches, if possible.


I hope this helps. Please let me know.

---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net



Hi Yasmin,

Thanks for the tip.

It seems this behaviour is random. I managed to get the TM working after several times ticking/unticking various options or changing the threshold in the TM section of the Preferences. But everytime I shut down WFP (latest version), the same is repeated.

I cannot do the second part of what you advise (open a fresh copy of the source to generate new TXML) because the client gave me TXML files without any source files (the TXMLs are created from a large, 500+ pages PDF, where the total content was split into 6 TXMLs of average length of 1900-2300 segments).

...
I've also noticed that WFP won't remember the change in spell checking setting - do I need to open a new thread about this? Before I used to use the MS Word spell checker but now I started using Hunspell, but every time I restart WFP, the setting rolls back to MS Word...


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 21:27
English to Arabic
Specific segments? Apr 17, 2011

Dear Stefan,

If you think that it is related specific segments, please send me the files and refer me to those segment IDs.

As for the spelling checker behaviour you mentioned, this has been fixed in the next version coming very soon.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Direct link Reply with quote
 

Stefan Stefanov  Identity Verified
Bulgaria
Local time: 21:27
English to Bulgarian
+ ...
TOPIC STARTER
Not segment related Apr 17, 2011

Yasmin Moslem wrote:

Dear Stefan,

If you think that it is related specific segments, please send me the files and refer me to those segment IDs.

As for the spelling checker behaviour you mentioned, this has been fixed in the next version coming very soon.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


Hi Yasmin,

No, it isn't specific segment related. If I now restart WFP, it won't be able to establish connection to the TM again, and I will have to try changing various options (randomly) in the TM section of Preferences to get it to connect to the TM. It doesn't matter where I am in the TXML. I can open it from the first segment and this behaviour will recur. I also tried "Commit to TM" and the picture was weird - both the "Commit to TM" dialog with the progress bar and the "Establish connection to TM" dialog were open - the latter kept popping up every half second, so it was a flashing of dialogs one over the other, until I hit "Cancel".


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 21:27
Member (2003)
Finnish to German
+ ...
Some options Apr 17, 2011

You could try to create a new TM, commit the translation to it and look if it helps. Size should be not problem generally. Did you re-organize the TM?
The problem might be related to your translation-file, who knows how they went about when creating it.
Good luck!


Direct link Reply with quote
 

Stefan Stefanov  Identity Verified
Bulgaria
Local time: 21:27
English to Bulgarian
+ ...
TOPIC STARTER
WFP cannot reorganize Apr 17, 2011

Heinrich Pesch wrote:

You could try to create a new TM, commit the translation to it and look if it helps. Size should be not problem generally. Did you re-organize the TM?
The problem might be related to your translation-file, who knows how they went about when creating it.
Good luck!


Hi Heinrich,

I have not reorganized the TM - WF Pro does not offer such an option. In fact, I can find no useful application of the TM editor at all, other than invert pairs.

I have just restarted WFP and the problem occurred again. So, I ticked the option "Perform TM lookup automatically" and it was fixed (connection was established). Apparently, ticking/unticking a random option or changing the threshold is the only way to establish connection to the TM.


......................
EDIT: Created a blank TM, committed all translations to it, restarted WFP and connection to TM was established successfully...

Then I reorganized the TM in WF Classic. Restarted WFP and the problem was back again

Old TM - 1654 KB (4712 TUs) / New TM - 1338 (4628 TUs).

[Edited at 2011-04-17 21:05 GMT]


Direct link Reply with quote
 

Gerry Vickers  Identity Verified
United Kingdom
Local time: 19:27
Member (2007)
Czech to English
+ ...
TM Lookup Apr 24, 2011

I don't know if my query is related, but it would be really great feature in Wordfast if when I click on 'TM lookup' and it finds the matching entry in the TM, I could copy and paste that section into the segment that I am currently working on instead of copying it down the slow way - this would save a lot of time. It would also be great if the buttons 'Find In Source', 'Find In Target' and 'Clear' actually did something instead of being apparently mere decorations.

I am using version 2.4.0.1

Thanks for any advice!


Direct link Reply with quote
 

Stefan Stefanov  Identity Verified
Bulgaria
Local time: 21:27
English to Bulgarian
+ ...
TOPIC STARTER
Unrelated Apr 24, 2011

Gerry Vickers wrote:

I don't know if my query is related, but it would be really great feature in Wordfast if when I click on 'TM lookup' and it finds the matching entry in the TM, I could copy and paste that section into the segment that I am currently working on instead of copying it down the slow way - this would save a lot of time. It would also be great if the buttons 'Find In Source', 'Find In Target' and 'Clear' actually did something instead of being apparently mere decorations.

I am using version 2.4.0.1

Thanks for any advice!


I think this is unrelated. It would, however, if what you're suggesting gets implemented in follow up versions (by the way, you could/should upgrade to 2.4.1).

The 'Find in Source' / 'Find in target' buttons work just fine. Are you writing your search query correctly? If you are looking for a phrase, use the "plus" sign in between, e.g.
find+this+phrase



Meanwhile, my problem presists, but I have found a way to fix it temporarily (each time I launch WFP) - I have to go to Translation Memory > New / Select TM > Click on the TM, then click Apply.

[Edited at 2011-04-24 18:51 GMT]


Direct link Reply with quote
 

Romeo Mlinar  Identity Verified
Portugal
Local time: 19:27
Member (2009)
English to Serbian
+ ...
Resident backup sw can lock a file Apr 24, 2011

In case there is some resident backup software on a computer (usually running as a "service" in the Task Manager) – it can lock the file for backup and block any operation until the backup is finished.

If: 1) the file is big 2) the connection is slow 3) the backup intervals happen too often – that can make work very difficult, if not impossible.

As for an immediate remedy: copy TM in a different folder (but only TXT file) and have WFP locate it.


Direct link Reply with quote
 

Daina Jauntirans  Identity Verified
Local time: 13:27
German to English
+ ...
Ctrl + Alt + M Apr 24, 2011

Gerry Vickers wrote:

I don't know if my query is related, but it would be really great feature in Wordfast if when I click on 'TM lookup' and it finds the matching entry in the TM, I could copy and paste that section into the segment that I am currently working on instead of copying it down the slow way - this would save a lot of time. It would also be great if the buttons 'Find In Source', 'Find In Target' and 'Clear' actually did something instead of being apparently mere decorations.

I am using version 2.4.0.1

Thanks for any advice!


I am using version 2.4.1, but if you click in the target field of the TM lookup and then click Ctrl + Alt + M, the target will be copied to your target translation field. Note that the whole text in the TM lookup field will be copied.


Direct link Reply with quote
 

Daina Jauntirans  Identity Verified
Local time: 13:27
German to English
+ ...
Another option? Apr 24, 2011

Stefan Stefanov wrote:
Meanwhile, my problem presists, but I have found a way to fix it temporarily (each time I launch WFP) - I have to go to Translation Memory > New / Select TM > Click on the TM, then click Apply.

[Edited at 2011-04-24 18:51 GMT]


I have also done this: Translation Memory > New / Select TM > Click on the TM, then click Edit, but don't change anything & click OK. It will say TM connection established & sometimes reorganize the TM - the only way I have found to reorganize the TM. Reorganizing in Classic caused me problems, so I have avoided it. Have to try that out again when I am done with this project.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

WFP does not connect to TM

Advanced search


Translation news related to Wordfast





SDL Trados Studio 2017 only €415 / $495
Get the cheapest prices for SDL Trados Studio 2017 on ProZ.com

Join this translator’s group buy brought to you by ProZ.com and buy SDL Trados Studio 2017 Freelance for only €415 / $495 / £325 / ¥60,000 You will also receive FREE access to our getting started eLearning program!

More info »
BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search