Hunspell doesn't work with WFP 2.4 on OS X 10.6
Thread poster: Per Riise

Per Riise  Identity Verified
Norway
Local time: 05:19
Member (2003)
English to Norwegian
+ ...
Apr 24, 2011

I bought WFP just after it was released, but I have yet to start using it. I've had several issues in the past that made me continue using Trados. I am, however, rather anxious to give WFP another try again, to rid myself of the darn virtualization ghost, but this time around, the spell checker won't work. I've tried to activate "Enable spell checking" and "Check spelling as you type". Then, when I want to do a spell check, I'm being told that spell check is not enabled. I've also received notifications that the spell check can't be found in the .wf_workspace/hunspell folder, so I downloaded my native language and put the files in that folder, to no avail.

I also did a complete uninstall/reinstall, using AppCleaner, but that didn't help, either.

Any advice?


 

esperantisto  Identity Verified
Local time: 06:19
Member (2006)
English to Russian
+ ...
Wrong place Apr 24, 2011

Per Riise wrote:

the spell check can't be found in the .wf_workspace/hunspell folder


In Linux/Windows they are in the WFP installation directory, most probably in MacOSX as well. But why did not you use the WFP built-in update feature? You can actually add a language manually (browse the WFP mail list archive in Yahoo! for details), but the procedure is not easy and straightforward.


 

Per Riise  Identity Verified
Norway
Local time: 05:19
Member (2003)
English to Norwegian
+ ...
TOPIC STARTER
Not that easy :-). Apr 24, 2011

Thanks for replying, esperantisto.

OS X doesn't use installation folders the same way it's being used in Windows and others. I've searched through the Internet, and the folder I'm referring to, seems to be the correct one (see this post: http://mac.proz.com/forum/wordfast_support/155143-mac_directory_wf_workspace_path_for_hunspell.html ).

I've also tried to add my language manually, but, like I stated in my initial post, it didn't take.

I forgot to mention that I've already tried the auto update feature, but Wordfast doesn't let me finish the update, firstly by not activating the "Finish" button after I've made my selections, and secondly because of the error message at the top of the Updates window, which says "Resulting configuration does not contain the platform"......whatever that means.


 

esperantisto  Identity Verified
Local time: 06:19
Member (2006)
English to Russian
+ ...
Sure, it did not Apr 25, 2011

Per Riise wrote:

I've also tried to add my language manually, but, like I stated in my initial post, it didn't take.


Simply copying the files does not work. Here’s what I’ve done to add Belarusian spellcheck (this language is not officially supported by WFP, inter alia):
1. In WFP install directory/plugins/ (well, to see what it is for Mac, try searching *.dic and *.aff files in your system), create a subdirectory following the pattern for other languages, thus org.gs4tr.editor.spellcheck.hunspell.dictionary.be_by_2.0.0.
2. Copy there the contents from the Ukrainian spellcheck directory (actually, any other would be fine).
3. Edit all auxiliary files there (plugin.properties , plugin.xml, MANIFEST.MF — just three) by changing uk_ua to be_by and, respectively, Ukrainian (Ukraine) to Belarusian (Belarus).
4. Copy my spellcheck files (be_BY.dic and be_BY.aff) to /dict.
5. Delete uk_UA.dic and uk_UA.aff.
Voilà!


 

Per Riise  Identity Verified
Norway
Local time: 05:19
Member (2003)
English to Norwegian
+ ...
TOPIC STARTER
Found the folder, still the same problem Apr 25, 2011

Thanks for your efforts, esperantisto.

I did find the proper path to the plug-ins folder. It turns out that when you click the "Restore Defaults" button, it switches back to the .wf_workspace/hunspell folder. All the proper dictionary files are present (including the one for my language). When pointing to the main folder (/Applications/Wordfast.app/Contents/Resources/Java/plugins), Wordfast lists all the available languages, including the one I'm looking for. Then I choose "Bokmal, Norway" from the list, go to Spelling and tick the "Enable spell checking" box and the "Check spelling as you type" box. After hitting the "Apply" button, I press F7 or launch spell check under the "Edit" menu, both of which only give me this message: "Warning: Spell check not enabled".

Something's probably wrong on a larger scale, since the Wordfast Update feature is inactive.

I just now noticed that if I go to "About Wordfast" and click "Plug-in Details", a list of errors are listed (com.aspose.cells and com.aspose.slides).

[Edited at 2011-04-25 10:00 GMT]


 

Yasmin Moslem  Identity Verified
Egypt
Local time: 05:19
English to Arabic
Norwegian Nynorsk (Norway) Apr 26, 2011

Per Riise wrote:

the spell checker won't work. I've tried to activate "Enable spell checking" and "Check spelling as you type".


Dear Per,

Not sure if I am right that you translate into Norwegian. If so, please create a project whose target language is Norwegian Nynorsk (Norway); the sell checker should work now.

I hope this helps.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Hunspell doesn't work with WFP 2.4 on OS X 10.6

Advanced search


Translation news related to Wordfast





SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running, helps experienced users make the most of the powerful features, ensures new

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search