Wordfast Demo: arbitrarily translating/not translating TUs
Thread poster: xxxSitiens
xxxSitiens
Sweden
Local time: 18:40
English to Swedish
+ ...
Jun 16, 2011

I'm trying to get the hang of the functions of the Wordfast Demo, partly because I have a large project perfectly suited for TM and Term list work, and partly because I'm going to increase my workload this year and start an enterprise.


So, the problem is that Wordfast only seems to be translating some TUs for me, but not others. For example is "Maintenance", a single word TU that appears on multiple occasions. I've saved it to the TM by Ctrl+Enter, and to the Term List by Ctrl+T. Yet, nothing happens when I encounter it the next time. The word is high-lighted, showing it has been added to the Term List, and it shouldn't be a fuzzy translation, because there's nothing else in the TU.

I haven't played around much with settings in the Demo. The fuzzy match threshold is 75%, I have opted to Use replaceables for higher TM matches, and Numbers Extraction. Other than that, nothing is changed.

I worked on this translation on another computer and e-mailed myself the TM-files. As I thought this might be the problem, I removed that TM and created another and loaded the translation into it. It didn't solve the problem, unfortunately.

On another note, can this have anything to do with the TU limit? My file is approx. 3 600 TUs, and this is how the limit works?

Thanks for the input!

/Alexandra


Direct link Reply with quote
 

SEA-words  Identity Verified
English to Italian
+ ...
Demo limitations and how terminology works in WF Jun 16, 2011

Hello Sitiens,
it looks like you have two problems:

1) TM is disabled - In the demo mode (i.e. the sw that can be freely downloaded and installed) you are allowed to use TMs with max 500 TUs. In fact, if you go to TM and select your current TM it will prompt a message stating that "You are limited to 500 TU in Demo mode. You need to to buy a registered license to remove this limit" and then "the TM will now be disabled". That is, the TM is disabled - that's why it doesn't works!

2) Terminology - There is no limit to terminology size, even in the demo version. However WF doesn't insert the translated term automatically, it just shows you in violet the term in the source segment. In the in the command, in the top left of your window, there are *orange* arrows that work the same way as the blue arrows used to select and insert/remove placeables.
Use the right orange arrow to select "maintenance" in violet, it will change its colour in the source segment, then use the down orange arrow to insert the translated term in the target segment.


I hope this is clear enough.


Direct link Reply with quote
 
xxxNMR
France
Local time: 18:40
French to Dutch
+ ...
Some answers Jun 16, 2011

There is no demo version of WF, you have a full working version. The only limit is the TM which should not exceed 500 segments. WF Pro takes the text as a whole, and I think that this one is too big.
Suggestion: first try WF on another, small file of one page, in order to see how it works. If it works (and it should), then cut your actual translation into 8 or 10 different parts. You will have to create a new TM for each part. Much hassle if you want to work for free.


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 18:40
English to Arabic
What is Ctrl+Enter! Use Alt+Down! Jun 16, 2011

Sitiens wrote:

I've saved it to the TM by Ctrl+Enter


Dear Alexandra,

What is Ctrl+Enter? You need to use Alt+Down to move between segments and save them into the TM.

Now, to fix what you already did:

1- Press Alt+End or click the toolbar button "Commit to TM" to save everything into the TM.

2- While working, make sure you move to the next segment using the toolbar button "Alt+Down".

3- Additional Option: You can activate Global Auto-propagation for exact segments on the same file (Edit menu > Preferences).


HTH,
Yasmin


Direct link Reply with quote
 

SEA-words  Identity Verified
English to Italian
+ ...
Demo says Jun 16, 2011

NMR wrote:

There is no demo version of WF, you have a full working version.


Wordfast offers a full-featured ***demo*** version that runs without a paid license for translation memories of up to 500 translation units, making it possible to use Wordfast on actual translation projects before you decide to purchase. This policy allows our customers to make a completely informed buying decision. [http://www.wordfast.com/store_download.html]



.....
....
...
..
.


Direct link Reply with quote
 
xxxSitiens
Sweden
Local time: 18:40
English to Swedish
+ ...
TOPIC STARTER
Thanks! (Ctrl should have been Alt) Jun 17, 2011

Dear Alexandra,

What is Ctrl+Enter? You need to use Alt+Down to move between segments and save them into the TM.

Now, to fix what you already did:

1- Press Alt+End or click the toolbar button "Commit to TM" to save everything into the TM.

2- While working, make sure you move to the next segment using the toolbar button "Alt+Down".

3- Additional Option: You can activate Global Auto-propagation for exact segments on the same file (Edit menu > Preferences).


Sorry, my mistake, I meant to write Alt+Enter, which is Confirm/Unconfirm a unit. I use Alt+Down as well, I am just not sure as of yet which button does exactly what, but this is, after all, a learning experience.

Thank you so much for your input! It makes it a little easier to understand what I'm doing, and trying to do.


Direct link Reply with quote
 
xxxSitiens
Sweden
Local time: 18:40
English to Swedish
+ ...
TOPIC STARTER
It helped! Jun 17, 2011

Paola Slajmer wrote:

Use the right orange arrow to select "maintenance" in violet, it will change its colour in the source segment, then use the down orange arrow to insert the translated term in the target segment.

I hope this is clear enough.


I tried it and it worked perfectly! Thank you very much, it will save me a lot of time with this text. It's incredible how much you can do in a CAT-tool, that I have no idea of yet.

Sincerely,
Alexandra


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 18:40
English to Arabic
Alt+Enter could be a disaster! Jun 17, 2011

Sitiens wrote:

Sorry, my mistake, I meant to write Alt+Enter, which is Confirm/Unconfirm a unit. I use Alt+Down as well, I am just not sure as of yet which button does exactly what, but this is, after all, a learning experience.

Thank you so much for your input! It makes it a little easier to understand what I'm doing, and trying to do.


Dear Alexandra,

I wrote a reply about Alt+Enter and then removed it as I noticed you wrote Ctrl+Enter. Well, why do you use Alt+Enter? It is simply for *preventing* your TUs from going to the TM. Unless you know what you are doing, do NOT use it. Now, add to the top of the list this step:

1- Go to Translation Memory menu > Confirm All (to fix what already unconfirmed).

Now, you can use Alt+End or the toolbar button (Commit to TM) to store everything to the TM.


===================================

This interactive video should give you a clearer idea about how to use Wordfast Pro:
http://www.wordfast.net/?kb=149-35

You can download Wordfast Pro's Manual at:
http://www.wordfast.com/docs/WF_Pro_2.4_User_Guide.pdf

You can also navigate Wordfast Pro up-to-date online help at:
http://www.wordfast.com/Wordfast_Pro/Wordfast_Pro_Help.htm

You can also watch useful Wordfast Pro videos at:
http://www.wordfast.com/support_learning.html
http://www.wordfast.com/tips_and_tricks.html


HTH,
Yasmin


Direct link Reply with quote
 

Alexey Slobukho  Identity Verified
Russian Federation
Local time: 19:40
English to Russian
+ ...
Another WF issue Jun 27, 2011

Hello everyone!
I've just started working with WF and I've this problem:
WF won't open certain entries if the glossary, thogh they certainly are there!

So, for instance, translatiang a single sentense I have a couple of terms highlighted and others (that I know should be highlighted too) stay unnoticed by the program. Sometimes I even have the same term highlithed and unnoticed in two consequent TUs. That's wierd...

I'm using "demo" version too (Classic 5 to be precise).

Any help will be much appreciated.
Thnx in advance.


Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 19:40
Finnish to French
untick 'Use fuzzy terminology recognition' Jun 27, 2011

Alexey Slobukho wrote:
So, for instance, translatiang a single sentense I have a couple of terms highlighted and others (that I know should be highlighted too) stay unnoticed by the program. Sometimes I even have the same term highlithed and unnoticed in two consequent TUs. That's wierd...

You probably have 'Use fuzzy terminology recognition' ticked for your glossary. Untick it for optimal results. Please note you may have to enter source terms in a certain way, depending on your source language. See 'terminology recognition' in the reference manual for details.

Alexey Slobukho wrote:
I'm using "demo" version too (Classic 5 to be precise).

The latest version is 6.01g. Terminology recognition works just the same in demo mode and in licensed mode.


Direct link Reply with quote
 

Alexey Slobukho  Identity Verified
Russian Federation
Local time: 19:40
English to Russian
+ ...
It doesn't help Jul 6, 2011

Thank you, Dominique, but it still doesn't work as it should. WF only sees some of the terms...
By the way, does WF recognize only the exact same form of a term as in the glossary?


Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 19:40
Finnish to French
It depends on your settings Jul 6, 2011

Alexey Slobukho wrote:
Thank you, Dominique, but it still doesn't work as it should. WF only sees some of the terms...

Please provide an example of a source segment containing glossary terms that are not recognized. Also mention how these terms have been entered in the glossary.

Alexey Slobukho wrote:
By the way, does WF recognize only the exact same form of a term as in the glossary?

It depends on your settings: do you have 'Use fuzzy terminology recognition' ticked or unticked. For best results, it should be unticked, but then you may have to enter source terms in a certain way in your glossary. This is described in details in the reference manual.


Direct link Reply with quote
 

Alexey Slobukho  Identity Verified
Russian Federation
Local time: 19:40
English to Russian
+ ...
An example of a typicfl WF failure Jul 7, 2011

So, here's an example of what I was talking about:

The source segment (in Russian):
"...подрывы взрывоопасных предметов (ВОП) при производстве земляных работ на участке строительства"

The target segment (in english):
Detonation of explosive objects (EO) during the ground works at the construction site;

Here WF has recognized only one term, or to be precise - the abbreviation "ВОП" (EO), though the glossary features the following terms that appeared in the segment:
взрывоопасных предметов / explosive objects
земляных работ / ground works
участке строительства / construction site

The terms were put into the WF glossary by the method specified in the manual at the WF site (namely: source term-Tab-target term) or by using "Ctrl-Alt-T" hot keys in the course of translation sections.


Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 19:40
Finnish to French
It does work here Jul 7, 2011

Alexey Slobukho wrote:
The source segment (in Russian):
"...подрывы взрывоопасных предметов (ВОП) при производстве земляных работ на участке строительства"

though the glossary features the following terms that appeared in the segment:
взрывоопасных предметов / explosive objects
земляных работ / ground works
участке строительства / construction site

I entered these three terms in a sample glossary and when I opened the above segment, they were recognized without problems, as you can see here:

http://screencast.com/t/QBkluXib


Direct link Reply with quote
 

Alexey Slobukho  Identity Verified
Russian Federation
Local time: 19:40
English to Russian
+ ...
No surprise Jul 8, 2011

Well, I'm not surprised, because I'm sure that the problem is not in the terms themselves, but in the way WF operates...

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Wordfast Demo: arbitrarily translating/not translating TUs

Advanced search


Translation news related to Wordfast





LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search