WF Pro error: 'could not create the java virtual machine'
Thread poster: xxxIrene Berger

xxxIrene Berger

Sep 29, 2011


Yesterday I discovered that I could no longer open Wf Pro (version 2.4.1.).
The error message appearing was: "Could not create the Java virtual machine".
After I clicked OK, another, much longer error message appeared (which, unfortunately, I was unable to paste into this message, even though I can paste it into Word....)

I installed this version 2.4.1. of Wordfast Pro in December 2010 and have so far been able to use it without problems for a webinar through one of my clients and to test the program for myself. Now I needed it for a translation job, and suddenly I was unable to open the program. I have no idea what caused this error.

What I did after the error message:
I downloaded the latest version of WF Pro (, restarted my computer: same error messages.
I downloaded the most recent version of Java, restarted my computer: same error message.
I contacted my client (through whom I did the Wf Pro webinar); they advised me to uninstall and install 2.4.2 instead, the most stable version apparently.
So I did that, restarted my computer: and still I am unable to start up Wf Pro.
Same error messages. My client did not know what else to do; neither do I...

Does anybody know how to solve this problem?

Thank you!


Direct link Reply with quote

Yasmin Moslem  Identity Verified
Local time: 19:30
English to Arabic
How to uninstall Sep 29, 2011

Dear Irene,

If you still have problems, you can completely uninstall Wordfast Pro. When you are asked to keep configuration files, answer with "NO", do not forget "NO".

Make sure you first back up or Export your glossaries, if any. If you need your glossaries, open the "glossaries" folder found in .wf_workspace folder and copy the txt files to a safe location so that you can Import them later.

Then, try re-installing the latest version of Wordfast Pro; hopefully, it could resolve that.

I hope this helps. Please let me know.


Direct link Reply with quote

Edward Vreeburg  Identity Verified
Local time: 18:30
Member (2008)
English to Dutch
+ ...
lets think Sep 29, 2011

I think I had similar issues when I accidentally moved the WF program files into a different directory... Just check to see that the path for the icon still refers to the actual location of the files

but if you reinstalled the whole thing is should have worked by now...


Direct link Reply with quote

xxxIrene Berger

problem solved! Sep 29, 2011

Hi Yasmin and Ed,

Thanks for your responses!
I followed Yasmins advice, uninstalled the Wf Pro version first, not keeping configurations etc, then restarted my computer, downloaded the most recent Wf Pro version ( and installed the program on another drive of my computer (my C drive was pretty full - maybe that had something to do with it?)

And when I next tried to open Wordfast Pro, it worked!

So thank you both!

Kind regards,

Direct link Reply with quote

To report site rules violations or get help, contact a site moderator:

You can also contact site staff by submitting a support request »

WF Pro error: 'could not create the java virtual machine'

Advanced search

Translation news related to Wordfast

SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »

  • All of
  • Term search
  • Jobs
  • Forums
  • Multiple search