WF Pro: Problem setting memory preferences, crashing upon right-click
Thread poster: eccotraduttrice

eccotraduttrice
United States
Local time: 14:55
Italian to English
+ ...
Dec 29, 2011

I'm having two problems - the first is that I can't change the memory in the memory preferences. I set it to 1470 MB, it tells me I have to restart the program, I do, and it is right back to 256 MB upon restart.

The second is if I right-click in the translated text column, the program freezes and crashes. I use right click to cut, copy, and paste all the time so it is difficult to remember that I can't do that in WF Pro.

Anyone else have these problem, and/or know how to fix them?icon_smile.gif

Thanks!


 

Yasmin Moslem  Identity Verified
Egypt
Local time: 21:55
English to Arabic
Update Java Dec 30, 2011

Chiara di Benedetto Brown wrote:

I'm having two problems - the first is that I can't change the memory in the memory preferences. I set it to 1470 MB, it tells me I have to restart the program, I do, and it is right back to 256 MB upon restart.


It seems you run some security software that prevents WFP from changing the file on the system partition. One thing to try is to adjust the Wordfast.ini manually. If you have installed Wordfast to the C: partition, it should be at: C:\Program Files\Wordfast\Wordfast.ini

You can the default value: -Xmx256m

Change it to be: -Xmx1024m

or -Xmx1470m

I hope this helps. Please let me know.

Chiara di Benedetto Brown wrote:

The second is if I right-click in the translated text column, the program freezes and crashes. I use right click to cut, copy, and paste all the time so it is difficult to remember that I can't do that in WF Pro.


I hope you had mentioned your OS and WFP version.

Please download and install the latest Java version, and then restart your machine. If you are on Windows, here is the link:
http://www.java.com/en/download/index.jsp

You can download and install the latest version of Wordfast Professional available at:
http://www.wordfast.com/store_download.html

If you run Windows Vista or 7, it is better usually to lower the UAC level during installing, licensing and updating Wordfast Pro. You can turn it on later. For more information, please have a look at the second part of this page:
http://www.howtogeek.com/howto/windows-vista/disable-user-account-control-uac-the-easy-way-on-windows-vista/

Also, please disable any security/anti-virus software for a while until you finish the installation. Try the same while it is active or inactive and see the difference.


Could you please try that and give me an elaborated feedback.


---
Best regards,
Yasmin Moslem

Wordfast Support Team
www.wordfast.com | www.wordfast.net


 

eccotraduttrice
United States
Local time: 14:55
Italian to English
+ ...
TOPIC STARTER
It worked, thank you! Dec 30, 2011

Hi Yasmin --

Thanks so much for your reply. I am running Windows 7 and I had not upgraded to the latest version of WFP.

Your instructions appear to have worked -- I went and changed the .ini file, downloaded and installed the latest version of Java and the latest version of WFP. My UAC level was already fairly low so I left that as is, and I didn't do anything to my security software. I then restarted my computer.

Upon restart, I see that the memory is set to 1470 and it is possible for me to right click and copy in the translated text column without the computer crashing - wonderful!

Thanks again!!!

Chiara


 

Yasmin Moslem  Identity Verified
Egypt
Local time: 21:55
English to Arabic
Great! Thanks! Dec 31, 2011

Dear Chiara,

I am happy that WF Pro works for you properly now. Many thanks for your feedback!

Kind regards,
Yasmin


 

isabellev50  Identity Verified
Spain
Local time: 21:55
Member (2006)
Spanish to English
+ ...
Unable to change memory preference settings and unable to save Wordfast.ini changes: access denied Feb 28, 2012

Hi Yasmin,

I am having the same problem as Chiara (on Windows 7, WF Pro 2.4.4).

I have followed all of the instructions provided (and downloaded/executed the Java update) but I can't seem to save the modified wordfast.ini file: all I get is an 'access denied' message...

Can you help please?

Thanking you in advance,

All the best,

Isabelle


 

isabellev50  Identity Verified
Spain
Local time: 21:55
Member (2006)
Spanish to English
+ ...
More details on impossibility to save modified wordfast.ini Feb 28, 2012

Sorry Yasmin,

I forgot to mention that when trying to save wordfast.ini after changing Xmx256m to Xmx1024 or 1470, as follows,

-vm
C:\Program Files (x86)\Wordfast\jre\bin\javaw.exe
-data
@user.home\.wf_workspace
-vmargs
-Xms64m
-Xmx1024m
-Declipse.log.size.max=400
-Dupdatesite.homebase=http://www.wordfast.com/wfupdate
-Dlicense.how_to=false
-Dterminal.server=false
-Djava.ext.dirs=C:\Program Files (x86)\Wordfast\jre\lib\ext;C:\Program Files (x86)\Wordfast\extensions
-Dbuild.timestamp=20111209-0937


I get the following message:

Wordfast.ini already exists, do you wish to replace it?
-->Yes
-->Access is denied


 

Yasmin Moslem  Identity Verified
Egypt
Local time: 21:55
English to Arabic
Permissions Feb 28, 2012

Dear Isabelle,

Are you working on a user with the administration rights?

To be able to change this file:

- You need to switch to a user with the administration rights.
- Right-click the file and select "Properties" > "Security".
- Click "Edit". Select "Users", and under "Allow", check "Full Control".
- Click "OK" > "OK".

HTH,
Yasmin


 

isabellev50  Identity Verified
Spain
Local time: 21:55
Member (2006)
Spanish to English
+ ...
wordfast.ini issue resolved, thank you! Feb 29, 2012

Thank you so much for all your help Yasmin,

It works fine now: thanks to you instructions, I managed to change the value on the wordfast.ini file to 1024 (although it wouldn't accept the higher value of 1470 for some reason) and the file now saves fine, although the format of the PDF wasn't completely maintained.

All the best,

Isabelle


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

WF Pro: Problem setting memory preferences, crashing upon right-click

Advanced search


Translation news related to Wordfast





memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search