Double .tmxl files in Wordfast Pro
Thread poster: B D Finch

B D Finch  Identity Verified
Local time: 02:10
Member (2006)
French to English
+ ...
Feb 15, 2012

I have been translating a multi-file project. As I completed translation on each file, I committed the changes to the TM, saved both the file and the translated file and then closed the tmxl file and opened the next one for translation.

Having translated the final file, I wanted to check each tmxl file again to incorporate any changes arising from insights when translating subsequent files and then to save each translated file again for proof reading on a paper printout. However, I have discovered that instead of having a neat arrangement of files:

filename.doc, filename_EN-GB.doc and filename_EN-GB.tmxl

I had:

filename.doc, filename_EN-GB.doc, filename_EN-GB.tmxl and filename.tmxl

What is going on? Which of the two tmxl files should I have opened for editing?
Now, having closed the files and looking at my files in Windows Explorer, I see that the filename.tmxl version has disappeared from all but one file, where it is there but no filename_EN-GB.tmxl.



Lianne van de Ven  Identity Verified
United States
Local time: 20:10
Member (2008)
English to Dutch
+ ...
Double means saved twice Feb 23, 2012

Not sure I understand what you have done (you must have saved the files as "filename_EN-GB" and also as "filename" when saving them as txml).

Here is how I do it:

Files to translate: a.doc, b.doc and c.doc
You will be making txml versions of these documents.

Open all files (at once) in WFP. These files have the Word symbol at the left on their tabs and are named a.txml, b.txml etc (in the tab), but they are not saved as txml's yet.
The only save options at this point are: "save as" or "save translated file" (but it has not been translated yet)

So choose "save as" for each file, removing "copy of" out of the name and leave the rest (including .doc).
Preselected is already txml as file type. Select "save", either in the same or in a separate folder.

This saves them named as a.doc.txml, b.doc.txml and c.doc.txml

(This naming helps to remember that they were not pdf's for example (in which case they would automatically be named a.pdf.txml etc.)

You can now close all tabs with the word symbols at the left and you'll have proper txml files open.
They have the WFP editor symbol on their tabs.

Now you have prepared proper txml files and you can choose to leave all files open or just one.
Then start translating. When finished, press save.

Choose "save translated file" only at the end, after your final edits.
This automatically saves it as monolingual .doc output file (.doc file type is preselected).

Hope this clears it up for you.


To report site rules violations or get help, contact a site moderator:

You can also contact site staff by submitting a support request »

Double .tmxl files in Wordfast Pro

Advanced search

Translation news related to Wordfast

SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »

  • All of
  • Term search
  • Jobs
  • Forums
  • Multiple search