Pages in topic:   [1 2] >
Wordfast Classic: my .tmx exports appear corrupted in Trados
Thread poster: Céline Mélard

Céline Mélard
Local time: 22:06
English to French
+ ...
Oct 16, 2012

Hello everyone,

I come to you with a recurring problem. Whenever I export one of my TM in .tmx, it appears that the export is corrupt. If I open my tmx memory with a text editor, I can see that all accented letters and special characters are replaced by other accented capitals. Such as :

Les prÈparatifs battent leur plein pour le Symposium national díurologie organisÈ par XXX le xx†mois†2012 ‡ Bruxelles.

The small "é" are replaced by capital É, the apostrophe is replaced by í, the indivisible spaces became crosses and my "à" a weird equal sign.

When I was first made aware of the problem by one of my clients, I tried upgrading my Wordfast 6.01g to the new version (6.03t). But the problem remains.

For your information, I am working on an iMac, with Word for Mac 2011.

Has anyone ever had this problem? If yes, did you figure out a solution? I can't find anything online...

Thanks for your help!


Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 23:06
Finnish to French
Encoding problem when text files travel from Mac to PC Oct 16, 2012

Céline Mélard wrote:
For your information, I am working on an iMac, with Word for Mac 2011.

This is the cause of your problem: you need to pay extra attention to text files when sending them from Mac to PC (or vice-versa), because of the different ways the respective OS deal with encoding. The same also applies when using a native Wordfast TM under Mac and PC.

The easiest way to make sure text files keep their correct encoding is to paste the content in a Word document, save as DOC/DOCS, move that from Mac to PC (or vice-versa) and then save back as TXT. The same approach should work with TMX. If you only have a Mac and no PC, the recipient needs to do it on the receiving end.

An easier way is to exchange uncleaned documents, as they travel without problems from Mac to PC and will let the PC user update his/her Wordfast or Trados TM.

[Edited at 2012-10-16 11:41 GMT]


Direct link Reply with quote
 

John Fossey  Identity Verified
Canada
Local time: 16:06
Member (2008)
French to English
Try Olifant Oct 16, 2012

I have also had similar problems exporting TMX from Wordfast Classic. Somtimes I have exported it using Olifant rather than WF - it can convert a WF t.xt TM to TMX. It's not always foolproof, however.

Direct link Reply with quote
 

Céline Mélard
Local time: 22:06
English to French
+ ...
TOPIC STARTER
Olifant not for Mac Oct 16, 2012

Thanks for your answers, Dominique and John.

Sadly, I apparently can't run Olifant on my mac, it is Windows only.

As for using a PC to copy my files, I could do it if it were only for a one shot, but I can't afford to constantly switch between my mac and a PC every time I have to send a translation. It would take me too much time, I'm afraid. For now I still send uncleaned files to my client but I'd still like to figure out how I can get a usable export.


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 00:06
Member (2006)
English to Russian
+ ...
UTF-16 Oct 16, 2012

Just make sure your TMX files are saved to UTF-16 (Unicode) encoding when exporting, and everything will be fine. And to make it, keep your TMs in Unicode. In the TM Editor, choose the special filter of rewrite to Unicode or something like this. Refer to the user manual.

[Edited at 2012-10-16 15:01 GMT]


Direct link Reply with quote
 
FarkasAndras
Local time: 22:06
English to Hungarian
+ ...
Mac vs PC Oct 16, 2012

Dominique Pivard wrote:

Céline Mélard wrote:
For your information, I am working on an iMac, with Word for Mac 2011.

This is the cause of your problem: you need to pay extra attention to text files when sending them from Mac to PC (or vice-versa), because of the different ways the respective OS deal with encoding. The same also applies when using a native Wordfast TM under Mac and PC.



Really? I've never heard of that and I've actually deveoped apps that generate TMX files on mac so I assume users would have told me about the problem by now. Can you be specific about what the issue is? I.e. what do macs and PCs do differently? They do use different end-of-line characters by default but that's not the issue here. Other than that, txt (XML, TMX) files should be generated and read exactly the same on the two platforms. They might have different deafault or preferred encodings but they can certainly read each other's preferred encodings.


To me, the issue appears to be a bug in Wordfast. Try exporting a TM in Wordfast and opening it on your mac with a text editor right away. Is it corrupted? What encoding does the text editor report for the file? What encoding does Wordfast claim to be generating? What encoding is listed in the TMX header? There's an encoding mismatch somewhere, and one needs to find out where it is to fix it.
Of course, if Wordfast has a setting for generating TMX files in various encodings, you can just try one that's different from the default. UTF-8 and UTF-16 (often incorrectly labeled as "Unicode") should both work, so whatever the default is, try the other one.

[Edited at 2012-10-16 15:18 GMT]


Direct link Reply with quote
 

Céline Mélard
Local time: 22:06
English to French
+ ...
TOPIC STARTER
Header Oct 16, 2012

So I've just tried to export another TM in TMX and opening it right away with an editor but the issue remains.

How can I change the encoding? (I've tried changing it through the Editor, via Preferences, but it's not doing anything).

Here's a copy of the header of the TM in .tmx






Again, thanks to everyone who's trying to help!


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 00:06
Member (2006)
English to Russian
+ ...
Provide more details Oct 17, 2012

Céline Mélard wrote:

How can I change the encoding? (I've tried changing it through the Editor


Describe in details what you did.


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 00:06
Member (2006)
English to Russian
+ ...
If it’s really UTF-16 Oct 17, 2012

…try manually adjusting the very first line to:

<?xml version="1.0" encoding="UTF-16"?>


Direct link Reply with quote
 

Céline Mélard
Local time: 22:06
English to French
+ ...
TOPIC STARTER
Details Oct 17, 2012

I opened the .tmx with TextEdit. Clicked on Preferences, tab "Ouverture et Enregistrement" (opening and saving in English?), then tried to change encoding on all 3 places possible (2 for text, 1 for html) as you can see on this screenshot : .

Then I closed, tried another export, opened it with TextEdit and sadly saw nothing had changed.


Direct link Reply with quote
 

Céline Mélard
Local time: 22:06
English to French
+ ...
TOPIC STARTER
Doesn't work either Oct 17, 2012

esperantisto wrote:

…try manually adjusting the very first line to:





I tried that, also with "UTF-8" but it doesn't work either :/


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 00:06
Member (2006)
English to Russian
+ ...
Now it seems clear Oct 17, 2012

Céline Mélard wrote:

I opened the .tmx with TextEdit.


Did it open correctly? You failed to mention.

change encoding on all 3 places possible (2 for text, 1 for html)


If the file opens correctly, change the encoding for file saving (lors de l’enregistrement) to UTF-16 and re-save the file.

P. S. That TextEdit looks like a very poor program. Try something good, such as jEdit.


Direct link Reply with quote
 

Céline Mélard
Local time: 22:06
English to French
+ ...
TOPIC STARTER
Komodo? Oct 17, 2012

The TM opened, but the characters are all messed up.

I've tried changing the encoding with Komodo (I forgot I had this Editor) and I've tried a few different encodings (UTF-16 Little endian, UTF-16 big endian, UTF-8, ... ) but nothing worked. I'm beginning to think that this is hopeless

I really appreciate that you tried to help me but I can't possibly take any more of your time for this. If it persists I think I'll purchase the hotline help and get them to figure out the problem.

Thanks again!


Direct link Reply with quote
 

Meta Arkadia
Local time: 04:06
English to Indonesian
+ ...
TextWrangler Oct 17, 2012

esperantisto wrote:
P. S. That TextEdit looks like a very poor program.

Apart from the name, there's nothing much wrong with TextEdit. It's a great app, I use it all the time. For word processing. The default file format is RTF. For a task like the current one it is just about completely unsuitable. For editing, I use TextWrangler (free), by far the most popular text editor for the Mac.
But thank you for mentioning jEdit, esperantisto, I'll give it a try. It's free as well, and it's cross-platform.

Cheers,

Hans


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 00:06
Member (2006)
English to Russian
+ ...
Like what? Oct 17, 2012

Céline Mélard wrote:

The TM opened, but the characters are all messed up.


How do they look like?


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Wordfast Classic: my .tmx exports appear corrupted in Trados

Advanced search


Translation news related to Wordfast





LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search