Google API key problems in WordFast Pro
Thread poster: johndel
johndel  Identity Verified
United States
Local time: 00:32
English to Spanish
Jan 15, 2013

Hi, I've tried to use two different Google Translation API keys to set up machine translation in WordFast Pro 3.1.3 but got the following message: "Error while parsing list of supported languages." The selected languages were English and Spanish, so I can't imagine what the problem might be.

Any ideas?


Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 10:32
Finnish to French
exact languages Jan 15, 2013

What are the exact languages of: 1) your project, 2) your TM? You can see the project languages under File > Open project (they appear as "Source Locale" and "Target Locale"). For the TM, it's under Translation Memory > New/select TM > Local TM properties.

I wasn't aware of the existence of 3.1.3, which appears to have been released very recently. According to the release notes, there shouldn't be a big difference compared to 3.1.2. All three MT services work in 3.1.2 (I just checked). I'm currently downloading 3.1.3, but it's painfully slow.

Have you checked whether your API key works in other tools, eg. Wordfast Anywhere or MemSource?


Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 10:32
Finnish to French
MT OK in 3.1.3 Jan 15, 2013

Dominique Pivard wrote:
I wasn't aware of the existence of 3.1.3, which appears to have been released very recently. According to the release notes, there shouldn't be a big difference compared to 3.1.2. All three MT services work in 3.1.2 (I just checked). I'm currently downloading 3.1.3, but it's painfully slow.

OK, 3.1.3 is now installed, and Google Translate, Microsoft Translator and Worldlingo all work fine, as expected. The problem must be with your key(s). Why do you have two API keys anyway?

Do you have a green light for the Translate API in your Google Console?



Direct link Reply with quote
 
johndel  Identity Verified
United States
Local time: 00:32
English to Spanish
TOPIC STARTER
API key issues with Google and Microsoft Translators Jan 15, 2013

I've been trying and retrying to get MTs going in Google, MS, and Worldlingo. The reason why I had 2 different keys for Google is that I canceled one and created another one to see if the new one might work--but the same thing happened. The tests don't work, and I get language-oriented error messages for all but Wordlingo, which connects just fine. I do have a green light for the Google key. I've not yet tried Anywhere but will do so in the next day or so--I've got work to do. . . .

Here are the error messages--
Google: Couldn't detect if languages are supported. Server message: Error while parsing list of supported languages. Please note that Google MT will not be used.

Microsoft: Couldn't detect if languages are supported. Server message: ACS50012: Authentication failed. Trace ID . . . . Please note that Microsoft MT will not be used.

Let me pt out that I've just installed WordFast Pro and only have one translated practice doc so far. Ultimately, the languages appear to be English and generic Spanish in the preferences, but only when I've highlighted the practice doc, which shows the language prefs at bottom of table. I have old files with localized varieties from Argentina, Spain, and Latin America but I've not actually used them with WF Pro. ???

I'm totally confused that I can't connect with the Google or MS but seem to be able to connect to Worldlingo. BTW, I'm using a MacBook Pro with the newest OS.

Your help is appreciated!


Direct link Reply with quote
 
johndel  Identity Verified
United States
Local time: 00:32
English to Spanish
TOPIC STARTER
All API keys work in WF Everywhere Jan 15, 2013

I quickly opened an Everywhere account, inserted keys in all 3 MTs we've mentioned, and all tested perfectly. Sooo it seems I've done something in WF Pro to mix up language descriptors but can't figure out what. Right now I've seen EN_US (or something like that) and ES for generic Spanish (all regions). Previously I had used localized descriptors for various files in Classic but haven't reused any of these docs (they're just in file folders) in WF Pro, only the one test doc I mentioned.

Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 10:32
Finnish to French
Just create a brand-new project Jan 16, 2013

johndel wrote:
I quickly opened an Everywhere account, inserted keys in all 3 MTs we've mentioned, and all tested perfectly.

First of all, it's Anywhere, not Everywhere
Secondly, if you are using Google Translate, Microsoft Translator and Worldlingo (the three supported MT providers in Wordfast Pro), only the first two require credentials.

johndel wrote:
Sooo it seems I've done something in WF Pro to mix up language descriptors but can't figure out what. Right now I've seen EN_US (or something like that) and ES for generic Spanish (all regions). Previously I had used localized descriptors for various files in Classic but haven't reused any of these docs (they're just in file folders) in WF Pro, only the one test doc I mentioned.

Just create a brand-new project and a brand-new TM in Wordfast Pro. Then open a document in that project and see if you are able to use Google Translate and Microsoft Translator with it.

If you need to use TM's that originate from Classic, you can use find/replace in a text editor so that their language codes match what Pro expects.

I would have thought MT in Wordfast Pro looks at language codes in the project, not in the TM.


Direct link Reply with quote
 
johndel  Identity Verified
United States
Local time: 00:32
English to Spanish
TOPIC STARTER
Continuing MT problems in WF Pro Jan 16, 2013

I tried a new project and new TM but it still didn't work with Google or MS. Wordlingo works great except for the awful translations. I need to back off to concentrate on other things for a day or so. Thanks for suggesting that I go thru Classic TMs and find/replace the language descriptors. I had seen this suggested elsewhere. I'll do that before returning although I'm doubtful that it will make a difference. . . . I might just re-install from scratch and put all my WF files in a separate folder (if I can find all the files!).

Well, thanks for your help. Like most things, it's probably something simple that I've not yet seen.


Direct link Reply with quote
 
johndel  Identity Verified
United States
Local time: 00:32
English to Spanish
TOPIC STARTER
MT problems resolved Jan 18, 2013

Thanks for your help but the final solution was something I hadn't expected. Ultimately, someone in a Google forum suggested I use the Cmd-V command to paste the keys into the MT prefs in Wordfast, that is, instead of trying to type them without making a mistake. Although I had carefully retyped them repeatedly, the MTs never worked until I was able to paste them with this command.

For some reason, in WF Pro on my MacBook Pro, I didn't find any drop-down menu for copy/paste and was unable to right-click either, which meant I had to retype the keys. Thanks to the Cmd-V suggestion, everything is working now. I'm grateful for other suggestions too since I was able to salvage previous Classic TMs by the find/replace method to correct lang codes as well as to rework my glossaries in Excel instead of dealing with problematic tabs/spaces in TextEdit.

Now on to more important issues since MTs often require more editing than they're worth.

Happy translating!

--johndel

[Edited at 2013-01-18 21:10 GMT]


Direct link Reply with quote
 

Claire Wright  Identity Verified
Local time: 03:32
Member (2007)
English to French
+ ...
having the same issue Aug 13, 2015

and trying to do what you did....

Direct link Reply with quote
 

Ana Carla Guimarães  Identity Verified
Australia
Local time: 19:32
English to Portuguese
I am getting the same error and I also tried to copy and paste the API key, but it didn't help Jun 18

I don't have a MAC book, so maybe there's another trick with Windows to figure out why I am getting the same error? I know that Portuguese and English are supported languages, so not sure why it's not detecting if they can be supported.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Google API key problems in WordFast Pro

Advanced search


Translation news related to Wordfast





CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search