Wordfast Pro 2.4.1 Html files - Norwegian special characters garbled when translated file saved.
Thread poster: Kjell Thornes

Kjell Thornes  Identity Verified
Spain
Local time: 13:42
Member (2005)
English to Norwegian
+ ...
Jan 16, 2013

I'm working on some html files in Wordfast Pro 2.4.1. The target text includes some Norwegian special characters which display as normal in the editor and in the MS Word preview inside Wordfast Pro, but when I save the translated file, the resulting html file shows for instance "æ" instead of the correct "æ". This happens in Word, Firefox and IE. It displays correctly in Opera (which is developed by Norwegians). I suppose it has something to do with which character set is used when converting txml (which Wordfast has converted the original html file into) to html , but I can't find any relevant settings. Any help?

Direct link Reply with quote
 

Kjell Thornes  Identity Verified
Spain
Local time: 13:42
Member (2005)
English to Norwegian
+ ...
TOPIC STARTER
No reply yet ... Jan 17, 2013

No reply yet, and I've been unable to find a solution myself. The best workaround I can think of is to open the finished file in word, run search/replace for the characters in question and save as html. Not ideal.

Just to get some response: has anyone else had problems with special characters when working with html files? Has anyone got a suggestions of settings/preferences/options that might be relevant?


Direct link Reply with quote
 
Extra Consult
Belgium
Local time: 13:42
Member (2008)
English
UTF8 and ANSI Jan 17, 2013

We've had this problem with html before, in some languages. You should check the encoding of the files, as sometimes UTF becomes ANSI after translation, and the ANSI character encoding has no way of displaying special characters.

You can check the encoding with Notepad++ for example, and even try and convert one to UTF8. However, if you have a lot of HTML files, you should take a look at UTFCast, which can batch convert files from ANSI to UTF.

If you need more help with Notepad++ or converting, let me know, and I'll send you some pics or a short screencapture.

Kind regards,
Geert


Direct link Reply with quote
 

Kjell Thornes  Identity Verified
Spain
Local time: 13:42
Member (2005)
English to Norwegian
+ ...
TOPIC STARTER
Good suggestion, but ideally Wordfast should just work Jan 17, 2013

Thanks for the reply and the suggestion. It will surely be a faster workaround than the one I came up with, but it's still a workaround. Is there anyway to set the encoding within Wordfast Pro?

A quick test in Wordfast Classic in MS Word gave good results, so if all else fails, I can do it in Word.


Direct link Reply with quote
 
HTML encoding in WFP Jan 17, 2013

Dear Kjell,

Kjell Thornes wrote:

Thanks for the reply and the suggestion. It will surely be a faster workaround than the one I came up with, but it's still a workaround. Is there anyway to set the encoding within Wordfast Pro?


Please go to Edit menu > Preferences > Formats > Default HTML Filter > Encoding, select the encoding of your HTML (which you can know if you open it in NotePad), and click OK.

---------------

Note 1: You are using an outdated version of WF Pro. Please download and install the latest version of Wordfast Professional available at: http://www.wordfast.com/store_download.html

If you are on Windows, when you install the new version, it will ask you to uninstall the old one; there is no other option. But when it asks you to keep configuration files, select "Yes".

Note 2: If you have more questions, and to get quick answers, please open a hotline support ticket. To open a new hotline ticket, log-in at wordfast.net with your login email and password mentioned on your invoice. Click on 'Contact the Hotline' and submit your ticket.

HTH,
Yasmin


[Edited at 2013-01-17 10:38 GMT]


Direct link Reply with quote
 

Kjell Thornes  Identity Verified
Spain
Local time: 13:42
Member (2005)
English to Norwegian
+ ...
TOPIC STARTER
Tried iso-8859-1, iso-8859-15 and UTF-16 ... no luck so far Jan 17, 2013

I tried changing the setting to UTF-16, iso-8859-1 and iso-8859-15, but no luck. I made sure to apply the changes and restarted WF PRO just in case. I also made a fresh import of the test file, translated it again and exported it with the new settings. The result is the same.

Is updating to the new version likely to make a difference? If not, I'll leave it until later.

Thanks for the info on the support hotline.


Direct link Reply with quote
 
Please update your WFP Jan 17, 2013

Kjell Thornes wrote:

I tried changing the setting to UTF-16, iso-8859-1 and iso-8859-15, but no luck. I made sure to apply the changes and restarted WF PRO just in case. I also made a fresh import of the test file, translated it again and exported it with the new settings. The result is the same.

Is updating to the new version likely to make a difference? If not, I'll leave it until later.


Dear Kjell,

It is not about "trying" - you should use the certain encoding of your HTML file as it is stated under "charset=".

If you think you might have spoilt the file by first fiddling, I suggest you download the source files again.

As for updating WFP, we do not offer support for such outdated versions. If I remember correctly, yes - this might make difference in this case.

Kind regards,
Yasmin


Direct link Reply with quote
 

Kjell Thornes  Identity Verified
Spain
Local time: 13:42
Member (2005)
English to Norwegian
+ ...
TOPIC STARTER
No character set defined Jan 17, 2013

Hello again. The reason I tried ISO-8859-1 is that it's the default character set and ISO-8859-15 is the intended future default. As far as I understand anyway - I'm obviously no expert. There is no "charset=" in the meta tag, so the browser should display it in the default set, shouldn't it? In my version of Firefox that's ISO-8859-1. I won't bother you more for now. I'll update WFP and mess around a bit to see if I can get this to work.

Direct link Reply with quote
 

Kjell Thornes  Identity Verified
Spain
Local time: 13:42
Member (2005)
English to Norwegian
+ ...
TOPIC STARTER
FIXED - WFP update fixed the problem Jan 17, 2013

Hello again. Updated WFP, and now things seem to be working fine. I'll make a mental note that when troubleshooting, the first step should be to download the latest version. Thanks Yasmin!

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Wordfast Pro 2.4.1 Html files - Norwegian special characters garbled when translated file saved.

Advanced search


Translation news related to Wordfast





TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search