WFC 6.03t placeables lose formatting
Thread poster: Lori Cirefice

Lori Cirefice  Identity Verified
France
Local time: 14:37
French to English
Mar 5, 2013

After activating a few PB commands related to placeables, firstcap and placeableplusspace, placeables no longer retain formatting. How annoying... Deactivating those commands doesn't bring previous behavior back. Glossary entries are still behaving properly.

Windows 8, Word 2007, WFC 6.03t

[Edited at 2013-03-05 21:50 GMT]


 

Lori Cirefice  Identity Verified
France
Local time: 14:37
French to English
TOPIC STARTER
Also Mar 5, 2013

Would a kind soul please explain the "new" ways of handling placeables (I recently upgraded from 5.52), I have figured out what the tab key does, but I thought I read somewhere that you could indicate the first letter of the desired placeable to avoid cycling through all of them and save time? I haven't found any relevant explanations in the manual!

 

Dominique Pivard  Identity Verified
Local time: 15:37
Finnish to French
AutoComplete Mar 6, 2013

Lori Cirefice wrote:
Would a kind soul please explain the "new" ways of handling placeables (I recently upgraded from 5.52), I have figured out what the tab key does, but I thought I read somewhere that you could indicate the first letter of the desired placeable to avoid cycling through all of them and save time? I haven't found any relevant explanations in the manual!

Yes, typing in the first letter of a word and pressing the tab key to expand it is one (new) way of doing things. However, you may want to investigate AutoComplete, which is even more versatile. It's not in the manual, but there are a couple of good videos about it icon_wink.gifhttp://wordfast.fi/blog/cat-tools/2012/03/10/autocomplete-in-wordfast-classic-v-6/

http://wordfast.fi/blog/cat-tools/2012/04/07/the-new-style-autocomplete-in-wordfast-classic-6-03/


 

Dominique Pivard  Identity Verified
Local time: 15:37
Finnish to French
Placeables & PB vs. AutoComplete Mar 6, 2013

Lori Cirefice wrote:
After activating a few PB commands related to placeables, firstcap and placeableplusspace, placeables no longer retain formatting. How annoying... Deactivating those commands doesn't bring previous behavior back. Glossary entries are still behaving properly.

The old-style PB commands about placeables were never supposed to "retain formatting" (whatever you mean by that), mostly to have words meeting certain criteria be considered as placeables (making it possible to select and copy them with Ctrl+Alt+arrows). AutoComplete (see my other reply in this thread) is a more convenient way to do it. You can still use PlaceablePlusSpace, however.

If a source segment includes several formatting attributes (eg. bold and normal text, words in different colours etc.), you should apply the formatting manually in the target segment, even though Wordfast may try to be smart (and even succeed in some cases).


 

Lori Cirefice  Identity Verified
France
Local time: 14:37
French to English
TOPIC STARTER
Thanks Mar 7, 2013

Dominique Pivard wrote:


Yes, typing in the first letter of a word and pressing the tab key to expand it is one (new) way of doing things.


I still can't get this to work here. I type the letter p for example, because the Placeable I want starts with a P, then "p" shows up in target segment, hit tab... and the first placeable in the source gets inserted, not the one I wanted that started with P.

Anyhow, I watched the videos and agree, AC looks like it should do a better job.


 

Lori Cirefice  Identity Verified
France
Local time: 14:37
French to English
TOPIC STARTER
what I meant Mar 7, 2013

Dominique Pivard wrote:


The old-style PB commands about placeables were never supposed to "retain formatting" (whatever you mean by that),


I meant things like color, bold, font. It used to be that with Ctrl+Alt+arrows, the placeable would be inserted in the same format as the rest of the segment (I am referring to homogenous segments of course, not segments with different attributes here and there). This old feature was working fine in my 6.03t until I activated the 2 PB commands mentioned above. I wasn't expecting those commands to change anything other than what they are supposed to do...



In this example, there were 3 attributes applied to the entire segment, color, font and size. The placeable inserted lost the color, but kept the font and size. I just did some testing on different kinds of segments, and I maintain that this is a bug! It seems that color is the only attribute that gets lost, other attributes like bold etc don't get lost. Again, having seen the videos, I think I will be activating AC right awayicon_wink.gif


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

WFC 6.03t placeables lose formatting

Advanced search


Translation news related to Wordfast





PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search