Header not recognised
Thread poster: Brian O Callaghan

Brian O Callaghan
United Kingdom
Local time: 17:35
Member (2013)
French to English
Apr 5, 2013

Hello there, I received a .txt file which is supposedly a wordfast TM, but it won't load in wordfast, nor will Trados recognise it...

Here's the first few lines of the document -



{\fonttbl
{\f1 \fmodern\fprq1 \fcharset0 Courier New;}
{\f2 \fswiss\fprq2 \fcharset0 Arial;}
{\f3 \fbidi\froman\fprq2 {\*\panose 02020603050405020304}\fcharset0 Times New Roman;}

Thanks in advance!
Brian


Direct link Reply with quote
 

David Daduč
Czech Republic
Local time: 18:35
English to Czech
Not a Wordfast TM Apr 5, 2013

Most likely, that's a TXT export from Trados. See http://wordfast.net/wiki/Trados_TXT_export_TM_file

Direct link Reply with quote
 

Brian O Callaghan
United Kingdom
Local time: 17:35
Member (2013)
French to English
TOPIC STARTER
Missing code Apr 5, 2013

Thank you. Yes, so I thought, but as I said, it won't load in Trados. I downloaded Xbench, tried to convert it, but without luck. I'm wondering if the file is perhaps damaged, as it resembles a trados file with a line of code missing from the top. Any suggestions for repair would be welcome! I can send the file if someone's really feeling nice
Brian


These are the very first two lines, sorry...




[Edited at 2013-04-05 11:28 GMT]


Direct link Reply with quote
 

Brian O Callaghan
United Kingdom
Local time: 17:35
Member (2013)
French to English
TOPIC STARTER
Missing code Apr 5, 2013

Okay, forum sees tags as html...

so, the first two lines:

(html bracket) RTF Preamble (html bracket)
(html bracket) FontTable (html bracket)

[Edited at 2013-04-05 11:56 GMT]


Direct link Reply with quote
 

David Daduč
Czech Republic
Local time: 18:35
English to Czech
File comes from older version of Trados Apr 5, 2013

Most likely, your Trados TXT file comes from an older version of Trados. The initial line was not there years ago.

If you have a newer version of Trados available, try copy-pasting the first line from a new TXT export file into the file that's missing it. When this is done, will it import into your Trados version and/or into Xbench?


Direct link Reply with quote
 

Brian O Callaghan
United Kingdom
Local time: 17:35
Member (2013)
French to English
TOPIC STARTER
First line Apr 5, 2013

Hi, yes I tried that, pasting the following line at the very top:

(TWBExportFile version="7.0" generator="TW4Win" build="8.3.0.863")

- Where round brackets replace tags

Is there perhaps a more appropriate first line I could use?
B


Direct link Reply with quote
 

David Daduč
Czech Republic
Local time: 18:35
English to Czech
Save the text file as UTF-8 Apr 5, 2013

Apart from inserting the initial line, one more thing may be required: open the TXT file in NotePad (or any other good text editor), go to File / Save As menu and save the file with a new name. Before you save it, make sure you change the Encoding option to Unicode UTF-8. Will this make it work?

Direct link Reply with quote
 

Brian O Callaghan
United Kingdom
Local time: 17:35
Member (2013)
French to English
TOPIC STARTER
Hmm Apr 5, 2013

Hi David, thanks so much for your dedication! I added the first line, saved with encryption you mentioned. In trados, .txt is not an accepted file format for TMs, I tried renaming the file .tmx, no luck. Xbench won't have it either... Okay, I think I got it. So, having added the first line of working Trados TM, then I went to (I have french version) update TM (?), as indicated halfway down this thread:

http://www.proz.com/forum/sdl_trados_support/152498-importing_txt_files_into_translation_memory.html

This allowed me to import the .txt file, and it generated a file with the following title - ocr111_en-GB_fr-FR, a Trados TM thumbnail, and "SDL File-Based Translation Memory (.sdltm)" file type. I am still working out whether this will function with wordfast, but there doesn't seem to be any problem. I would also like to see if your suggestion of changing the encoding on the .txt file was a necessary step. Pheww. And my client is sleeping all the while in another time zone...
Thank you so much David,
Brian


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Header not recognised

Advanced search


Translation news related to Wordfast





Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search