Wordfast Classic: keyboard shortcuts messed up
Thread poster: Tony M

Tony M  Identity Verified
France
Local time: 13:36
Member
French to English
+ ...
Jul 18, 2013

I know this subject has been mentioned before in this and other forums, but none of the suggestions there seems to work for me — or else the instructions given were not detailed enough for me to followicon_wink.gif

I am running an old version 5.xx of Wordfast Classic (which works just fine for me, please don't tell me I should upgrade!), which I have been using successfully for some years under Windows XP.

I have previously installed WFC on my newer laptop running Windows 7, and initially experienced problems because the Wordfast keyboard shortcuts were being hijacked by my graphics driver, causing the alarming 'upside down screen' and other symptoms; I did eventually manage to resolve that problem (though finding where I had to go to do it was quite a headache!).

However, I have now installed the same version of WFC onto my newer office computer, also running W7. I should mention too that I am still using Office XP.

I thought originally when I first tested it (in unlicensed 'demo' mode) it seemed OK (though I might be mistaken on that point), so satisfied it was going to be OK, I decided to license it on this, my second machine. At the same time, I decided to upgrade to a slightly more recent version, so I installed v 5.53 instead of v 5.51.

To my horror, many of the keyboard shortcuts seem messed up; this time I am not getting the inverted screen problem, but the Ctrl + Alt + arrow shortcuts to move between and then copy placeables don't work (but the menu buttons are fine). Moving between placeables (+ sideways arrows) seems unreliable, it often takes several key presses to make anything happen. Pasting (+ down arrow) is even worse: it closes the segment and moves me on to the next one, just as if I'd pressed Alt + down without pressing Ctrl as well.

I don't know if it's related, but I have also just recently noticed that the Num Lock seems to untoggle itself for no apparent reason at random times.

So, assuming that there might be some kind of problem with this untried v 5.53, I uninstalled it and went back to the known good v 5.51. Sadly, that failed to cure the problemicon_frown.gif

Following a suggestion in another forum, I also deleted and re-created my Normal.dot template, but all to no avail.

One suggestion was to re-assign the Wordfast shortcuts, but that seems like a pretty drastic solution, and likely to cause me immense confusion when moving between computers.

I just can't understand what is going on? I have shut down all other applications, and surely if the W/f shortcut was being hijacked by Word itself, then I would see something happen in Word, and the shortcut would have no effect within W/f?

Please help, I've wasted my entire morning trying to sort thisicon_frown.gif


 

John Fossey  Identity Verified
Canada
Local time: 07:36
Member (2008)
French to English
Reassigning WF shortcuts Jul 18, 2013

Tony M wrote:

One suggestion was to re-assign the Wordfast shortcuts, but that seems like a pretty drastic solution, and likely to cause me immense confusion when moving between computers.



Re-assigning the WF shortcuts is not a very big deal - I have 3 computers and on one I have to re-assign one of the shortcuts due to another piece of software that interferes. At first it was a bit annoying but I got used to it.


 

Tony M  Identity Verified
France
Local time: 13:36
Member
French to English
+ ...
TOPIC STARTER
How? Jul 18, 2013

John Fossey wrote:

Re-assigning the WF shortcuts is not a very big deal


Well, that's reassuring, at least, John! if I do it, I'll make them the same on both computers.

BUT... I know how to reassign WORD shortcuts, but where do I have to go to do it under W/f?

BTW, when I was looking into this earlier, I tried to see if Word had assigned my shortcut to something else, so I typed it in the 'new key combination' box, but all it came up with was the proper W/f shortcut.

So I just don't understand how or where it happens that when I type one key combination, W/f interprets it as a different one?

At first I thought (and I still wonder?) if it was just the Ctrl key on my keyboard playing up; certainly pressing Ctrl firmly and holding it down while pressing the other keys DID make it work OK on at least ONE occasion; BUT it didn't work for ALL the corrupted shortcuts. What on earth can be going wrong here?

The only thing I did do was to try changing my USB keyboard, but have no gone back to the original one, to no avail.

Also, I now have confirmation that SOMEthing, one of the key combinations I type without noticing is DEFINITELY consistently turning off Num Lock.

I did also just have an odd problem (which I've occasionally encountered before on other hardware) where the mouse moved the cursor around the screen OK, but clicking did nothing, i.e. I couldn't place the cursor somewhere, for example. Luckily, rebooting seems to have cured that one at least icon_wink.gif


 

B D Finch  Identity Verified
France
Local time: 13:36
Member (2006)
French to English
+ ...
Could it still be the graphics settings? Jul 18, 2013

I had a similar problem to the first one you described when I installed Wordfast Pro and Classic onto my Windows 7 notebook PC, with Alt+Down turning my screen upside down etc. I eventually solved it by right-clicking on the desktop and turning off the hot keys on the properties tab of my graphics program. It's easy enough to turn them back on when not using Wordfast and saves re-programming the keyboard shortcuts.

 

Tony M  Identity Verified
France
Local time: 13:36
Member
French to English
+ ...
TOPIC STARTER
I don't think so... Jul 18, 2013

Thanks, Barbara, for your comment, but I don't think it's that; BTW, when I right click on the desktop, I don't get anything that lets me adjust the graphics card settings...

But the thing is, when I use the shortcut, it doesn't have any effect on the screen dispaly, or anything else; BUT it does have an effect in W/f — just not the right one!

The mystery remains...


 

John Fossey  Identity Verified
Canada
Local time: 07:36
Member (2008)
French to English
Reassigning WF shortcuts Jul 18, 2013

Tony M wrote:

BUT... I know how to reassign WORD shortcuts, but where do I have to go to do it under W/f?



In Word Options > Customize > Keyboard Shortcuts: Customize > Under "Categories" select "Macros"

You will see all the WF macros in the right pane. Each WF shortcut references a WF macro, and you can change the shortcuts using the "Assign" and "Remove" buttons in the "Customize Keyboard" window.


 

Tony M  Identity Verified
France
Local time: 13:36
Member
French to English
+ ...
TOPIC STARTER
Thanks a lot, John — but that hasn't solved the problem. Jul 18, 2013

Thanks for that explanation, I had no idea where to go and look for it.

However, when I tried it, it just doesn't work: the newly-assigned shortcut simply reproduces the same error that I get when I use the original W/f shortcut.

Haven't a clue what can be going on... icon_frown.gif


 

Lori Cirefice  Identity Verified
France
Local time: 13:36
French to English
Some thoughts Jul 19, 2013

I wish I had something more constructive to help you... I hope you are able to work on another computer in the meantime?

The fact that this issue is cropping up in more than one version of WF, and considering the solutions you have already tried (including reassigning shortcuts), I think that "something else" is the source of the problem.

Graphics card, other software or hardware... is there anything you have installed lately that could be the culprit?

What about a virus? A friend of mine had a virus recently that played havoc with certain keyboard keys, it was really strange.

I had the numlock issue too, when I was using a 5.52 version (on a different, older Toshiba computer, not this one). I never did figure it out, or else I forgot what caused it...

Forgive me for straying off topic here, but I feel that I am in a unique position to give you some advice about upgrading. I stayed with 5.52 for many years, until a few months ago, because I felt like it was just fine for my needs, if it works, don't fix it right? You read so much about bugs in new versions on the various lists and forums, and I did have a few bugs in mine, but known bugs are usually better than the unknown kind. Anyhow, I recently took the plunge and got 6.03t - and I'm glad I did. The auto-complete feature is really a time-saver. 6.03t is quite stable in my opinion, it was a smooth transition.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Wordfast Classic: keyboard shortcuts messed up

Advanced search


Translation news related to Wordfast





BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search