Successfully opened TMX in Wordfast, but no matches appearing!
Thread poster: CWarren

CWarren  Identity Verified
Japan
Local time: 07:00
Japanese to English
Jan 20, 2014

Dear technical people,

I recently had to turn down a project due to not being able to open up a TMX file in my Wordfast (Wordfast Pro 3.2.1) and am wondering where I went wrong.

Client prefers Trados but said Wordfast was fine; he converted the file to a TMX for me. Unfortunately, when I tried to load the files, my Wordfast browser did not even recognize the files.

I eventually tried using a file converted using Olifant; my browser was able to open this one and establish a TM connection successfully. Hooray! Unfortunately, when I opened the Excel files I was supposed to be translating, not a single match (fuzzy or 100%) came up, not even when I tried searching for things with the TM lookup. It was as though the TMX just wasn't there.

Now, here are the instructions my client sent me:


"• in Wordfast Pro: copy the TMX memory you want to use in any folder, then select Translation Memory > New/Select TM > Open; it will be converted on-the-fly to the native Wordfast format and a file with the same name, but the .TXT extension will be created in the same folder."


In addition, when I did a search through the forums here, I saw instructions like this:


"Make sure you create a Project in Wordfast Pro with the same language codes as those of the TMX TM. To open the TM:

1- Open "Translation Memory" menu.
2- Select "New/Select TM".
3- Click "Open" (Button).
4- Click "Browse" (button)
5- Select "Translation Memory eXchange" from the dropdown menu.
6- Locate the TMX and click "Open".
7- Make sure that your Source and Target locales selected are the same as the TMX > OK
http://www.proz.com/forum/wordfast_support/197035-cannot_open_tmx_file_in_wordfast_pro.html


Now, when I open a translation memory in Wordfast, I go to "Translation memory" -->"New/select TM" -->which takes me straight to the TM list--I can't see any "Open" button or menu. From the TM list I have to choose either the "Create TM" or "Add TM" button. I don't understand where this "Open" is supposed to be. Is there something wrong with my Wordfast Pro settings? I think there must be something simple that I am doing wrong.

Many, many thanks in advance to anyone who is patient enough to bear with me!


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 01:00
Member (2006)
English to Russian
+ ...
Add TM Jan 20, 2014

CWarren wrote:

I can't see any "Open" button or menu. From the TM list I have to choose either the "Create TM" or "Add TM" button.


Use Add TM. I think, Open is obsolete, was present in earlier builds. By the way, Add TM can be applied directly to a TMX file without prior conversion (WFP will convert on its own).

As for your problem, are you sure that the TMX file language/locale codes match your project codes?


Direct link Reply with quote
 

CWarren  Identity Verified
Japan
Local time: 07:00
Japanese to English
TOPIC STARTER
File language and code could indeed be the issue! Jan 20, 2014

As for your problem, are you sure that the TMX file language/locale codes match your project codes?


Good point. The file was sent from Singapore. Hmm. I think I will have to go back and have another look. Oh, and thank you for taking the time to reply!


Direct link Reply with quote
 

John Di Rico  Identity Verified
France
Local time: 00:00
Member (2006)
French to English
Language codes Jan 20, 2014

Dear CWarren,

Esperantisto is probably right. I had the same problem the other day. I used EN-US as target language but should have used EN-GB. A wordfast compatible TM gets created but without any TUs.

I will report this to developers to make the import more user-friendly by either:
1. Giving the user a import failure warning message (wrong language codes!)
2. Automatically detecting language codes from TMX upon import.

Hope it all works out for you in the end!

John


Direct link Reply with quote
 

CWarren  Identity Verified
Japan
Local time: 07:00
Japanese to English
TOPIC STARTER
Thanks-- more details about changing the language codes Jan 20, 2014

Thank you very much for alerting the designers about this!

I just went back and tried to change the language code.

Basically, I went to Add TM as usual, and the usual Add TM box came up, with the information as follows:


Location

Local TM Properties
Symbolic Name
Source Language Code Japanese (Japan)
Target Language Code English (United States)


Now, I presumably need to change the last one--Target Language Code. Trouble is, it (and the one above) is shaded in grey and can't be clicked on or changed. Is there any way to do this?

If not, I guess I will just have to alert the client to the problem, and ask them to create TMXs using US English as the language code in the future?


Direct link Reply with quote
 
John Daniel
Local time: 16:00
Select the TMX file Jan 20, 2014

Hi CWarren,

You have to select Browse next to Location and select Translation Memory eXchange to select the TMX file. Then you will see the disabled options for source and target language gets enabled.

Hope this helped.

Thank you,

John

CWarren wrote:
Now, I presumably need to change the last one--Target Language Code. Trouble is, it (and the one above) is shaded in grey and can't be clicked on or changed. Is there any way to do this?


[Edited at 2014-01-21 00:02 GMT]


Direct link Reply with quote
 

CWarren  Identity Verified
Japan
Local time: 07:00
Japanese to English
TOPIC STARTER
Still not working.... :( Jan 21, 2014

Oh dear--I have tried this a couple of times--selecting the Translation Memory eXchange to select the file when browsing--and it is still not working.

I wonder if there is a problem with my WF settings in some way.


Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 01:00
Finnish to French
Contact the hotline Jan 21, 2014

Charlotte: it looks like your license was overdrawn (= your attempted to relicense too many times since you purchased your Wordfast license). I have reset it to zero. This may have prevented you from using large TM's (= TM's with more than 500 units in them).

If you're still having problems, you can contact the hotline: log in to your personal account at wordfast.net, select Contact the hotline and describe your problem.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Successfully opened TMX in Wordfast, but no matches appearing!

Advanced search


Translation news related to Wordfast





PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search