Wordfast Classic - find/replace lists?
Thread poster: Claire Cox

Claire Cox
United Kingdom
Local time: 22:37
French to English
+ ...
Feb 17, 2014

hello,

I've just set up Wordfast on a new computer (a dream compared to some of the other programs I've been trying to download/set up!) and can't work out how to add the find/replace lists to change decimal commas to decimal points and full stops/spaces in thousands to commas in thousands, for example. I know I had problems doing this when I switched computers a few years ago, but did eventually get it working. However, my main computer has since crashed and the ini file I've copied to the new set-up is from my laptop, which I'd only recently switched to the 6.03t version of Wordfast and so didn't have the latest find/replace settings.

Can anyone jog my memory as to how I do this? I've found the location of the lists in the Data Editor but can't see how I enter the commands. I think the commands I used were these (although please correct me if I'm wrong!):

([0-9]),([0-9]) \1.\2 FR to EN financial format converter, step 2 /wc  
([0-9]),([0-9][0-9][0-9]) \1.\2 /wc  
,([0-9][0-9]) .\1 EN to FR financial format converter, step 1 /wc  
[!^s][\!\?\:\;] Non-breaking space before ! ? : ; /wc
^32@^13 (Trailing space) /wc
^32{2} (Multiple spaces) /wc

but nothing happens when I try and enter them in the relevant source/target columns, or I get a run time error. I'm probably missing something really obvious.

I'd be very grateful for any guidance.

Many thanks

Claire


 

Dominique Pivard  Identity Verified
Local time: 00:37
Finnish to French
tick entries + enable F/R in QA Feb 18, 2014

Claire Cox wrote:
but nothing happens when I try and enter them in the relevant source/target columns, or I get a run time error. I'm probably missing something really obvious.

You need to make sure Find/Replace entries you want to use are ticked in the Data editor:

2014-02-18_0854.png

You also need to tick the relevant entry in the QA tab:

2014-02-18_0857.png

Obviously QA during translation needs to be ticked as well, since Find/Replace operations take place during real-time QA.

Also make sure you are using the latest 6.07x, which reports itself as 6.07y once installed. It fixes a Data editor bug ("run-time error 402" when using any of the functions listed under the TM tools tab).


 

Claire Cox
United Kingdom
Local time: 22:37
French to English
+ ...
TOPIC STARTER
Thanks Dominique Feb 18, 2014

I had downloaded the latest version when I first set it up, but for some reason the Wordfast toolbar didn't display in the quick access toolbar at first, so I'd reverted to my older 6.03t which did. Having now downloaded 6.07t again, the toolbar stays in place and the find/replace lists are all there too. I wonder why the toolbar doesn't show at first as I've just had exactly the same problem when trying to set up my new laptop as well (two new computers to set up - nightmare!), but I'm hoping that if I go back and install 6.03 t and then this one again, that will fix it. Perhaps it needs an older version to be installed first?

Many thanks again, anyway - much appreciated as ever.


 

Claire Cox
United Kingdom
Local time: 22:37
French to English
+ ...
TOPIC STARTER
Incidentally... Feb 18, 2014

...when I open the companion windows in Version 6.07x, either by the shortcuts or by clicking the cons in the toolbar, I receive two prompts to save eachcompanion file each time, which I obviously don't want to do. Is there any way to disable this? I haven't had to do this before.

Many thanks


 

Claire Cox
United Kingdom
Local time: 22:37
French to English
+ ...
TOPIC STARTER
The plot thickens... Feb 18, 2014

I've just checked on the new laptop, on which I've just installed the very same version of Word 2013 with all the same settings and there's no prompt to save the companions on that machine. I had to jiggle around where they were displayed, but having got them in position, next to my main document screen, they returned to the same position when I reopened the document later. The only difference I can see is that for some reason the Wordfast commands open in the quick access toolbar on the desktop and in the Home ribbon under a New Group on the laptop. I can't find any reason why it should want me to save the companions before I open them (and again after I've said no to that offer).

I'd be very grateful for any guidance on this as I really don't want to have to click four unnecessary times each time I open a translation.

Many thanks


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Wordfast Classic - find/replace lists?

Advanced search


Translation news related to Wordfast





BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search