Why Wordfast Pro does not replace the 100% matches?
Thread poster: chopra_2002

chopra_2002  Identity Verified
India
Local time: 00:15
Member (2008)
English to Hindi
+ ...
Sep 5, 2015

Hello expert users,

I have bought the latest version of Wordfast (3.4.5) a few days ago. I am facing a strange issue. A CAT tool is supposed to produce the existing translation from the Translation Memory in respect of a same or similar segment. I have found that it is not producing the translation in respect of even 100% matches. I am editing similar documents. Therefore, it is quite important to provide the same translation for the same segments which appear in different documents.

I have adopted another method to fix it. I use the TM lookup because it produces the translation from TM in respect of same matches, and I then copy and paste them in the file. It is essential to maintain consistency but it kills time.

Could you figure out the reason behind this problem? Second, is there any shortcut to transfer the text from the TM lookup to the target cell so that one can avoid copying and pasting again and again?

Thanks and regards,

Chopra


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 20:45
Member (2006)
English to Afrikaans
+ ...
Not an expert, but... Sep 5, 2015

chopra_2002 wrote:
I have found that it is not producing the translation in respect of even 100% matches.


In the Preferences (Edit > Preferences), under Translation Memory, do you have "Perform TM Lookup automatically" checked?

If you're in a segment that gets no match, what happens if you press Alt+left or Alt+right? Does WFP cycle through matches, as it should?

How do you move to the next segment?

Second, is there any shortcut to transfer the text from the TM lookup to the target cell so that one can avoid copying and pasting again and again?


The WFC shortcut seems to work in WFP also: Alt+F12 will insert the selected text into the segment (unfortunately at the end of the segment, and not at the cursor position).


Direct link Reply with quote
 

chopra_2002  Identity Verified
India
Local time: 00:15
Member (2008)
English to Hindi
+ ...
TOPIC STARTER
Thanks for your detailed and informative answer Sep 5, 2015

Thank you for taking time to help me in this respect. Here are my replies to your questions:

Samuel Murray wrote:


In the Preferences (Edit > Preferences), under Translation Memory, do you have "Perform TM Lookup automatically" checked?


Yes, it is already checked.

Samuel Murray wrote:

If you're in a segment that gets no match, what happens if you press Alt+left or Alt+right? Does WFP cycle through matches, as it should?



Your suggestion is very useful. When I press alt + right, I get the translation from the TM but it should be presented automatically and the color of segment should be green in respect of a 100% match.

Samuel Murray wrote:

How do you move to the next segment?



I use the downwards arrow on the Wordfast interface. I also sometimes, use Alt + down arrow key.


The WFC shortcut seems to work in WFP also: Alt+F12 will insert the selected text into the segment (unfortunately at the end of the segment, and not at the cursor position).


Thanks for another useful tip. It works but it does not shift the placeholders.

I appreciate the help offered by you which may save time to a good extent but the main problem is persisting. I can't understand the reason why it is not replacing the translation in respect of same or similar matches which is very important to maintain consistency while editing many same or similar documents from the same project.

Thanks and regards,

Chopra


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 20:45
Member (2006)
English to Afrikaans
+ ...
Alt+minus Sep 5, 2015

chopra_2002 wrote:
Your suggestion is very useful. When I press alt + right, I get the translation from the TM but it should be presented automatically and the color of segment should be green in respect of a 100% match.


I find that pressing Alt+minus does that -- it puts the highest match in the target field, and updates the percentage (e.g. 100 if it's a 100% match). However, I agree with you that it is very strange that WFP doesn't put the 100% match into the target field automatically.


Direct link Reply with quote
 

chopra_2002  Identity Verified
India
Local time: 00:15
Member (2008)
English to Hindi
+ ...
TOPIC STARTER
Thanks for another useful and time saving tip Sep 6, 2015

Samuel Murray wrote:

I find that pressing Alt+minus does that -- it puts the highest match in the target field, and updates the percentage (e.g. 100 if it's a 100% match).


Thanks so much for yet another useful advice. Is there a list which encompasses all shortcuts for other functions as well?

While your answers have helped me a lot, I await the advice and comments from an expert who may explain the very reason behind this problem and suggest a solution.

Regards,

Chopra

[Edited at 2015-09-06 03:47 GMT]


Direct link Reply with quote
 

chopra_2002  Identity Verified
India
Local time: 00:15
Member (2008)
English to Hindi
+ ...
TOPIC STARTER
Another issue Sep 6, 2015

I have found that these shortcuts work only when the language is English. While translating, I have to select Hindi and when I try to use the above shortcuts, these don't work. So, I have no other choice but to revert to English in order to use these shortcuts.

Direct link Reply with quote
 
Marcelina Haftka  Identity Verified
Poland
Local time: 20:45
Member (2006)
English to Polish
+ ...
Shortcuts Sep 6, 2015

chopra_2002 wrote:

Is there a list which encompasses all shortcuts for other functions as well?


When in Wordfast Pro go to: Edit > Preferences > General > Shortcut Keys.
You can view and modify the shortcuts to suit your needs.


When you change from English to Hindi, the keyboard settings change, so you need to find a solution for this (or quickly switch to the English one for a shortcut and then come back - I practice this technique with English, French and Polish and sometimes it's really the quickest solution).

Good luck!


Direct link Reply with quote
 
Aelf
Poland
Local time: 20:45
English to Polish
+ ...
Similar issue Sep 6, 2015

I had a similar issue, albeit it included machine translation, and had to get in touch with the Wordfast support.

I used machine translation first in conjunction with my TMs. I don't know why but WFP favored machine translation over TM partial matches. Also, while working on the segments, it wouldn't substitute the MT with TM matches even though they could be found with TM Lookup.

I was told by the Support that once a segment is modified, WFP won't overwrite it. Fortunately, it all supposedly works under PM Perspective Analyze tab.

What is strange, though, is that I began messing around with MT and TM settings and magically it started to work just as I had expected.

Anyway, these are the setting that I use: https://www.flickr.com/photos/95023606@N03/


Direct link Reply with quote
 

chopra_2002  Identity Verified
India
Local time: 00:15
Member (2008)
English to Hindi
+ ...
TOPIC STARTER
Thank you for your detailed answer but... Sep 6, 2015

...it has not helped me even though I applied the same settings as suggested by you in the screenshot.

Aelf wrote:

I was told by the Support that once a segment is modified, WFP won't overwrite it.


This is strange. It means if someone edits a segment, it won't be presented despite the fact that it exists in the TM. I think that they should introduce this feature because it is essential and very helpful.

Regards,

Chopra


Direct link Reply with quote
 
Aelf
Poland
Local time: 20:45
English to Polish
+ ...
Your TM Sep 6, 2015

I suspected my issue was slightly different, but essentially it was about the units from the TM not being picked up, just like yours.

Now, if I were you I'd try translating from scratch. That is, back up your current document you're working on, and open the original file (hope you have it) and start anew with the TM.

Also you might want to check suggestions at the "Not Able to..." page:
https://www.wordfast.net/wiki/Not_able_to...
especially, the one about deleting *.jtx and *.lock files (BTW, I don't know what Alt+Space does there, as I've remapped my shortcuts).


Direct link Reply with quote
 

Camille Beaupin
France
Spanish to French
+ ...
The solution to the problem :-) Mar 28, 2016

I think I have found the solution to this problem!
I was wondering, too, how the already translated segments could propagate automatically.
It seems that we only have to click "Translation Memory" and then "Translate all".
The shortcut for this option is: Ctrl + Shift + End
I hope that will help other Wordfast users!


[Modifié le 2016-03-28 16:52 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Why Wordfast Pro does not replace the 100% matches?

Advanced search


Translation news related to Wordfast





Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search