Issues with WordFast Pro 3 being extremely slow
Thread poster: Emilie M

Emilie M
Canada
Local time: 02:59
French to English
+ ...
Jan 20

I had to start using WordFast Pro 3 for a couple of agencies I am working with, but I am finding it excruciatingly slow. For example, there is usually a lag after typing each character. Sometimes I type out an entire sentence, and I have to stop and wait at least 30 seconds for each word to appear one by one in the target field. It also seems to slow down my entire computer, as every time I close it, all of my other applications start running much smoother. Has anyone else experienced these kinds of issues using this CAT tool? Any idea would is causing this? Any tips for making the tool run faster?


Thank you so much for any advice you can give me!


Direct link Reply with quote
 

DJHartmann  Identity Verified
Australia
Member (2014)
Thai to English
+ ...

MODERATOR
What system? Jan 20

The best info you could provide here is about your computer system.

Then we can help determine whether that might be your problem.

i.e. my late 2013 iMac has zero problems running either WF3 or WF4.


Direct link Reply with quote
 

Emilie M
Canada
Local time: 02:59
French to English
+ ...
TOPIC STARTER
Computer system Jan 20

Thank you for your comment DJHartmann! I have a Dell XPS 13 9350, running Windows 10 (v. 1607). These are the specs: i56200U CPU @ 2.30 GHz 2.40 GHz; 8 GB RAM; 64-bit processor. This is probably more detailed then you need, but you never know!
As a note, I also use Trados Studio 2015, and I do not have any speed issues with that tool.


Direct link Reply with quote
 

Emilie M
Canada
Local time: 02:59
French to English
+ ...
TOPIC STARTER
Solution found Jan 22

I ended up finding the answer to my own question, so I thought I would share it in case anyone else encounters this problem. The issue is that for Wordfast to work properly in Windows 10, you need to disable UAC on your device. https://www.wordfast.net/?whichpage=versions

Direct link Reply with quote
 

David Daduč
Czech Republic
Local time: 11:59
English to Czech
Did turning off UAC help? Jan 22

Emilie, the advice you quoted refers to Wordfast Classic, rather than Pro. Anyway, did turning off UAC help suppress Wordfast Pro 3 slowness in your Windows 10 system?

Direct link Reply with quote
 

Emilie M
Canada
Local time: 02:59
French to English
+ ...
TOPIC STARTER
Turning off UAC Jan 22

Thanks David, good catch! I thought all my troubles had been solved. The tool has been significantly faster since I turned off UAC, but I still find it slower than what I consider normal. I have contacted WordFast support, so I will post an update, if I do finally get to the bottom of this.

Direct link Reply with quote
 

David Daduč
Czech Republic
Local time: 11:59
English to Czech
Is your AV scanning the TM any time you open a segment? Jan 23

Emilie, are you using a large TM or multiple TMs? If so, I wonder if the slowness problem may be due to your anti-virus software scanning the TM file(s) every time Wordfast Pro read/writes from/to the TM(s). See if you can exclude your TM file(s) from real-time scans in your AV software. Wordfast Pro 3 TMs are simple text files, so doing so should be safe I believe. I wonder if it helps.

Direct link Reply with quote
 

cvmagalhaes  Identity Verified
Brazil
Local time: 08:59
Member (2014)
English to Portuguese
Any news? Feb 16

Hey Emilie,

any success in solving it definitively?

Keep us posted! I've been suffering from this for a looong time, but since I don't need to use the notebook a lot, it's bearable in the desktop.
Let us know =)


Direct link Reply with quote
 
John Daniel
Local time: 03:59
Try these Feb 16

Hi Emilie,

Try the following:

1) Go to Preferences > Terminology > Disable Highlight terms in Editor with Box
2) If you are using Microsoft Spellcheck, try Hunspell.
3) If you still want MS spellcheck disable, Spell check as you type or disable spellcheck completely to see if it makes a difference
4) Increase Memory preferences to 1024 MB.
5) If you save your work to Google Drive, try disabling the sync while you work.

Check these options one by one and see if any improvement on typing lag and let us know if anything worked.

Thank you,

John

Emilie M wrote:

I had to start using WordFast Pro 3 for a couple of agencies I am working with, but I am finding it excruciatingly slow. For example, there is usually a lag after typing each character. Sometimes I type out an entire sentence, and I have to stop and wait at least 30 seconds for each word to appear one by one in the target field. It also seems to slow down my entire computer, as every time I close it, all of my other applications start running much smoother. Has anyone else experienced these kinds of issues using this CAT tool? Any idea would is causing this? Any tips for making the tool run faster?


Thank you so much for any advice you can give me!


Direct link Reply with quote
 

Emilie M
Canada
Local time: 02:59
French to English
+ ...
TOPIC STARTER
Update on Wordfast issues Feb 17

Thank you David and John for your suggestions. My interactions with Wordfast support weren't very helpful. They don't have a number you can call, and any response I received appeared to be a generic copy-pasted response. However, the issue miraculously resolved itself. I wish I could share what I did to fix it, but I have no idea. One day, it was suddenly working smoothly. One change that I made over that period of time is that I set my screen to the highest resolution. I had previously set it to a lower resolution, because some of my apps weren't displaying properly, but I have no idea if that could have had any influence on Wordfast. Another thing that I tried was right-clicking on the Wordfast icon and selecting "Resolve compatibility issues", and then selecting the recommended compatibility settings. However, the improvement only started a few days after doing this, so I'm not sure if that had anything to with it either. I wish I could provide more information about fixing this issue. Thanks again to all of you who provided suggestions.



cvmagalhaes wrote:

Hey Emilie,

any success in solving it definitively?

Keep us posted! I've been suffering from this for a looong time, but since I don't need to use the notebook a lot, it's bearable in the desktop.
Let us know =)


Direct link Reply with quote
 
Murthy R.A.N
India
Local time: 16:29
Japanese to English
+ ...
One option for this issue Oct 15

As a Wf user for the last so many years, this problem is very severe when we want to type in Asian languages. Some solutions which I have found myself are:

1) Type in the segments, and then insert the placeholders (e.g. {ut1} etc.), because if you try to make corrections after inserting the placeholders, it will be extremely slow. OR

2) Open notepad, type/modify the translation (which is very easy, fast), and paste it in the Wf segment, and then add the placeholders, if any.

3) Sometimes, lot of placeholders get created in the source segment. These placeholders don't have any meaning.There is no need to worry. Go to Edit, copy all placeholders into the target segment in one lot, and type in your translation. In case, we want to take the text to Google Translate, I copy the source into target segment, ask all tags to be removed (go to Edit, you will find it there), and then copy in Google Translate..

4) I also have found that this problems if you edit your dictionaries in Wf when you are working. At that time, Wf will not allow you to do any more additions and/or modifications to your dictionaries. In such cases, the only option is save the file, close the Wf and restart.

5) In case of Asian languages, where sometimes, we need to combine more than 1 character, this problem can make you really mad, and also tremendously slowdown the work.

4) These problem are not there in Trados, which is very amenable to edits in the target segments.


Direct link Reply with quote
 

John Di Rico  Identity Verified
France
Local time: 11:59
Member (2006)
French to English
OS, version, specs for slow response with Asian languages Oct 16

Murthy R.A.N wrote:

As a Wf user for the last so many years, this problem is very severe when we want to type in Asian languages.


What version are you using? What OS are you running? What are the specs on your computer? Have you contacted the hotline or submitted feedback via the software? This is odd.

Thanks,
John


Direct link Reply with quote
 
Murthy R.A.N
India
Local time: 16:29
Japanese to English
+ ...
Slow typing in Wf Pro3 Oct 17

WF Pro 3 (Latest build - updated and installed just last week). My system is : Windows 10, 64bit -DELL - latest system bought 3 months ago. I have seen the same problem even when I was using Windows 7. Even, as on today, I have seen the same problem. Yes, I used to occasionally communicate on this issue, but not received any solution. So, in order to keep moving, I devised my own solutions - they may look very amateurish, but they are effective and keeps the work progressing. In some Indian languages (e.g. Hindi, Marathi, Kannada etc., which are supported in Wf), sometimes 2-3 characters are combined to form one single character, and this is where the problem is. In segments without tags, typing is fast and OK if we type without any error. Once an error occurs and we delete some characters to make correction, then this problem occurs, and the combination of characters will not give correct output at all. Similar problem I face even when I type in English (when editing between tags). At that time, Notepad is the only option. And, sometimes, for no apparent reason, typing between tags can be very slow, which requires restarting the application.

As I mentioned, this problem I have not faced in Trados (right from Trados 6 up to Trados Studio 2017). Of course, Wf has many advantages vs. Trados.


Direct link Reply with quote
 
John Daniel
Local time: 03:59
Email me Oct 17

Hi Murthy,

I would like to setup a call with you to go over the speed issues. Can you email me at jsingaram@wordfast.com

Thank you,

John

Murthy R.A.N wrote:

WF Pro 3 (Latest build - updated and installed just last week). My system is : Windows 10, 64bit -DELL - latest system bought 3 months ago. I have seen the same problem even when I was using Windows 7. Even, as on today, I have seen the same problem. Yes, I used to occasionally communicate on this issue, but not received any solution. So, in order to keep moving, I devised my own solutions - they may look very amateurish, but they are effective and keeps the work progressing. In some Indian languages (e.g. Hindi, Marathi, Kannada etc., which are supported in Wf), sometimes 2-3 characters are combined to form one single character, and this is where the problem is. In segments without tags, typing is fast and OK if we type without any error. Once an error occurs and we delete some characters to make correction, then this problem occurs, and the combination of characters will not give correct output at all. Similar problem I face even when I type in English (when editing between tags). At that time, Notepad is the only option. And, sometimes, for no apparent reason, typing between tags can be very slow, which requires restarting the application.

As I mentioned, this problem I have not faced in Trados (right from Trados 6 up to Trados Studio 2017). Of course, Wf has many advantages vs. Trados.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Issues with WordFast Pro 3 being extremely slow

Advanced search


Translation news related to Wordfast





Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search