Disable automatic capitalization of glossary insertions?
Thread poster: alentrix

alentrix  Identity Verified
German to English
Sep 22, 2017

I'm using Wordfast Classic 6.99. I have glossary entries that are recognized during a translation session. When I use Ctrl-Alt-Down to insert a capitalized German source noun, Wordfast inserts my English target noun or noun phrase with each target word capitalized. These target words should not be capitalized. Wordfast seems to have decided that capitalization from the source should be added to every target word, even though my target words in the glossary are not capitalized. I'm assuming that it's possible to disable this behavior, but I'm not having any luck finding anything in the manual or online. Can anyone provide some thoughts as to what to do?

 

Jean Lachaud  Identity Verified
United States
Local time: 13:10
English to French
+ ...
lock case Sep 22, 2017

Each glossary entry now offers the possibility to lock the source or / and the target case, which presumably would solve your problem. In addition, glossaries can be set to "Lock target case on entire glossary."

 

Samuel Murray  Identity Verified
Netherlands
Local time: 19:10
Member (2006)
English to Afrikaans
+ ...
@Alentrix Sep 23, 2017

alentrix wrote:
I'm assuming that it's possible to disable this behavior, but I'm not having any luck finding anything in the manual or online. Can anyone provide some thoughts as to what to do?


WFC > Terminology > Glossary > "Lock target case on entire glossary".

AFAIK it's not possible to lock source case, so "Foo", "FOO" and "foo" in the source text will be treated by WFC as "foo" when doing matching. But if you lock target case, then glossary entries' target text case will be respected.


 

neilmac  Identity Verified
Spain
Local time: 19:10
Spanish to English
+ ...
Vice versa Sep 23, 2017

My issue is quite the opposite. I would like WordFast to maintain the punctuation and capitalisation of the source text, but I don't know how to do it. I'm going to have a look at the route suggested by Samuel to see if I can set it up...

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Disable automatic capitalization of glossary insertions?

Advanced search


Translation news related to Wordfast





SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search