Word keeps changing TARGET language to French - sorry, I'm clearly having one of those days!
Thread poster: Marie-Hélène Hayles

Marie-Hélène Hayles  Identity Verified
Local time: 12:30
Italian to English
+ ...
Oct 30, 2006

This is happening in two TMs, both of which were given to me by an agency (i.e. not created by me personally). Every time I open them, WF asks me the source language (IT), asks me the target language (GB-EN), thinks about it for a few seconds and then sets the target language as French. I've had a look at the TM and it all seems to be OK in there - IT-EN-GB as it should be. But the target segments are all set in French, not English. Obviously I can get round this by using cont+, to display only the target, then selecting all and selecting English as the language, but if I then try to process it again with WF it goes straight back into French.

I've had a look at the manual but this problem doesn't seem to be mentioned... any ideas?

Interestingly, this has only happened since my computer was upgraded - I'm using XP and Word 2003 Professional, and the WF version is 4.22a AG.


[Edited at 2006-10-30 22:15]


Direct link Reply with quote
 
Ken Cox  Identity Verified
Local time: 12:30
German to English
+ ...
style problem? Oct 30, 2006

This is a blind guess, in part because I've never enountered this particular problem -- but I do more than occasionally have the problem that WF starts applying the font attributes of the underlying style (usually the Normal style) to the text instead of copying the attributes of the source text. If the language attribute of the underlying style is set to French (likely if you're translating from French) and WF copies this attribute, voilà...

Unfortunately I don't have a clue why WF sometimes uses the underlying style attrributes instead of the local attributes.

You might try changing the language attribute of the underlying style to see if that helps.

[Edited at 2006-10-30 22:35]

[Edited at 2006-10-30 22:36]

Hmmm... you're probably not translating from French, but the language attribute of the underlying style might be set to French, depending on the origin and history of the document.

[Edited at 2006-10-30 22:38]


Direct link Reply with quote
 

Gerard de Noord  Identity Verified
France
Local time: 12:30
Member (2003)
German to Dutch
+ ...
Just a guess Oct 30, 2006

Open the TMs in Word. Maybe the TUs have the right language coded but the headers haven't.

Workaround: on the Setup/Segments tab you can choose between:
Set target segment language to TM's target language
and
Set target segment language to Word's default language
Maybe you can change this setting.

I'm sure you aren't using Word's automatic language detection.

Regards,
Gerard


Direct link Reply with quote
 

Marek Buchtel  Identity Verified
Czech Republic
Local time: 12:30
Member (2005)
English to Czech
+ ...
Language codes Oct 30, 2006

Hi,

Just another guess
Are you sure you are entering the correct language codes when asked?
The code for Italian is IT-IT (not just IT) and the code for British English it EN-GB (not GB-EN).
It's quite possible that when WF does not recognize the language code, it assumes French - guess what nationality Yves (the author of WF) is

Regards

Marek


Direct link Reply with quote
 

Stephen Rifkind  Identity Verified
Israel
Local time: 13:30
Member (2004)
French to English
+ ...
Same problem Oct 31, 2006

I've had it for months. I have four languages on my language bar, with English first and French second. At random times, the language turns to French. I think there is some preset macro combination to move the language from the first to the second, asidem from Control Shift. I would be interested to know if anybody has heard of one.

Stephen Rifkind


Direct link Reply with quote
 

Dominique Pivard  Identity Verified
Local time: 13:30
Finnish to French
Double-check automatic language detection is disabled Oct 31, 2006

Marie-Helene Hayles wrote:
Interestingly, this has only happened since my computer was upgraded - I'm using XP and Word 2003 Professional, and the WF version is 4.22a AG.

Two questions:

1) what Word-version did you use before upgrading your system? Perhaps Word 97 (which doesn't have the brain-dead automatic language detection "feature")? If so, double-check that automatic language detection is really disabled *before* starting your first translation session in a document.

2) why do you insist on running a version of Wf that is almost 3 years old?


Direct link Reply with quote
 

Marie-Hélène Hayles  Identity Verified
Local time: 12:30
Italian to English
+ ...
TOPIC STARTER
No, they're definitely correct Oct 31, 2006

Marek Buchtel wrote:

Hi,

Just another guess
Are you sure you are entering the correct language codes when asked?
The code for Italian is IT-IT (not just IT) and the code for British English it EN-GB (not GB-EN).
It's quite possible that when WF does not recognize the language code, it assumes French - guess what nationality Yves (the author of WF) is

Regards

Marek


You're absolutely right of course, but even if I didn't quote them right here, when I open the TM in WF the correct codes are already there - it just then goes and changes the target to French.


Direct link Reply with quote
 

Marie-Hélène Hayles  Identity Verified
Local time: 12:30
Italian to English
+ ...
TOPIC STARTER
sorted! Oct 31, 2006

Gerard de Noord wrote:

Open the TMs in Word. Maybe the TUs have the right language coded but the headers haven't.

Workaround: on the Setup/Segments tab you can choose between:
Set target segment language to TM's target language
and
Set target segment language to Word's default language
Maybe you can change this setting.

I'm sure you aren't using Word's automatic language detection.

Regards,
Gerard


Following Gerard's advice, I went into Setup/Segments, but rather than selecting "set target to Word's Default" (my Word defaults to Italian no matter how many times I tell it to use English), I tried "leave unchanged" - and it worked!

Thanks Gerard and everyone else who responded.


Direct link Reply with quote
 

Simon Mountifield  Identity Verified
Local time: 12:30
French to English
Regional and language options Oct 31, 2006

Hi,

I've experienced this problem in the past, and in my case, it had something to do with the Windows language options - on my computer (Windows XP), I had EN and FR for the language settings, and for some reason, Wordfast kept switching to EN (you should see an EN / FR symbol in the System Tray). Another problem is that the keyboard configuration would change (i.e. it would turn my AZERTY into a QWERTY).

My solution was to go to the language options (Control Panel > Regional and Language Options > Language > Details) and then delete the language that I didn't need (in my case, EN), leaving just FR. It was then impossible for Wordfast to switch to anything else, as only FR was defined on my computer. It might be worth a try. You can also take a look at the thread where this problem was discussed - http://www.proz.com/post/180273#180273

Good luck,

Simon

P.S. I've just noticed that you solved the problem before I posted my suggestion - forget everything I said

[Edited at 2006-10-31 08:22]


Direct link Reply with quote
 

Marie-Hélène Hayles  Identity Verified
Local time: 12:30
Italian to English
+ ...
TOPIC STARTER
Thanks Dominique... Oct 31, 2006

Dominique Pivard wrote:


2) why do you insist on running a version of Wf that is almost 3 years old?


Good question, I thought (not that I actually insisted, I just hadn't got round to upgrading it), so downloaded the latest version, wasted an hour trying to get it installed and the old one uninstalled, finally succeeded, only to find

1) that the fix I'd found on my three-year-old version ISN'T THERE on the new one; and

2) that my old licence has expired, all my TMs are way over the trial limit, and I now have to wait 48 hours for my credit card payment to be approved before I can use the new version with my existing TMs.

So to answer your question (too late now though): IF IT AIN'T BROKE, DON'T FIX IT! Grrr.....

(I know it's not your fault really)

[Edited at 2006-10-31 18:39]


Direct link Reply with quote
 

Marie-Hélène Hayles  Identity Verified
Local time: 12:30
Italian to English
+ ...
TOPIC STARTER
Update... Nov 4, 2006

So I've just opened one of the problematic TMs for the first time with the latest version of Wordfast, and it won't let me use them at all - it asks me to re-save it as either UNI-16 or Unicode (it's currently UNI-8), and when I do and then try to run it, WF wipes the whole TM.

As this is a different problem, I'll now have alook and see if anyone else has experenced this and if not I'll open a new thread.

[Edited at 2006-11-04 14:04]


Direct link Reply with quote
 

lestertrad
Local time: 12:30
French to English
+ ...
Check box keeps resetting itself Oct 24, 2012

Dominique Pivard wrote:


2) why do you insist on running a version of Wf that is almost 3 years old?


Nobody asked me, but my reason is that I've just wasted too much time trying new versions and finding that they remove or break functions that I've come to depend on, without any of the changes being documented.

In my case, Autocorrect works when I clear "Set target segment to TM's target language," but every time I clear it it gets set back again.

Version 5.92b (see above)


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Word keeps changing TARGET language to French - sorry, I'm clearly having one of those days!

Advanced search


Translation news related to Wordfast





memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search