Wordfast: Placeable function on Japanese Glossary
Thread poster: Masahiro Imafuji

Masahiro Imafuji  Identity Verified
United States
Local time: 13:41
Member (2007)
English to Japanese
+ ...
Sep 4, 2007

Hi. I am new to the translation world and using Wordfast.

I recently downloaded Wordfast and the placeable function works beautifully when translating English to Japanese but not Japanese to English.

Is this normal or should I do something to use the function?


Thanks,


Hiro


Direct link Reply with quote
 

Yvonne Gerstheimer  Identity Verified
Germany
Local time: 19:41
Member (2007)
Japanese to German
+ ...
I have the same problem Sep 4, 2007

Hello Hiro,

I have the same problem translating Japanese to German texts with Wordfast. Wordfast works beautifully with English to German translations, but somehow it only works half-way in the combination Japanese-German. It does not really find matches or fuzzy matches even if I know that I already have translated exactly the same term, or the program just marks the whole text as recognized.

In my case, it is probably a Mac-problem. The support advised me to install the Office X patch and the multilingual function in the Office program. I did so, but it still does not really work well for me. But I heard that it should work if you are using Windows.

For Japanese-German translations I use OmegaT now, which is a free CAT-Tool. It is not as funky and not as glamourous with lots of funtions as Wordfast or Trados, but is very reliable and easy to understand.

Regards,
Yvonne

[Bearbeitet am 2007-09-04 12:45]


Direct link Reply with quote
 

Masahiro Imafuji  Identity Verified
United States
Local time: 13:41
Member (2007)
English to Japanese
+ ...
TOPIC STARTER
Yeah, it looks like it should work Sep 4, 2007

Hi Yvonne,

Thanks for your reply and tip.

It looks like it should work but it does not .
I should also try to ask the same question in Japanese forum too.


I look into Omega T.

Thanks again!


Hiro


Direct link Reply with quote
 

Yvonne Gerstheimer  Identity Verified
Germany
Local time: 19:41
Member (2007)
Japanese to German
+ ...
You're welcome! Sep 4, 2007



I check the Japanese forum, too, but please let me know if you find out a trick outside the forums!

Thanks!

Yvonne


Direct link Reply with quote
 

Juan Perello  Identity Verified
Chile
Local time: 14:41
Member (2005)
Japanese to Spanish
+ ...
Does the problem appear only with numbers or with terms also? Sep 4, 2007

Hi,

I translate from Japanese into Spanish, so I guess it should be the same as with English. I don't have this problem at all, but I think I have and idea about what might be your problem.

From my experience, it looks like the placeable function for numbers and other symbols (not words) works only when they are written in hankaku characters, and not when they are zenkaku.

So, with string like 123 should work, but with 123, it shouldn't.

So to overcome this, before begining to translate, I run a macro to convert all zenkaku characters into hankaku ones.

If you are also have problems with term recognition, then it looks it would be something else.

I hope it helps.


Direct link Reply with quote
 

David Daduč
Czech Republic
Local time: 19:41
English to Czech
Use PlaceableContains Sep 4, 2007

juanluis wrote:

So, with string like 123 should work, but with 123, it shouldn't.


This is quite right. There is a relatively simple way to customise Wordfast. Pandora's Box or PB (refer to Wordfast's user manual for details if you are not familiar with the concept) has the following command:

PlaceableContains=#@=+/\-

You can customise the list of characters following the first equals sign and, when this is done, Wordfast will treat as a placeable any string containing any of the characters. So you will want to use something like:

PlaceableContains=1234567890

Of course, you can add more special characters in the list if you need. I have just tried this on my system (Windows, Word 2000) and it's working very well.


Direct link Reply with quote
 

Masahiro Imafuji  Identity Verified
United States
Local time: 13:41
Member (2007)
English to Japanese
+ ...
TOPIC STARTER
What about actual words? Sep 4, 2007

Thank you for your advice, guys.

So zenkaku numbers can be fixed by using "PlaceableContains=" and also macro that converts zenkaku to hankaku.

Am I right so far?


What about actual words?

For example, please look at a picture below.
http://www.imafujitranslations.com/example.jpg


I have already registered a world "株式持合い" in a glossary but it is not highlighted. Do I have to convert it to hankaku? If so, can you tell me how I can do that by macro?


Thank you,


Hiro


Direct link Reply with quote
 

Juan Perello  Identity Verified
Chile
Local time: 14:41
Member (2005)
Japanese to Spanish
+ ...
I can't see you example but... Sep 4, 2007

I tried to see your example but I couldn't access the page.

Anyway, if the problem is with actual words, though they may be obvious, I would check a couple of things.

1. The glossary is in Unicode format.
2. You are using the right JP > EN glossary (they are not bidirectional. I think).
3. The path to the folder where the glossary is is not written in Japanese characters, that sometimes may cause trouble.
4. Glossary is active (marked with a check mark, on the terminology tab.)

That's all I can think of for now. Hopefully David has a better idea.

Regards.


Direct link Reply with quote
 

Masahiro Imafuji  Identity Verified
United States
Local time: 13:41
Member (2007)
English to Japanese
+ ...
TOPIC STARTER
humm... Still does not work Sep 4, 2007

Thanks for your advice.


I had already done 4 things that you suggested checking.
However, I checked them again.
They were ok.


So you do not have any problem with translating Japanese to Spanish?

I wonder why Yvonne and I have the same problem.

Is it because I am using a Japanese Windows XP?

Do you guys use Japanese based Windows or computer?

Thanks,


Hiro


Direct link Reply with quote
 

David Daduč
Czech Republic
Local time: 19:41
English to Czech
Language code in TM Sep 4, 2007

An important thing to check is the language code defined in your TM. When translating from Chinese / Japanese / Korean (CJK), this setting is vital because it lets Wordfast know the source language is CJK and makes it operate accordingly.

Open the Wordfast window and see the TM tab. The source language code must be JA-01 for Japanese (the initial "JA" is decisive). When the language code is correctly set, you should see "(CJK)" label next to the file name of the TM. [You should also see "(Unicode)" label there because both your TM and glossaries must be Unicode.]

One more thing to check: go to Tools > Options menu in Word and make sure the "highlights" box is checked on the View tab.


Direct link Reply with quote
 

Juan Perello  Identity Verified
Chile
Local time: 14:41
Member (2005)
Japanese to Spanish
+ ...
Definitely not the Japanese OS. Sep 4, 2007

I also have Windows XP Japanese version, and usually there are no problems.
So I think that is not the problem.
But now that you mention, I remember a couple of months ago I had a glossary that would not work no matter how I tried. It looks it was a case of glossary corruption, because other glossaries were just fine. The file seemed Ok, though.

If David's suggestions didn't work, maybe you could try making another glossary to see if that is the problem, but I hope you don't need to.


Direct link Reply with quote
 

David Daduč
Czech Republic
Local time: 19:41
English to Czech
Wordfast version Sep 5, 2007

There's one more thing: if you have Wordfast version 5.51t3, update Wordfast (download and install a very recent update). Version 5.51t3 was not reliable concerning terminology recognition in CJK mode. I'm sorry I did not remember this yesterday. The latest update fixes the glitch, as mentioned in the version history at Wordfast's website.

Direct link Reply with quote
 

Masahiro Imafuji  Identity Verified
United States
Local time: 13:41
Member (2007)
English to Japanese
+ ...
TOPIC STARTER
Yeah! Sep 5, 2007

Guys,


Thanks so much for helping me out!

Finally it works!


What I did was


1. reinstalled Wordfast.
2. recreated TM and Glossary.


Then Boom!!


It worked!


Thank you so much for your help guys!
I really appreciate it!!

Cheers,

Hiro


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Wordfast: Placeable function on Japanese Glossary

Advanced search


Translation news related to Wordfast





PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search