Linux-Wordfast disk space error
Thread poster: Elliot Everett

Elliot Everett  Identity Verified
Uruguay
Local time: 12:13
Spanish to English
Jun 16, 2010

Hello.

I have been using Linux Mint (Ubuntu) with Wordfast Classic with no issues for several months.

Today, I got a bizarre error about not having enough disk space, even though I have several gigs to spare. I tried saving to different partitions and to pen drives with no luck.

This is the error I got:

Microsoft Word
The disk is full trying to write to Z::. Free some space on the drive, or save the document to another disk.
Try one or more of the following:
* Close unneeded documents
* Save the document on another disk

Any ideas?

Thanks,
Elliot


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 18:13
Member (2006)
English to Russian
+ ...
Why z: drive actually? Jun 17, 2010

It may be some problem with permissions. Where do you store your document(s) and translation memories? I would put them somewhere into ~/Documents.

Direct link Reply with quote
 

Elliot Everett  Identity Verified
Uruguay
Local time: 12:13
Spanish to English
TOPIC STARTER
Nothing has changed Jun 17, 2010

It said drive Z (root) because that was the last thing I tried. I might have a bad sector on the disk.

Thanks!


Direct link Reply with quote
 
opolt  Identity Verified
Germany
Local time: 16:13
English to German
+ ...
Pls check temp and program file location Jun 17, 2010

Elliot,

please check how your emulation software (vmware, wine, crossover, whatever) is configured to store its files. That might be on a partition different from your Linux /home partion, or even from the system's main (i.e. root) partition. Mind you, you have to find out about about the Linux partition. There may be two kinds of files locations involved here: Normal files (the ones which you're working on) and temporary files. Both might be saved on the same Windows "drive", or each on a different "drive". In any case, you have to find out about the Linux partition(s) involved. And you should do so for both your virtual Windows installation and the programs involved, namely Wordfast.

In any case, when you have identified the Linux partitions, try to copy (not move!) files to that partition manually from you file manager and see what happens. If the problem persists, yes, there might be a permissions problem. Personally I don't think your hard disk is failing, but be sure to do a backup of your files NOW to be on the safe side!

Good luck and please tell us what you have found out.


Direct link Reply with quote
 

Elliot Everett  Identity Verified
Uruguay
Local time: 12:13
Spanish to English
TOPIC STARTER
Temp and program files under /home Jun 17, 2010

I did some digging and found that the program and temp files for MS Word are under /home/me/.cxoffice (I use CrossOver). The CrossOver program itself is under /opt.

Since I had unsuccessfully tried to save to my pen drive, it can't be a bad hard disk problem.

Perhaps the Word file is corrupt. The program crashed and I had to redo my edits. The TM is missing some parts too, so I had to do that part over again.

Such is life.

Thanks for the help!


Direct link Reply with quote
 
opolt  Identity Verified
Germany
Local time: 16:13
English to German
+ ...
Is Z your pen drive then? Jun 17, 2010

I haven't used Windows in ages that's why I'm asking whether Z is your pen drive. If so, it might explain the error. This type of storage has a limited number of cycles -- though it really shouldn't break in normal everyday use. Luckily USB sticks can easily be swapped.

So what happens if you save to your hard disk somewhere under /home? Does the problem go away?

What does your system monitor (found somewhere under the Preferences or Administration menu) show how much space of your home directory is being used? Or, open a terminal, simply type "df -h". In the output, you can find "/home" in the right column, and also the USB stick should be listed somewhere as "/media/XXXX" -- as long as it's plugged in of course.

Finally, your USB stick's partition contains a VFAT file system in all likelyhood (most people using Linux do so for compatibility reasons). However, VFAT is very messy and prone to all kinds of ugly things, so no big surprise here if it behaves in an unruly way.

Cheers, y buena suerte.




[Edited at 2010-06-17 15:22 GMT]


Direct link Reply with quote
 

Elliot Everett  Identity Verified
Uruguay
Local time: 12:13
Spanish to English
TOPIC STARTER
Thanks but I had already tried these workarounds Jun 17, 2010

There is no problem with permissions, lack of space, etc. I already tried various pen drives, partitions, etc. The problem seems to be a corrupt .doc file.

¡Gracias y saludos!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:

Moderator(s) of this forum
Prachya Mruetusatorn[Call to this topic]

You can also contact site staff by submitting a support request »

Linux-Wordfast disk space error

Advanced search






memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search