Java Heap space
Thread poster: Odette Grille

Odette Grille  Identity Verified
Canada
Local time: 01:35
English to French
+ ...
Nov 8, 2012

Hi,

I translated a PDF with Wordfast, but I can only get a word preview. When I want to save translated file (as PDF), a pop-up tells me : Error while saving file. Java heap space.


My client will take the word format, but just to know ... If someone would care to spare the time to explain what went wrong or what I should do to get my translation in the same format as source.
I did it before with other PDFs. It is the first time I receive this message.

Thanks
Ode


Direct link Reply with quote
 

Iza Szczypka  Identity Verified
Spain
Local time: 07:35
English to Polish
+ ...
Same problem recently Nov 8, 2012

And also with PDF as the source format.
I tried the same with the graphics-rich RTF created by WF Pro from the same PDF, and the problem persists.
No problem when the source is a (non-grahical) .doc / .docx - the 'Save the translated file' function works OK with that.

[Edited at 2012-11-08 13:58 GMT]


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 08:35
English to Arabic
Memory Preferences Nov 8, 2012

Dear Odette,

Please go to Edit > Preferences > Memory Preferences and raise it to the highest value. Restart WFP and make sure the option you selected remains. Now, try to Save Translated File.

I hope this helps. Please let me know.

Note: Only if the option moved back to the default value, please refer to this:
http://wordfast.net/wiki/Not_able_to...#Change_Memory_Preferences

Kind regards,
Yasmin


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 08:35
English to Arabic
RTF vs DOC(X) Nov 8, 2012

Iza Szczypka wrote:

And also with PDF as the source format.
I tried the same with the graphics-rich RTF created by WF Pro from the same PDF, and the problem persists.
No problem when the source is a (non-grahical) .doc / .docx - the 'Save the translated file' function works OK with that.


Thanks Iza!

One can derive a tip from your observation. As WFP generates an RTF file from a PDF, one can save the generated RTF as DOC or DOCX in MS Word which will decrease the file size. Then, one can open this *.doc(x) file in WF Pro and pre-translate it using the toolbar button "Translate All".

This might help in some cases. Again, the Memory Preferences change I described above should help in most cases.

Kind regards,
Yasmin


Direct link Reply with quote
 

Odette Grille  Identity Verified
Canada
Local time: 01:35
English to French
+ ...
TOPIC STARTER
Restart WFP Nov 8, 2012

Yasmin Moslem wrote:

Dear Odette,

Please go to Edit > Preferences > Memory Preferences and raise it to the highest value. Restart WFP and make sure the option you selected remains. Now, try to Save Translated File.

I hope this helps. Please let me know.

Note: Only if the option moved back to the default value, please refer to this:
http://wordfast.net/wiki/Not_able_to...#Change_Memory_Preferences

Kind regards,
Yasmin


Thank you for prompt answer Yasmin.
I closed WFP after moving to highest Memory value and now I cannot open it again. Message says : "Could not create the Java Virtual Machine.

Oooo

[Edited at 2012-11-08 15:22 GMT]


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 08:35
English to Arabic
Wordfast.ini Nov 8, 2012

Dear Odette,

Please adjust the Wordfast.ini manually. If you have installed Wordfast Pro onto the C: partition, it should be at: C:\Program Files\Wordfast\Wordfast.ini

You should have the default value: -Xmx256m

Change the value -Xmx1470m to be: -Xmx1024m


I hope this helps. Please let me know.


Direct link Reply with quote
 

Odette Grille  Identity Verified
Canada
Local time: 01:35
English to French
+ ...
TOPIC STARTER
ini worked Nov 8, 2012

Thank you Yasmin, I did the .ini thing and it worked like a miracle ...

Direct link Reply with quote
 

Odette Grille  Identity Verified
Canada
Local time: 01:35
English to French
+ ...
TOPIC STARTER
RTF to DOC Nov 8, 2012

Thanks Iza!

One can derive a tip from your observation. As WFP generates an RTF file from a PDF, one can save the generated RTF as DOC or DOCX in MS Word which will decrease the file size. Then, one can open this *.doc(x) file in WF Pro and pre-translate it using the toolbar button "Translate All".

This might help in some cases. Again, the Memory Preferences change I described above should help in most cases.

Kind regards,
Yasmin
[/quote]

I tried out of curiosity but I have no option for .doc when I want to save the RTF


Direct link Reply with quote
 

Yasmin Moslem  Identity Verified
Egypt
Local time: 08:35
English to Arabic
"Save as" in MS Word Nov 8, 2012

Odette Grille wrote:

I tried out of curiosity but I have no option for .doc when I want to save the RTF


As I said, this is in MS Word (not in WFP). You can save any RTF as DOC or DOCX, and then open it in WFP to generate a new TXML file.

I hope this helps. Please let me know.

Kind regards,
Yasmin


Direct link Reply with quote
 

Odette Grille  Identity Verified
Canada
Local time: 01:35
English to French
+ ...
TOPIC STARTER
Ouh là là Nov 9, 2012

I did find the .doc extension and saved the rtf document as word.doc.
Then, I tried to load the word doc into Wordfast and panick struck.

Wordfast ran and ran. Then as I touched the mouse to move the WsP page, many blank wsp pages opened. Ctrl+ escape worked only after many trials. And then while computer was closing (or trying to) different pop-ups appeared one after the other with error messsages about applications that could not close (some YSAAgent among them), but they did close eventually.
I figured I'd better let the computer and myself rest.
And I have not tried again this morning.
I will, later, when I have no work in progress.

Thank you for all your help
Ode


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Java Heap space

Advanced search


Translation news related to Wordfast





Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search